Author Topic: Getting the Keyboard app back  (Read 757 times)

Isurus65

  • Newbie
  • *
  • Posts: 19
    • View Profile
    • http://
Getting the Keyboard app back
« on: December 18, 2019, 06:59:49 pm »
I unwittingly toggled the option in the Planet Keyboard not to show on the launcher, mistakenly thinking that it would just disappear from the App Bar. Now it remains on the App Bar but has disappeared from my Apps drawer, and clicking on the Keyboard icon on the App Bar now does nothing. I tried resetting all Planet settings and also cleared the cache/storage of the app from the Settings menu but that did nothing.

Does anyone know how to get the app back?
Previous PDA's: Toshiba e740; Toshiba e755; Psion 3c; Psion 5; HP Jornada 680; HP Jornada 720; Palm Tungsten T3; Palm LifeDrive; Nokia E90 ; Gemini PDA

Daniel W

  • Sr. Member
  • ****
  • Posts: 305
    • View Profile
Getting the Keyboard app back
« Reply #1 on: December 18, 2019, 08:03:10 pm »
Quote from: Isurus65
Does anyone know how to get the app back?
One way might be to open the Google Play app and search for "Gemini keyboard". For apps that are already installed and up to date, Google Play tends to show an "open" button, which should launch the app. Once in the app, you should be able to turn the "show app icon" back on.

Edit: No that won't work... As Isurus65 points out below, there is no Cosmo version of the keyboard settings app on Google Play yet, and even if there was, once I turned off "show app icon" for the keyboard settings app on my Gemini (to properly replicate the issue at hand), it turned out the "Open" button vanished from Google Play.
« Last Edit: December 19, 2019, 07:30:07 am by Daniel W »

ianisthewalrus

  • Newbie
  • *
  • Posts: 49
    • View Profile
Getting the Keyboard app back
« Reply #2 on: December 18, 2019, 11:41:57 pm »
maybe try settings ->cosmo settings -> reset to default. i would test it, but i dont want to get stuck too.

Isurus65

  • Newbie
  • *
  • Posts: 19
    • View Profile
    • http://
Getting the Keyboard app back
« Reply #3 on: December 19, 2019, 01:05:33 am »
Many thanks to both for your suggestions. I have already tried both to no avail.

The Planet Keyboard app is not in Google Play. The app still appears in the Settings-Apps list, but the only options are to disable and force-close.

I had also previously tried the "restore to default", but it did not work. Strangely, going back to the menu again, I cannot toggle that option anymore.

Maybe when Linux comes around eventually, I will do a factory reset and hopefully see it back.

[Edit]: The app name in Cosmo is "Planet Keyboard". I also searched for "Gemini Keyboard" in Play Store which turns up, but it says it is already installed, and there is no "Open" button (there is no button at all). Disabling the "Planet Keyboard" app in the Cosmo causes the "Gemini Keyboard" to display the "Enable" button. So it is actually the same app, but it gets me no further.
« Last Edit: December 19, 2019, 01:12:18 am by Isurus65 »
Previous PDA's: Toshiba e740; Toshiba e755; Psion 3c; Psion 5; HP Jornada 680; HP Jornada 720; Palm Tungsten T3; Palm LifeDrive; Nokia E90 ; Gemini PDA

Daniel W

  • Sr. Member
  • ****
  • Posts: 305
    • View Profile
Getting the Keyboard app back
« Reply #4 on: December 19, 2019, 05:40:29 am »
Sorry for mixing the names of the keyboards up - I was testing on a Gemini (and I was in a bit of a hurry).

Anyway... on my Gemini, I can do this:
Settings > System > Language&Input > Virtual Keyboard > Gemini Keyboard > Advanced > Show App Icon

I presume yours will say Planet Keyboard instead, but the idea should be the same.
« Last Edit: December 19, 2019, 07:33:09 am by Daniel W »

vldmr

  • Jr. Member
  • **
  • Posts: 96
    • View Profile
Getting the Keyboard app back
« Reply #5 on: December 19, 2019, 09:11:51 am »
I think you get keyboard app launched when you open it from Virtual keyboard settings.

At one point while fiddling with adding new keyboard layout I issued command to uninstall planet keyboard from adb as documented here. After that I was only able to restore it by installing gemini keyboard from play store.

Finally, if it shows as installed but not in your launcher - I'd think its launcher problem. Did you try to use different launcher? I'd say T-UI would launch you anything you have installed. Also you could try if you could add the app to the planet app bar

Isurus65

  • Newbie
  • *
  • Posts: 19
    • View Profile
    • http://
Getting the Keyboard app back
« Reply #6 on: December 19, 2019, 10:22:57 am »
Many thanks for the advice. Yes, I now see that I am able to access the same keyboard options from the Virtual keyboard menu (axcept to show the app icon again) - which is quite counterintuitive since the options are for the physical keyboard. But it works, and that is good enough for me. Many thanks again.
Previous PDA's: Toshiba e740; Toshiba e755; Psion 3c; Psion 5; HP Jornada 680; HP Jornada 720; Palm Tungsten T3; Palm LifeDrive; Nokia E90 ; Gemini PDA

PNuT

  • Newbie
  • *
  • Posts: 45
    • View Profile
Getting the Keyboard app back
« Reply #7 on: December 19, 2019, 11:55:46 am »
Quote from: Daniel W
Sorry for mixing the names of the keyboards up - I was testing on a Gemini (and I was in a bit of a hurry).

Anyway... on my Gemini, I can do this:
Settings > System > Language&Input > Virtual Keyboard > Gemini Keyboard > Advanced > Show App Icon

I presume yours will say Planet Keyboard instead, but the idea should be the same.

I just listed packages via adb & it is listed as gemini.keyboard so I assume it is the same one!