Author Topic: To Adam Boardman : Phone dialer not working ( SOLVED )  (Read 335 times)

cam1965

  • Sr. Member
  • ****
  • Posts: 331
    • View Profile
    • http://
To Adam Boardman : Phone dialer not working ( SOLVED )
« on: June 16, 2021, 01:19:29 pm »
Hi.
After a long time without using gemini, I decided to reinstall linux on it.
But dialer-app is not working. No sound on voice calls. It rings and I can answer a call with the silver button. But only this. No sound on conversations.
I remember in the past ( DEBIAN TP first version ) it was working.
I think the problem is /data/system.img.
I have downloaded the previous first version and extracted the system.img  to /data/
So as described in the old wiki ( not available now ).
But from memory:
wget https://gemian.thinkglobally.org/system.img.delta
sudo apt-get install xdelta3
xdelta3 -d -s /data/system.img system.img.delta system.img
sudo cp system.img /data/system.img

The problem is that the file from wget https://gemian.thinkglobally.org/system.img.delta is wrong or it is not working correctly.
The system.img from first version seems to be correct
So I can't do this test.
Please if someone has this file , let me know.
When I did the command  xdelta3 -d -s /data/system.img system.img.delta system.img I got an error
xelta3: not a VCDIFF input : XD3_INVALID_INPUT

Thank you.

EDIT : SOLVED.

I saw this :

https://github.com/gemian/gemini-keyboard-apps/wiki/UpdateAndroidSystemLXCImage

So I downloaded the firmware image  of KALI linux ( from  Planet site ) and discovered that the md5sum of the correct system.img is the same of the link above  ( New md5 output after update: 1b6f07d345cbb9fadca562e788375515 ).

So I have extracted  kali.zip  and mounted linux.img .
First  I made a backup of system.img . ( cp /data/system.img to somewhere )
Then I removed the system.img from /data.
I copied the system.img (from kali ) to /data.
I did a Reboot.
But the phone didn´t work and neither the camera-app.
So, I copied the backup of  system.img to /data ( overwriting the system.img from kali ).
I rebooted linux again.
And for my surprise the phone was working . The camera-app too ( of course ).
I really don´t know. Maybe when booting with  kali system.img in /data some configuration was changed in debian.
The most important is that now everything is working.
« Last Edit: June 19, 2021, 06:58:45 am by cam1965 »

jakfish

  • Sr. Member
  • ****
  • Posts: 356
    • View Profile
Re: To Adam Boardman : Phone dialer not working ( SOLVED )
« Reply #1 on: June 20, 2021, 09:34:34 pm »
That's amazing. I would've thought the two OSs would be completely different, no shared files.

And it's so strange the Kali system.img sort-of worked but the the recopy of the original system.img brought back the calling, etc.

So to clarify: you're running Debian Stretch (9) with all phone capability?

Well done,
Jake

cam1965

  • Sr. Member
  • ****
  • Posts: 331
    • View Profile
    • http://
Re: To Adam Boardman : Phone dialer not working ( SOLVED )
« Reply #2 on: June 21, 2021, 07:20:20 am »
That's amazing. I would've thought the two OSs would be completely different, no shared files.

And it's so strange the Kali system.img sort-of worked but the the recopy of the original system.img brought back the calling, etc.

So to clarify: you're running Debian Stretch (9) with all phone capability?

Well done,
Jake

Yes, phone capabilities are working.
You have to wait a little after the login. You can run dialer-app to see if the operator is reconized. It takes about a minute.
For data, you have to enable Mobile Data in the Mobile tab from cmst. And run in /usr/share/ofono/scripts :  ./activate-context 1 ( in my case 1 is the internet profile ). You  must  have ofono-scripts installed.
Please, upgrade the kernel and kernel-headers and you can see  that  most of the modules are pre compiled . I think you can use your dongle usb modem and  your wifi external adapter too.( please use the left port usb, because some devices only work in this port). My tv dongle works in both usb  ports but my external web camera only in the left port with guvcview and vlc . In the right usb port only with xawtv . I think I deleted my configuration files in the past because of this. When you upgrade the kernel, remember to do this command  as below:
 dd if=/usr/share/kernel/linux-bot.img of=/dev/disk/by-partlabel/(your boot partition, in my case boot2).
I am using dual boot:  android 7 (rooted )  and debian. Also twrp installed.  Android 8 has some problems described in this forum and confirmed by me.
Note : when I copied system.img I didn´t use sudo or root permissions to copy to and from /data.
First I have copied the system.img from the kali mounted image ( in my PC ) to an external sd card. Then copied the system.img ( from sd card ) to gemini home directory.
Good Luck !
« Last Edit: June 21, 2021, 08:28:23 am by cam1965 »

jakfish

  • Sr. Member
  • ****
  • Posts: 356
    • View Profile
Re: To Adam Boardman : Phone dialer not working ( SOLVED )
« Reply #3 on: June 21, 2021, 08:50:59 am »
Great work. Congratulations.

I'm a big fan of Stretch on the Gemini. I have my install working about as well as it can, all key-stroked, no mouse needed.

Jake

cam1965

  • Sr. Member
  • ****
  • Posts: 331
    • View Profile
    • http://
Re: To Adam Boardman : Phone dialer not working ( SOLVED )
« Reply #4 on: June 21, 2021, 09:44:51 am »
Great work. Congratulations.

I'm a big fan of Stretch on the Gemini. I have my install working about as well as it can, all key-stroked, no mouse needed.

Jake
👍

Yes, it is really very good.