Author Topic: Gemian-planet Thinkglobally buster repository down error  (Read 773 times)

wintergreen

  • Newbie
  • *
  • Posts: 3
    • View Profile
Gemian-planet Thinkglobally buster repository down error
« on: June 11, 2022, 07:13:57 am »
Hi,

I'm installed v4 of Gemian for the Cosmo Communicator. When I do an apt update it says gemian-planet.thinkglobally.org:443 connection timed out.

Is the repository down?

What should I do? Is there a mirror anywhere?

Thanks,

Shaun.
« Last Edit: June 11, 2022, 07:31:32 am by wintergreen »

Dom (shymega)

  • Newbie
  • *
  • Posts: 39
    • View Profile
Re: Gemian-planet Thinkglobally buster repository down error
« Reply #1 on: June 11, 2022, 04:18:27 pm »
The build server is currently offline and will be a few weeks until it's ready again. I had confirmation of this during a call...

zcfrank1st

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Gemian-planet Thinkglobally buster repository down error
« Reply #2 on: September 05, 2022, 10:47:03 pm »
When online again? :'(

Dom (shymega)

  • Newbie
  • *
  • Posts: 39
    • View Profile
Re: Gemian-planet Thinkglobally buster repository down error
« Reply #3 on: September 06, 2022, 12:51:18 pm »
I do not know. I've lost contact with Planet right now, but last time I heard the build server still isn't working.

DanskFantom

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Gemian-planet Thinkglobally buster repository down error
« Reply #4 on: September 14, 2022, 12:35:19 am »
If you are looking to update to install apps, then I have a workaround (see below).
Currently upgrading breaks the installation, which appears to be due to critical gemian apps being downgraded with update.
Working out which Gemian packages to hold prior to an upgrade is on my to do list.

UPDATE: See comment from Shymega below - he is concerned about the risks of this approach, which is understandable.  Note: this is currently the only way to install apps.  I recommend only installing apps that you know are going to be ok with this install method (see my install guide) or only installing apps on a Cosmo that you don't mind re-formatting if things going wrong. 
I recommend uncommenting the line again afterwards to avoid accidentally upgrading anything (which WILL break your installation).



See my linux installation guide for the Communicator:
https://www.oesf.org/forum/index.php?topic=36822.msg298717#msg298717
----
#REPOSITORIES
#unfortunately deb https://gemian-planet.thinkglobally.org/buster/ buster main has been taken down by Planet, so we need to comment it out in the sources list.
#vi can be flaky and we can't install vim yet, so use nano to edit the file
Code: [Select]
sudo nano /etc/apt/sources.list.d/gemian.list
#comment out the currently offline old V3 firmware planet repository
Code: [Select]
deb https://gemian.thinkglobally.org/buster/ buster main
#deb https://gemian-planet.thinkglobally.org/buster/ buster main
#save the file and exit

Code: [Select]
sudo apt update#when asked about accepting that the repository has changed from stable to oldstable, select 'yes'
# IMPORTANT: DO NOT RUN sudo atp upgrade AT ANY TIME - THIS WILL BREAK THE INSTALLATION
« Last Edit: September 16, 2022, 02:22:35 am by DanskFantom »

Varti

  • Administrator
  • Hero Member
  • *****
  • Posts: 1240
    • View Profile
Re: Gemian-planet Thinkglobally buster repository down error
« Reply #5 on: September 14, 2022, 06:49:53 am »
Thanks for this tutorial, I hope the build server will be eventually put back online. I have fixed a couple of URLs in your post (https:/ -> https://).

Varti
Planet Gemini PDA WiFi/LTE with Mediatek x27
SL-C1000 running Arch Linux ARM May2017, K30225 Wi-Fi CF Card, 64GB SDXC card
and many other Zauruses!

Dom (shymega)

  • Newbie
  • *
  • Posts: 39
    • View Profile
Re: Gemian-planet Thinkglobally buster repository down error
« Reply #6 on: September 15, 2022, 02:55:39 pm »
Do not follow these instructions. It's too big of a risk, and downgrading v4 Gemian WILL brick your device. The server should be back up soon, but Planet is very busy. Believe me, as a dev, we're not in the best position either. Kindly avoid downgrading v4 to v3, it uses a whole different foundation for the distro.

DanskFantom

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Gemian-planet Thinkglobally buster repository down error
« Reply #7 on: September 16, 2022, 02:20:12 am »
Do not follow these instructions. It's too big of a risk, and downgrading v4 Gemian WILL brick your device. The server should be back up soon, but Planet is very busy. Believe me, as a dev, we're not in the best position either. Kindly avoid downgrading v4 to v3, it uses a whole different foundation for the distro.

Thanks Shymega,

That's really useful info.  I've updated the instructions to include your concerns and to recommend uncommenting the rep again after an installation to avoid accidentally upgrading.

I'm not removing the instructions as obviously there is no timescale for the reps being back up and this is the only way to install Linux or apps at present, and for all we know the rep may be down for another year (or if we are very unlucky, forever).  I've installed the apps in my list without issues so I think the advice works, but thanks for clarifying the risks.