Author Topic: backspace key removes two characters  (Read 2359 times)

norwin

  • Newbie
  • *
  • Posts: 3
    • View Profile
backspace key removes two characters
« on: April 14, 2023, 02:59:13 am »
my device behaves strange: in two apps (telegram and anWriter pro) the backspace key of the physical keyboard always removes the last two characters.
in all other apps it removes one.
any idea?

jakfish

  • Sr. Member
  • ****
  • Posts: 392
    • View Profile
Re: backspace key removes two characters
« Reply #1 on: April 15, 2023, 09:37:55 am »
Though I don't own an Astro, I've had the Gemini/Cosmo, and I found a similar problem in TextMaker. I posted in their forum but didn't find a solution until I simply reprogrammed (in TextMaker only) the problematic keys.

If you can't reprogram the keys--say, Ctrl+BackSpace = BackSpace--within the actual programs, you could try a kb remapper from the Playstore. If you've rooted your machine, then you may be able to edit the key map yourself.

This is assuming that your Astro doesn't have a hardware malfunction.

Jake


Zarhan

  • Sr. Member
  • ****
  • Posts: 367
    • View Profile
Re: backspace key removes two characters
« Reply #2 on: April 15, 2023, 10:20:38 am »
One thing to check: Do the two character removals happen at once, or does first character get removed when you press the backspace *down* and then the second character gets removed when you lift your finger and the key comes up?

ZimbiX

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
    • https://twitter.com/ZimbiX
Re: backspace key removes two characters
« Reply #3 on: April 15, 2023, 10:59:45 am »
I've just tried in Telegram, and can't reproduce this problem! 😕 Any ideas what might be different about your setup?

What software keyboard are you using? That seems to have an effect on physical keyboard input somehow, e.g., sometimes while my selected software keyboard is Swype (installed from an old APK, given it's not on the Play Store anymore), using the Shift key on the physical keyboard strangely does not capitalise (I haven't yet worked out how to consistently reproduce this). When I disable Swype, it comes good.

I've tried to reproduce your issue with and without Planet Keyboard being the only enabled keyboard (Settings -> System -> Languages and input -> On-screen keyboard -> Manage on-screen keyboards). In case it makes a difference, I'm using the 'English (US), Gemini keyboard' layout setting (Settings -> System -> Languages and input -> Physical keyboard -> Integrated keyboard) - though I think that might have been selected via the 'Planet Keyboard' app's wizard.

norwin

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: backspace key removes two characters
« Reply #4 on: April 16, 2023, 03:53:11 am »
"One thing to check: Do the two character removals happen at once"?
--> they do. releasing the key does nothing.

"What software keyboard are you using"
-->i didn't change anything on the standard configuration, thus planet keyboard.

changes in the keyboard settings don't have an effect on this behaviour.

KMM

  • Newbie
  • *
  • Posts: 29
    • View Profile
Re: backspace key removes two characters
« Reply #5 on: April 30, 2023, 04:37:25 pm »
I'm having the same problem, but only when using MS Word.

Dom (shymega)

  • Full Member
  • ***
  • Posts: 100
    • View Profile
Re: backspace key removes two characters
« Reply #6 on: May 03, 2023, 07:09:52 pm »
I can't help but wonder if this is related to the keyboard driver. However, if the bug isn't present on some Astros, this is more indicative of a hardware fault.