Author Topic: libgcc_s.so.1 for libc 2.2.2?  (Read 1393 times)

vinc17

  • Newbie
  • *
  • Posts: 38
    • View Profile
    • http://www.vinc17.org/
libgcc_s.so.1 for libc 2.2.2?
« on: August 29, 2004, 06:51:14 pm »
Where can I find a libgcc_s.so.1 compatible with the libc 2.2.2 that is in the original Sharp ROM of the SL-C860?

The http://sgp.zaurii.net/binaries/libgcc_s.so.1 I've found in the archives of these forums can't be used as it requires libc 2.2.4.

Thanks in advance.
SL-C860 with Sharp ROM 1.40 JP, WLI2-CF-S11 wireless LAN, CF-10T LAN, 1GB Sandisk SD, 128MB PQI CF.

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
libgcc_s.so.1 for libc 2.2.2?
« Reply #1 on: August 30, 2004, 06:35:56 am »
The cacko ROM is the only other one out there with such an old version of libc (the one on my web site came from pdaXrom I assume looking at the version of libc).

I don't even know whether there's a toolchain for cacko, but if there is, that's where you want to look (or you want to ask someone with it).


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

vinc17

  • Newbie
  • *
  • Posts: 38
    • View Profile
    • http://www.vinc17.org/
libgcc_s.so.1 for libc 2.2.2?
« Reply #2 on: August 30, 2004, 09:16:11 am »
No, I couldn't see libgcc_s.so.1 on the pdaXrom site.
SL-C860 with Sharp ROM 1.40 JP, WLI2-CF-S11 wireless LAN, CF-10T LAN, 1GB Sandisk SD, 128MB PQI CF.

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
libgcc_s.so.1 for libc 2.2.2?
« Reply #3 on: August 30, 2004, 11:06:59 am »
The one on my site was taken from the pdaXrom toolchain (assuming the libc versions are correct).


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

vinc17

  • Newbie
  • *
  • Posts: 38
    • View Profile
    • http://www.vinc17.org/
libgcc_s.so.1 for libc 2.2.2?
« Reply #4 on: August 30, 2004, 12:19:20 pm »
I've just tried, and it also needs libc 2.2.4.
SL-C860 with Sharp ROM 1.40 JP, WLI2-CF-S11 wireless LAN, CF-10T LAN, 1GB Sandisk SD, 128MB PQI CF.

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
libgcc_s.so.1 for libc 2.2.2?
« Reply #5 on: August 31, 2004, 10:04:28 am »
Yes, that's what I was trying to get at; you need to grab the libgcc_s from the cacko toolchain (assuming there is one available somewhere) as that should be the right version of libc.
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva