Author Topic: 6000 boot init error, shared library, help!!  (Read 2544 times)

mobilerex

  • Newbie
  • *
  • Posts: 5
    • View Profile
6000 boot init error, shared library, help!!
« on: September 02, 2004, 01:05:11 am »
Hi,

I have a 6000, and for some reason I simply cannot fathom, when I turn it on I get

" init: error cannot find libc.so.6" and it sits there, needing a reset.  

Now, this raises many questions, especially why init needs a shared library, but what I really need to know is how to recover from this. I have tried installing a new kernel that drops to the command line, but it still stops on the above error.

Is there a way of interrupting the boot process? Or perhaps booting off another partition (I have an SD card).

I am pretty desparate as I have only had this for a few weeks, and I have trolled many newsgroups , so any help would be appreciated.

 Regards.

  MR

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
6000 boot init error, shared library, help!!
« Reply #1 on: September 02, 2004, 12:34:28 pm »
Everything is linked against libc.

You have a problem. Have you been deleting symlinks in /lib (if this is even possible with your ROM)?

Not sure what you can do now, but someone posted a while back about recovering from trying to upgrade libc (and failing).

Have a search (or hope they stumble onto your post).


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

pirlouit

  • Newbie
  • *
  • Posts: 10
    • View Profile
6000 boot init error, shared library, help!!
« Reply #2 on: September 02, 2004, 07:32:57 pm »
Quote
Hi,

I have a 6000, and for some reason I simply cannot fathom, when I turn it on I get

" init: error cannot find libc.so.6" and it sits there, needing a reset.  

Now, this raises many questions, especially why init needs a shared library, but what I really need to know is how to recover from this. I have tried installing a new kernel that drops to the command line, but it still stops on the above error.

Is there a way of interrupting the boot process? Or perhaps booting off another partition (I have an SD card).

I am pretty desparate as I have only had this for a few weeks, and I have trolled many newsgroups , so any help would be appreciated.

 Regards.

  MR
# ls -la /sbin/init
lrwxrwxrwx    1 root     root            7 Feb 17  2004 /sbin/init -> telinit
#

 /home/zaurus/ldd /sbin/telinit
  libc.so.6 => /lib/libc.so.6 (0x40022000)
  /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
#

my /lib is mounted read-only; What did you do to hork your /lib directory ?

Have you tried a full reset ? Maybe your internal memory is corrupt somehow (but i doubt it).

p
P.S:
I only have had my Sl-6000 for a couple days..so i'm not that much knowledgeable yet.

mobilerex

  • Newbie
  • *
  • Posts: 5
    • View Profile
6000 boot init error, shared library, help!!
« Reply #3 on: September 03, 2004, 08:30:15 am »
Hi,

Well I fixed my problem, but I am still not sure how it got that way. I grabbed the Sharp 6000 default ROM and reflashed it. I restored a recent backup , and all is back to normal.

Oh, the name of the ROM bundle is: 20040217SL6V112.zip

in case you need to search for it.

Any thoughts on this and how it occured , would be useful for general knowledge.

Regards

MR

cvmiller

  • Full Member
  • ***
  • Posts: 242
    • View Profile
    • http://
6000 boot init error, shared library, help!!
« Reply #4 on: September 03, 2004, 12:01:14 pm »
Quote
Hi,

Well I fixed my problem, but I am still not sure how it got that way.

Any thoughts on this and how it occured , would be useful for general knowledge.
MR,

I have had my SL-6000 since April, and I haven't managed to lose my Libc.

I did run into a problem with libraries after setting up the Zaurus compiler (with dev-img1.5), where some libraries were pointed to the dev-img rather than the /home/QtPalmtop/lib. But that was fixed by re-sym-linking a couple of files.

I don't reboot my Zaurus all that much, and perhaps I would have run into more problems had I rebooted. There really are very few reasons to reboot the Zaurus.

I hope this helps,

Craig...
SL-6000
ROM v1.12 (Sharp)
Belkin F8U1500 IR Keyboard
1 GB SD Card by SanDisk (ext2)

mobilerex

  • Newbie
  • *
  • Posts: 5
    • View Profile
6000 boot init error, shared library, help!!
« Reply #5 on: September 08, 2004, 07:17:49 am »
Hi,

As a postscript, I suppose what I learned is to RESET not unplug the power. Yes, in case you are all wondering, I have had DELL laptops that have required such remedies, and it was force of habit.

Somewhat distrubing that many computers no longer have a hard OFF switch...

MR

icecure

  • Newbie
  • *
  • Posts: 8
    • View Profile
6000 boot init error, shared library, help!!
« Reply #6 on: September 08, 2004, 09:46:14 pm »
Hmm some software might mess up things.


Anyway if some one knows a linux distro work fine on the 6000 just let me know, until OZ gets out for the 6000.