Author Topic: When New OZ is going tobe relized  (Read 1973 times)

Yasen

  • Full Member
  • ***
  • Posts: 107
    • View Profile
    • http://
When New OZ is going tobe relized
« on: November 05, 2004, 04:54:51 am »
Will there be changes in CF drivers. I'm interesed in Orinoco drivers. This from 3.5.1 don't work with my Trendnet card.
[span style=\'font-size:8pt;line-height:100%\']SL-5600 PXA-250
noname 256 MB MMC fat,
SanDisk 1GB  CF vfat
[/span]

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
When New OZ is going tobe relized
« Reply #1 on: November 05, 2004, 06:32:20 am »
No changes to orinoco are planned - it works perfectly here. Any more concrete failure descriptions?

cardctl ident ?
lsmod ?
dmesg ?
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

Yasen

  • Full Member
  • ***
  • Posts: 107
    • View Profile
    • http://
When New OZ is going tobe relized
« Reply #2 on: November 05, 2004, 10:46:50 am »
Here, here and here what I have for Sharp ROM. Might be useful. There was a ticket on http://bugs.openembedded.org/ but I cant log in there now and can't find it. It was with number between 63-68 cant remember exactly. In the caption there is  "TEW-222CF". In adition to the ticket I can add than it hangs not on inset but on iniciating the card. In the ticket  I think there is all three which you are asking for. Right nnow I'm wit Sharp ROM but will flash OZ for testing and debuging.
[span style=\'font-size:8pt;line-height:100%\']SL-5600 PXA-250
noname 256 MB MMC fat,
SanDisk 1GB  CF vfat
[/span]

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
When New OZ is going tobe relized
« Reply #3 on: November 05, 2004, 10:53:37 am »
Looks like a prism card which should be in hostap.conf, not in hermes.conf. Add it to hostap.conf and remove it from hermes.conf. Then restart pcmcia and reinsert your card. If that doesn't work, I need the lsmod and dmesg from OZ running, the ones from SharpROM don't help.
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

Yasen

  • Full Member
  • ***
  • Posts: 107
    • View Profile
    • http://
When New OZ is going tobe relized
« Reply #4 on: November 05, 2004, 10:59:18 am »
Yes it's Prism2
Those on http://bugs.openembedded.org/ I think are from OZ. Flashing now and do them again. And try to modify *.conf files
« Last Edit: November 05, 2004, 11:03:28 am by Yasen »
[span style=\'font-size:8pt;line-height:100%\']SL-5600 PXA-250
noname 256 MB MMC fat,
SanDisk 1GB  CF vfat
[/span]

Yasen

  • Full Member
  • ***
  • Posts: 107
    • View Profile
    • http://
When New OZ is going tobe relized
« Reply #5 on: November 05, 2004, 11:44:17 am »
Excuse my ignorance but I'm not sure what should I do with thi conf files.
Should I move
Code: [Select]
card "Orinoco or Intersil Prism 2 Wireless"
  manfid 0x0156, 0x0002
  bind "orinoco_cs"
or I should do something other.
Sory but I'm n00b
[span style=\'font-size:8pt;line-height:100%\']SL-5600 PXA-250
noname 256 MB MMC fat,
SanDisk 1GB  CF vfat
[/span]

Yasen

  • Full Member
  • ***
  • Posts: 107
    • View Profile
    • http://
When New OZ is going tobe relized
« Reply #6 on: November 05, 2004, 11:44:32 am »
Sory but ihave to go home now have a nice weekend.
« Last Edit: November 05, 2004, 11:51:42 am by Yasen »
[span style=\'font-size:8pt;line-height:100%\']SL-5600 PXA-250
noname 256 MB MMC fat,
SanDisk 1GB  CF vfat
[/span]

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
When New OZ is going tobe relized
« Reply #7 on: November 05, 2004, 11:52:07 am »
If this entry describes your card (what you can check via cardctl ident), then delete it from hermes.conf, put it into hostap.conf and change "bind orinoco_cs" to "bind hostap_cs". Restart pcmcia and reinsert your card. What happens then? Look also into dmesg and lsmod then.
« Last Edit: November 05, 2004, 11:52:38 am by Mickeyl »
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

Yasen

  • Full Member
  • ***
  • Posts: 107
    • View Profile
    • http://
When New OZ is going tobe relized
« Reply #8 on: November 08, 2004, 06:35:57 am »
Thanks Mickeyl. I think it is ok now. At least it dosen't hangs. Now I don't know which of two devices to set up but somewhere there was explanation. I'm going to search it.
Quote
Looks like a prism card which should be in hostap.conf, not in hermes.conf.
If this is true for all Prism2 cards then why this
Code: [Select]
card "Orinoco or Intersil Prism 2 Wireless"
 manfid 0x0156, 0x0002
 bind "orinoco_cs"
is in hermes.conf by default.
[span style=\'font-size:8pt;line-height:100%\']SL-5600 PXA-250
noname 256 MB MMC fat,
SanDisk 1GB  CF vfat
[/span]

Mickeyl

  • Hero Member
  • *****
  • Posts: 1495
    • View Profile
    • http://www.Vanille.de
When New OZ is going tobe relized
« Reply #9 on: November 08, 2004, 08:24:35 am »
orinoco is intended for hermes based cards, but also handles a couple of prism cards. hostap is the "more natural" driver for prism cards though.
Cheers,

Michael 'Mickey' Lauer | Embedded Linux Freelancer | www.Vanille-Media.de
Consider donating, if you like the software I contribute to.

dansawyer

  • Sr. Member
  • ****
  • Posts: 293
    • View Profile
    • http://
When New OZ is going tobe relized
« Reply #10 on: November 08, 2004, 09:59:57 am »
I have an Intersil card that works and a LInksys card that does not. Where are hostap.conf and hermes.conf files? Where should the Linksys card be? The Intersil card seems to be using hostap.

Thanks,
Dan

Yasen

  • Full Member
  • ***
  • Posts: 107
    • View Profile
    • http://
When New OZ is going tobe relized
« Reply #11 on: November 08, 2004, 10:05:54 am »
Quote
Where are hostap.conf and hermes.conf files?
By memory "/etc/pcmci" or somethink like this.
One of them before .conf has _cs
[span style=\'font-size:8pt;line-height:100%\']SL-5600 PXA-250
noname 256 MB MMC fat,
SanDisk 1GB  CF vfat
[/span]