Author Topic: Rc8, Bluetooth And Nokia 6310i  (Read 940 times)

Foxdie

  • Sr. Member
  • ****
  • Posts: 465
    • View Profile
    • http://trackmygps.co.uk
Rc8, Bluetooth And Nokia 6310i
« on: January 01, 2005, 08:34:48 am »
Well I'll be honest, bluetooth support has always been flaky in pdaXrom, I've always had to edit hcid.conf and change the bluetooth pin helper to a shell script which echo's PIN:0000 to get it to pair with a phone.

Now since RC8 and possibly since the update IPKG's I am unable to pair a Nokia 6310i that I have paired multiple times in the past with other ROMs, so I know it's not a fault with the phone or the bluetooth card.

I have a BlueMonkey BlueCF card and all the bluetooth ipk's installed from the feed, still can't get it to work though.

The current setup I have right now is a shell script in /etc/bluetooth/ called givepin, in that shell script is only the line "echo PIN:0000" and hcid.conf points to that script file to provide the pairing pin, in the past this has worked fine up until RC8 (and yes the permissions are all set up correctly).

Anyone able to assist? I've exhausted everything I can think of.


Ps. I absolutely hate the pppconfig applet as it overwrites rfcomm.conf with whatever it feels like, please can we get that applet to prompt before overwrite? Not only that but the damn thing locks up whenever I try to add a bluetooth profile.
« Last Edit: January 01, 2005, 08:48:02 am by Foxdie »
Jason "Foxdie" Gaunt
HTC Universal G4 with 2GB SD card running Debian Titchy Linux
[img]http://trackmygps.co.uk/signatures/foxdie.gif\" border=\"0\" class=\"linked-sig-image\" /]
Click image to view my GPS tracker
Follow me on Twitter: @jasongaunt

tumnus

  • Hero Member
  • *****
  • Posts: 1176
    • View Profile
    • http://www.cpinkney.org.uk
Rc8, Bluetooth And Nokia 6310i
« Reply #1 on: January 01, 2005, 09:30:56 am »
Try deleting the file /etc/bluetooth/link_key and make sure the pairing is deleted from your phone also. The keys might have become out of sync. Also make sure you have rebooted your phone (turned it off and removed the battery for more than 10 seconds) as Nokia have a flakey Bluetooth implementation that stops responding properly at times.

If that does not work, have a look at the syslog messages (not dmesg) when you try to connect. You should see some link key exchanges when trying to pair. Otherwise it should give some kind of error message if it fails.
# Search the Zaurus Howtos ## Search the Zaurus FAQs ## Find Z software at ELSI #
--------------------
UK SL5500 with Sharp ROM 3.13, SL5600 with Sharp ROM 1.32 - SuSE 9.0 Pro, Windows XP Home
Qualendar for Calendar and Todo
Socket Bluetooth CF Card (Rev F), Kingmax 512MB MMC Card, Palm Tungsten T Stylus,
Pretec CF->Smartmedia Adapter, Semsons Universal Battery Extender

Foxdie

  • Sr. Member
  • ****
  • Posts: 465
    • View Profile
    • http://trackmygps.co.uk
Rc8, Bluetooth And Nokia 6310i
« Reply #2 on: January 01, 2005, 10:40:28 am »
That's fixed it, thanks tumnus, had to do a forced reset of the Nokia 6310i (pulling out the battery while the phone was still on) which then allowed me to pair it when I turned the phone back on. The result? I can now get on IRC at work
Jason "Foxdie" Gaunt
HTC Universal G4 with 2GB SD card running Debian Titchy Linux
[img]http://trackmygps.co.uk/signatures/foxdie.gif\" border=\"0\" class=\"linked-sig-image\" /]
Click image to view my GPS tracker
Follow me on Twitter: @jasongaunt