Author Topic: Cacko FAQ and Bugz Database are available  (Read 37455 times)

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
Cacko FAQ and Bugz Database are available
« on: January 05, 2005, 11:15:56 am »
Based on 1.22 ROM thread, I've set up initial verison of Cacko ROM 1.22 FAQ. Please, visit it at: http://cacko.biz/cacko/faq

Comments are welcome.
« Last Edit: January 05, 2005, 02:13:54 pm by maslovsky »

ev1l

  • Hero Member
  • *****
  • Posts: 608
    • View Profile
    • http://bbshuffle.blogspot.com/
Cacko FAQ and Bugz Database are available
« Reply #1 on: January 05, 2005, 10:16:17 pm »
here is the bugDB

might be a good idea to put ncurses 4 in the cacko feed if you recommend it.
that last QA is a bit confusing though. You open th equestion with joe, and the answer is 90% about vim
Disabling dimming seems to make the screen-shutoff problem come back.

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
Cacko FAQ and Bugz Database are available
« Reply #2 on: January 06, 2005, 07:12:59 am »
This FAQ is far from being complete. I just wanted to make sure that we have some information about all the issues we found in 1.22.

_Psycho

  • Full Member
  • ***
  • Posts: 114
    • View Profile
    • http://zports.sf.net
Cacko FAQ and Bugz Database are available
« Reply #3 on: January 06, 2005, 08:57:51 am »
Its quite good if you ask me
Zaurus Porting Project :
http://zports.sf.net
Conics:
http://www.conics.net

ev1l

  • Hero Member
  • *****
  • Posts: 608
    • View Profile
    • http://bbshuffle.blogspot.com/
Cacko FAQ and Bugz Database are available
« Reply #4 on: January 06, 2005, 06:04:18 pm »
Quote
This FAQ is far from being complete. I just wanted to make sure that we have some information about all the issues we found in 1.22.
Wasn't meant as a complaint. Just pointing things out

\Kritikal\

  • Newbie
  • *
  • Posts: 5
    • View Profile
Cacko FAQ and Bugz Database are available
« Reply #5 on: January 13, 2005, 10:18:16 am »
I noticed the page was slow to load as well as having a Geocities/Yahoo style advert in the upper right corner. I can provide space on my domain, you'd get a login of course, so that we can enjoy an advert free site. Plus, I love giving back and since I don't know Linux enough to contribute anything technical, I'd love to help out in any other way I can. Send me a PM if you're interested!
« Last Edit: January 13, 2005, 10:18:38 am by \Kritikal\ »

mrente07

  • Newbie
  • *
  • Posts: 14
    • View Profile
    • http://
Cacko FAQ and Bugz Database are available
« Reply #6 on: February 05, 2005, 10:53:16 am »
Thanks a lot for the really nice ROM.  I used the previous version and I like the newone.

I 'm using a CFU USB adapter with some USB memory sticks and need some help. With Cacko V1.21 I hadn't any problems to use them. But with V1.22 I couldn't connect to any sticks anymore.  The CFU adapter will be detected but no sticks. I looked at the FAQ page, but I couldn't find some information about the hotplug system.

Can you give me a hint how this should work with CFU and USB sticks or where I can more details to solve my problem?

Thanks, regards
[span style=\'font-size:8pt;line-height:100%\']
C860, Cacko ROM V1.22A
SD Pretec 128MB
CF Sandisk UltraII 1GB
CFU1 Ratoc USB Adapter
billionton CF 10Base Ethernet
[/span]

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
Cacko FAQ and Bugz Database are available
« Reply #7 on: February 06, 2005, 05:01:04 am »
Quote
Thanks a lot for the really nice ROM.  I used the previous version and I like the newone.

I 'm using a CFU USB adapter with some USB memory sticks and need some help. With Cacko V1.21 I hadn't any problems to use them. But with V1.22 I couldn't connect to any sticks anymore.  The CFU adapter will be detected but no sticks. I looked at the FAQ page, but I couldn't find some information about the hotplug system.

Can you give me a hint how this should work with CFU and USB sticks or where I can more details to solve my problem?

Thanks, regards
[div align=\"right\"][a href=\"index.php?act=findpost&pid=65704\"][{POST_SNAPBACK}][/a][/div]

Do you mean Ratoc USB Host? It should be working, I will check.

mrente07

  • Newbie
  • *
  • Posts: 14
    • View Profile
    • http://
Cacko FAQ and Bugz Database are available
« Reply #8 on: February 06, 2005, 05:36:46 am »
Quote
Do you mean Ratoc USB Host? It should be working, I will check.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=65804\"][{POST_SNAPBACK}][/a][/div]

Yes, it is the CFU1 USB host cf card of Ratoc systems. I tried the new patch V1.22A also but no changes. Could I check anything else for you additionally?
[span style=\'font-size:8pt;line-height:100%\']
C860, Cacko ROM V1.22A
SD Pretec 128MB
CF Sandisk UltraII 1GB
CFU1 Ratoc USB Adapter
billionton CF 10Base Ethernet
[/span]

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
Cacko FAQ and Bugz Database are available
« Reply #9 on: February 07, 2005, 07:48:10 am »
Quote
Quote
Do you mean Ratoc USB Host? It should be working, I will check.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=65804\"][{POST_SNAPBACK}][/a][/div]

Yes, it is the CFU1 USB host cf card of Ratoc systems. I tried the new patch V1.22A also but no changes. Could I check anything else for you additionally?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=65813\"][{POST_SNAPBACK}][/a][/div]

Today checked my USB Host card with two card readers and one USB Stick - all worked fine.

Try to start syslog (/etc/rc.d/init.d/syslog start) and see what messages appear (tail -f /var/log/messages) when you insert your USB stick.

mrente07

  • Newbie
  • *
  • Posts: 14
    • View Profile
    • http://
Cacko FAQ and Bugz Database are available
« Reply #10 on: February 07, 2005, 01:23:36 pm »
Quote
Try to start syslog (/etc/rc.d/init.d/syslog start) and see what messages appear (tail -f /var/log/messages) when you insert your USB stick.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=65956\"][{POST_SNAPBACK}][/a][/div]

Thanks for your checks. I have done what you proposed and I got following messages ....
.... by inserting the USB stick:
   hub.c:  USB new device connect on bus1/1, assigned device number 4
   usb.c:  USB device 4 (vend/prod 0xea0/0x2168) is not claimed by any active driver
   /etc/hotplug/usb/.agent: Setup for USB product ea0/2168/200

.... by removing the USB stick:
   hub.c: USB disconnect on device 4

I hope, this will help.
[span style=\'font-size:8pt;line-height:100%\']
C860, Cacko ROM V1.22A
SD Pretec 128MB
CF Sandisk UltraII 1GB
CFU1 Ratoc USB Adapter
billionton CF 10Base Ethernet
[/span]

Lutz-W.

  • Newbie
  • *
  • Posts: 27
    • View Profile
    • http://
Cacko FAQ and Bugz Database are available
« Reply #11 on: February 07, 2005, 03:31:39 pm »
Quote
Try to start syslog (/etc/rc.d/init.d/syslog start) and see what messages appear (tail -f /var/log/messages) when you insert your USB stick.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=65956\"][{POST_SNAPBACK}][/a][/div]

Hi maslovsky,

I use Cacko 1.22 Lite and have the same problem with the with the RATOC CFU1-Card and a USB stick. I found the following in /var/log/messages:

Feb  7 20:03:07 zaurus daemon.info cardmgr[164]: initializing socket 0
Feb  7 20:03:07 zaurus daemon.info cardmgr[164]: socket 0: RATOC USB HOST CF+ Card
Feb  7 20:03:07 zaurus daemon.info cardmgr[164]: executing: 'modprobe usbcore'
Feb  7 20:03:07 zaurus syslog.info klogd: usb.c: registered new driver usbdevfs
Feb  7 20:03:07 zaurus syslog.info klogd: usb.c: registered new driver hub
Feb  7 20:03:07 zaurus daemon.info cardmgr[164]: executing: 'modprobe hc_sl811'
Feb  7 20:03:07 zaurus daemon.info cardmgr[164]: executing: 'modprobe sl811_cs'
Feb  7 20:03:07 zaurus syslog.info klogd: cf_usb0: index 0x04: Vcc 3.3, irq 39, io 0xf6000000-0xf6000007
Feb  7 20:03:07 zaurus syslog.info klogd: usb.c: new USB bus registered, assigned bus number 1
Feb  7 20:03:07 zaurus syslog.info klogd: hc_sl811.c: USB SL811 at f6000000,f6000001, IRQ 39
Feb  7 20:03:07 zaurus syslog.info klogd: hub.c: USB hub found
Feb  7 20:03:07 zaurus syslog.info klogd: hub.c: 1 port detected
Feb  7 20:03:08 zaurus daemon.info cardmgr[164]: executing: './usb-host start cf_usb0'
Feb  7 20:03:08 zaurus user.notice /etc/hotplug/usb.agent: Setup for USB product 0/0/0
Feb  7 20:03:13 zaurus syslog.info klogd: hub.c: USB new device connect on bus1/1, assigned device number 2
Feb  7 20:03:13 zaurus syslog.info klogd: hub.c: USB hub found
Feb  7 20:03:13 zaurus syslog.info klogd: hub.c: 1 port detected
Feb  7 20:03:13 zaurus syslog.info klogd: hub.c: USB new device connect on bus1/1/1, assigned device number 3
Feb  7 20:03:13 zaurus syslog.warn klogd: usb.c: USB device 3 (vend/prod 0x67b/0x2517) is not claimed by any active driver.
Feb  7 20:03:14 zaurus user.notice /etc/hotplug/usb.agent: Setup for USB product 67b/2515/100
Feb  7 20:03:14 zaurus user.notice /etc/hotplug/usb.agent: Setup for USB product 67b/2517/100

On /proc there is no scsi file or directory.

I hope also, this will help.
Lutz
C3200, Cacko 1.23 Lite

stupkid

  • Hero Member
  • *****
  • Posts: 578
    • View Profile
    • http://
Cacko FAQ and Bugz Database are available
« Reply #12 on: February 07, 2005, 03:45:22 pm »
Does running "sudo modprobe usb-storage" do anything for you?  I see that the scsi modules and the usb-storage module is there.  So all the necessary kernel modules should be there.

Zaurus SL-C3200 pdaXii13v2 5.5 / Ambicom WC1100C-CF / Socket Bluetooth Rev G


OpenMoko FreeRunner - Running Tweaked OM2008.x Image

Lutz-W.

  • Newbie
  • *
  • Posts: 27
    • View Profile
    • http://
Cacko FAQ and Bugz Database are available
« Reply #13 on: February 07, 2005, 04:16:38 pm »
Quote
"sudo modprobe usb-storage"[div align=\"right\"][a href=\"index.php?act=findpost&pid=66021\"][{POST_SNAPBACK}][/a][/div]

Okay! That is it.
It functions again.  

Thanks!
Lutz

P.S. Stupkid: What makes BestCrypt?  
« Last Edit: February 07, 2005, 04:20:08 pm by Lutz-W. »
C3200, Cacko 1.23 Lite

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
Cacko FAQ and Bugz Database are available
« Reply #14 on: February 07, 2005, 04:38:58 pm »
Looks like your USB stick don't have an enry in hotplg configuration file. Try to copy /etc/hotplug/usb.distmap from a PC wth a recent liux distro installed. That should bind you class/vendor etc id with usb-storage hotplug scripts and load modules automaticaly.
« Last Edit: February 07, 2005, 04:42:47 pm by maslovsky »