Author Topic: Firewall-settings For Os X Internetsharing Via Usb  (Read 25671 times)

samot

  • Jr. Member
  • **
  • Posts: 82
    • View Profile
    • http://
Firewall-settings For Os X Internetsharing Via Usb
« Reply #15 on: May 01, 2006, 08:21:50 pm »
Resuming what I did an worked (os sharp rom 3.1) was:

opening port 80 on the osx firewal

After geting good connection between the mac and the zaurus y started the internet sahring on the usb port.

On the zaurus:

sudo route add -host 192.168.129.1 usbd0

sudo route add default gw 192.168.129.1

if yo dont have sudo you can do "su -", root password and then: "route add..."
that shoud let you ping ip addresses. Yo still need to set the DNS

edit:
 /etc/resolv.conf

and add your DNS server after nameserver, this is not your router server, its you ISP DNS.

(ie: nameserver 200.64.48.11)


Open Opera and voila!!!
sl-5500 | WCF12 | SD kingstone 1gb | CF Memorex (Samsung) 64mb | OZ/OPIE (for the moment)

icruise

  • Sr. Member
  • ****
  • Posts: 292
    • View Profile
Firewall-settings For Os X Internetsharing Via Usb
« Reply #16 on: May 02, 2006, 03:06:38 am »
I mentioned in this thread that I was able surf the Internet on my Zaurus using a bluetooth connection to my Mac. But somewhere along the line it stopped working (perhaps when I upgraded to Tiger). I could connect to the Mac and use things like FTP, but not surf the net. This thread made me realize that I had to open some ports in the firewall to get it to work again. I opened up ports 80 and 443 (for secure web sites) and now I am surfing with no problems.

(See the thread above if you want the bluetooth sharing scripts I used.)

Edit: After trying to enable this on another machine, I discovered that the port settings weren't really my problem, although they are helpful when setting up the firewall. By coincidence, the machine on which I was able to get this to work had Internet sharing (to its ethernet port from airport) enabled. It turns out that unless I have Internet sharing enabled, I can't use the Internet through the Zaurus, even though I have it set to an unrelated port. It's not a big deal to enable this, since I don't use the ethernet port anyway, but I was wondering if there was another way to do this.
« Last Edit: May 02, 2006, 03:56:31 am by icruise »

freizugheit

  • Sr. Member
  • ****
  • Posts: 409
    • View Profile
    • http://
Firewall-settings For Os X Internetsharing Via Usb
« Reply #17 on: May 03, 2006, 05:55:56 am »
samot,

I am glad to know that you enjoy surfing via Mac as your Internet gateway.

It further proves that those procedures that I have regularly used are correct.

samot

  • Jr. Member
  • **
  • Posts: 82
    • View Profile
    • http://
Firewall-settings For Os X Internetsharing Via Usb
« Reply #18 on: May 08, 2006, 05:20:55 pm »
Quote
samot,

I am glad to know that you enjoy surfing via Mac as your Internet gateway.

It further proves that those procedures that I have regularly used are correct.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=125541\"][{POST_SNAPBACK}][/a][/div]


Yes, what I wrote is basicly your instructions all in a same post to make it easier for reading. Thanks for your instructions.  
sl-5500 | WCF12 | SD kingstone 1gb | CF Memorex (Samsung) 64mb | OZ/OPIE (for the moment)

eji

  • Full Member
  • ***
  • Posts: 233
    • View Profile
    • http://charlatan.blogspot.com/
Firewall-settings For Os X Internetsharing Via Usb
« Reply #19 on: May 12, 2006, 03:35:34 am »
Hey, this is great! Thanks. I got USB (en2) working in about thirty seconds. I'll fiddle with Bluetooth later on today.
Zaurus SL-6000L w/ Sharp ROM v1.12 - 1GB SanDisk CF - 1GB Lexar SD - Socket Rev. E BT CF | Mac OS X 10.5.x - iMac 24" 2.8Ghz | SIP: 864753@voip.brujula.net - 1 747 603 3461 (Gizmo/SIPhone)