Author Topic: New Packages Announcement  (Read 483890 times)

kkazakov13

  • Sr. Member
  • ****
  • Posts: 408
    • View Profile
New Packages Announcement
« Reply #270 on: March 16, 2007, 11:02:41 am »
Dia 0.95.1

[img]http://up.drun.net/v/s/2/f/dia1.png\" border=\"0\" class=\"linked-image\" /]

http://z.drun.net/packages/dia_0.95-1_armv5tel.ipk

I didn't had it, the one in the feed didn't worked, so I rebuilt it. I did this on beta3. I don't know if it needs any special library ... it should work out of the box. If not - let me know what it says, will try fill a dependencies list. All you need should be here http://z.drun.net/packages/ or in the official b3 feed.

Note: there is an anoying message about libpng something ... you can safely upgrade your libpng with this one: http://z.drun.net/packages/libpng_1.2.12_armv5tel.ipk - works great, fully backward compatible.
« Last Edit: March 19, 2007, 05:35:21 am by kkazakov13 »
SL-C3200 ** FOR SALE :( **
https://www.oesf.org/forum/index.php?showtopic=25969

Canon K30225 CF wireless card
Taxan iTax-LAN10 wired card
My packages for customized pdaXrom beta 3

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
New Packages Announcement
« Reply #271 on: March 16, 2007, 03:23:10 pm »
Battle for Wesnoth, cross-compiled for 2.6 kernels with the options "-O4 -mtune=iwmmxt -ncpu=iwmmxt -fomit-frame-pointer -fno-common."

If it doesn't work on Cxx0 models and somebody wants it, PM me and I'll (probably) rebuild it with the iwmmxt stuff replaced with xscale.

It's in multiple packages because I couldn't upload one big one.

EDIT: All packages are (probably) required to use the game.
« Last Edit: March 16, 2007, 07:38:22 pm by Capn_Fish »
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo

InSearchOf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1144
    • View Profile
    • http://
New Packages Announcement
« Reply #272 on: March 16, 2007, 08:47:19 pm »
Comments regarding Images not loading have been moved to here

Late
« Last Edit: March 17, 2007, 12:37:51 pm by InSearchOf »
Sharp Zaurus SL-C3100 and SL-6000L
pdaXrom Developer
Please visit pdaXrom.org for updates
My Blog
IRC #pdaxrom @ FreeNode

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
New Packages Announcement
« Reply #273 on: March 17, 2007, 05:39:17 pm »
Planner 0.14.2.

See here for more details.

EDIT: Post #200.
« Last Edit: March 17, 2007, 05:40:00 pm by Capn_Fish »
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo

Antikx

  • Hero Member
  • *****
  • Posts: 1147
    • View Profile
    • http://tyrannozaurus.com
New Packages Announcement
« Reply #274 on: March 18, 2007, 01:24:03 am »
[span style=\'font-size:14pt;line-height:100%\']Calcurse 1.7[/span]


« Last Edit: March 18, 2007, 01:26:07 am by Antikx »
Kanpai,
-Antikx (Twitter, Mugshot and PodNova)
C1000 - pdaXrom R198 (Celestial Environment)
tyrannozaurus.com
[img]http://www.tyrannozaurus.com/files/category_pictures/general_1.png\" border=\"0\" class=\"linked-sig-image\" /]
Zaurus news/blogs feed from Zaurus users
Free Windows, Linux, or Web RSS readers.
Featured pages at tyrannozaurus:
Sharp Petition, ScummVM, Cacko, pdaXii13, and Celestial Environment

willgan

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
    • http://
New Packages Announcement
« Reply #275 on: March 19, 2007, 12:51:52 am »
This is a requested application.

Name: Golly 1.1

It uses wxWidgets and unfortunately the wxWidgets that came with standard pdaxrom beta3 does not work because of some missing components.
So i rebuild the wxWidgets with all the necessary components for the application.
I've attached all the necessary files..

For the golly application, i haven't package it yet because it need more work on the Makefile..
You just need to extract the tar.gz files in any directory.. and run ./golly

Hope you enjoy it..
My Current Z...

Zaurus C1000 - Pdaxii13
Using Pdaxrom-builder (SVN) for building packages

willgan

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
    • http://
New Packages Announcement
« Reply #276 on: March 19, 2007, 01:18:57 am »
Hi everybody,

I've manage to compile OpenTTD 0.50.

The package does not have all the data files. You need the original TTD data files.
Please do not ask from me, you must own the game.

Music files are not included.

All the files are compiled from the source from openttd website.

Note: I'm not really sure what dependencies it requires but SDL packages is a must.
I haven't finish the packaging part yet.
You just need to extract the files where ever you like and run ./openttd
You need all the original TTD data files to run the application.
You can also use the configuration file, but its not included in the gz file.

Bugs:
The map background is black... not sure why..
Haven't fully tested the game yet..

 [ Invalid Attachment ]
My Current Z...

Zaurus C1000 - Pdaxii13
Using Pdaxrom-builder (SVN) for building packages


wellswang

  • Jr. Member
  • **
  • Posts: 78
    • View Profile
    • http://wells.osall.com
New Packages Announcement
« Reply #278 on: March 19, 2007, 08:38:18 pm »
[span style=\'font-size:14pt;line-height:100%\']Dosbox 0.70 Optimized for PXA270(iwmmxt)[/span]

This version is based on kkazakov's dosbox 0.70 package
( https://www.oesf.org/forums/index.php?showt...c=18415&st=240# )

I tried his version on my C3100, found that performance is not good enough.
So I rebuilt dosbox and added "-g -O2 -mcpu=iwmmxt -mtune=iwmmxt" parameters.
Now, it's optimized for Cxx00 models (which using Intel XScale PXA270 CPUs).
The performance is acceptable, and I can use it to play " DUNE 2" now, haha

Project Homepage:
http://dosbox.sourceforge.net

Compile Environment:
pdaXrom 1.1.0 beta3, gcc 3.4.6 (" -mcpu=iwmmxt -mtune=iwmmxt ")

Download:
http://wells.osall.com/files/download.php?id=1727

Playing an old game named "Power Dolls" in dosbox 0.70:
[img]http://www.zaurus.cn/files/pds1_134.jpg\" border=\"0\" class=\"linked-image\" /]



[span style=\'font-size:14pt;line-height:100%\']Gammu 1.10.1[/span]

Gammu is a project which encompasses applications, scripts and drivers for managing various functions on cellular phones and similiar devices.

Project Homepage:
http://www.gammu.org/wiki/index.php?title=Gammu:Main_Page

Compile Environment:
pdaXrom 1.1.0 beta3, gcc 3.4.6

Download:
http://wells.osall.com/files/download.php?id=1728

Notes:
You MUST create /etc/gammurc or ~/.gammurc to configure your mobile settings first!
For detail config parameters please read the Gammu Documents.

Using gammu to get SMS from my Siemens M55:
[img]http://www.zaurus.cn/files/gammu_116.jpg\" border=\"0\" class=\"linked-image\" /]


[span style=\'font-size:14pt;line-height:100%\']JustReader 2.0k-fiX-2[/span]

This version is based on my previous verison(Justerreader 2.0k-fiX).
In this release fixed following problems:
   * Can't open mobipocket 4.0 e-book.
   * Using jogwheel sometimes may scroll more than one page.

Project Homepage:
http://justreader.sourceforge.net/

Compile Environment:
pdaXrom 1.1.0 beta3, gcc 3.4.6

Download:
http://wells.osall.com/files/download.php?id=1666
« Last Edit: March 19, 2007, 08:42:14 pm by wellswang »

2or0

  • Full Member
  • ***
  • Posts: 217
    • View Profile
    • http://
New Packages Announcement
« Reply #279 on: March 21, 2007, 04:47:00 pm »
[span style=\'font-size:14pt;line-height:100%\']SDict Viewer 0.4.0[/span]
SDict Viewer is a viewer for dictionaries in open format developed by AXMA Soft. Because it is written in Python and pygtk it can run on all platform. The number of dictionaries is 321 including all languages of Wikipedia.

Screenshots:
Korean-English


Collins COBUILD Advanced Learner's English Dictionary, 4th edition


Project page: http://sdictviewer.sourceforge.net/

Download:

 [ Invalid Attachment ]

Dictionary data: You can get them from here: http://sdict.com/en/
Zaurus SL-C3200 with Debian armel of kernel 2.6.24-yonggun
Ambicom WL1100C WLAN
1 GB Sandisk SD / 1 GB Lexar SD / 256 MB Dane-Elec CF
-----
Blog http://yonggun.tistory.com (English/Korean)

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
New Packages Announcement
« Reply #280 on: March 23, 2007, 08:27:22 am »
compiled the following for pdaXii13 (beta3)

glipper is a gnome based clipboard daemon for copying and pasting stuff between applications...

http://www.tyrannozaurus.com/feed/beta3/cu....1_armv5tel.ipk


pager allows you to switch between virtual desktops...

http://www.tyrannozaurus.com/feed/beta3/cu....1_armv5tel.ipk

i also integrated pager into the tasks applet
http://www.tyrannozaurus.com/feed/beta3/cu....2_armv5tel.ipk

xrestop is like top but only show resource consumption used by X processes...

http://www.tyrannozaurus.com/feed/beta3/cu....4_armv5tel.ipk
http://www.tyrannozaurus.com/feed/beta3/cu....1_armv5tel.ipk
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
New Packages Announcement
« Reply #281 on: March 24, 2007, 09:43:45 pm »
compiled apache2 for pdaXii13 (beta3)
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

ZDevil

  • Hero Member
  • *****
  • Posts: 1998
    • View Profile
    • http://
New Packages Announcement
« Reply #282 on: March 25, 2007, 05:24:08 am »
[span style=\'font-size:14pt;line-height:100%\']IceWM 1.2.30 (Latest)[/span]

Download it from here.

And see the discussion in this post.

Life is too precious for hacking *too much*
Visit my Z screencap gallery[/color]
My EeePC 701 Black = Debian (Lenny) on IceRocks + Transcend SDHC Class6 8GB + 2GB RAM
My Zaurus SL-C3200 = Debian EABI (kernel 2.6.24.3-yonggun) on a swapped internal Sandisk Extreme III CF 16gb
My Debian EABI feed: http://matrixmen.free.fr/zaurus/debian/
My OpenBSD/Zaurus feeds:  Link1, Link2
[/i][/font][/color][/size]

ZDevil

  • Hero Member
  • *****
  • Posts: 1998
    • View Profile
    • http://
New Packages Announcement
« Reply #283 on: March 25, 2007, 05:44:08 am »
[span style=\'font-size:14pt;line-height:100%\']Emacs 23.0.0.1 (XftGnuEmacs)[/span]

Here is the latest (as of March 14 2007) Emacs 23, with much better unicode and CJK support. It can run with GTK GUI or simply in the terminal.

The full huge build is split into five packages: base, extra, lisp, leim, docs and lisp-source.

Download all the files from this post


[span style=\'font-size:14pt;line-height:100%\']Emacs PIM Suite 1.3[/span]

This is a collection of byte-compiled "modes" (like softwares in an OS) specially for PIM.
The package contains: Planner (the gold of PIM in Emacs), BBDB (for contacts), Muse (wiki functionality), Remember (reminder)

Download it here.


Also see the discussion in this thread.


(PS It seems the downloads in the forum are somehow corrupted. I can only download the files all named "index.html" and then I have to change them to the original filenames and they will work just fine.)

Life is too precious for hacking *too much*
Visit my Z screencap gallery[/color]
My EeePC 701 Black = Debian (Lenny) on IceRocks + Transcend SDHC Class6 8GB + 2GB RAM
My Zaurus SL-C3200 = Debian EABI (kernel 2.6.24.3-yonggun) on a swapped internal Sandisk Extreme III CF 16gb
My Debian EABI feed: http://matrixmen.free.fr/zaurus/debian/
My OpenBSD/Zaurus feeds:  Link1, Link2
[/i][/font][/color][/size]

wellswang

  • Jr. Member
  • **
  • Posts: 78
    • View Profile
    • http://wells.osall.com
New Packages Announcement
« Reply #284 on: March 25, 2007, 11:57:36 pm »
[span style=\'font-size:14pt;line-height:100%\']digger[/span]


[/b]
[img]http://www.zaurus.cn/files/smplayer1_791.jpg\" border=\"0\" class=\"linked-image\" /]
« Last Edit: March 27, 2007, 02:42:10 am by wellswang »