Author Topic: Can't Get Bt Dun Working With Samsung Sgh-i310  (Read 1139 times)

merli

  • Full Member
  • ***
  • Posts: 227
    • View Profile
    • http://
Can't Get Bt Dun Working With Samsung Sgh-i310
« on: January 13, 2007, 09:25:56 am »
Hello

I have quite strange problem I cannot solve. Recently I got (as christmas gift from my wife) Windows Mobile 5 smarphone Samsung SGH i310. I am trying to get Zaurus DUN to Internet through Bluetooth Billlonton CF card. I had working Internet connection with Sony Eriscon T610 without any problem also Nokia 6230i without problem except connection last only 1 minute (I think problem in Nokia BT module). I got both working through PPP Modem config application. So I thought everything will be the same also with SGH i310. I was very wrong!

First I tried this config application and in Modem tab searched for BT device. I got " Can't get DUN info.
So i tried to hack it manually! Tried...

# hcitool scan
Scanning ...
        00:17:D5:1B:84:F0       misik

OK I see mobile

# sdptool search DUN  
Inquiring ...
Searching for DUN on 00:17:D5:1B:84:F0 ...
Service Name: Dial-up Networking
Service RecHandle: 0x10007
Service Class ID List:
  "Dialup Networking" (0x1103)
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 4
Language Base Attr List:
  code_ISO639: 0x656e
  encoding:    0x6a
  base_offset: 0x100
Profile Descriptor List:
  "Dialup Networking" (0x1103)
    Version: 0x0100

#

So DUN is there... on channel 4. So I manually edited

# cat /home/root/Choices/common/Network-PPP-Samsung.conf
[Info]
name = Samsung
[Properties]
BTDUN = 00:17:D5:1B:84:F0,4
Bluetooth = 1
IrDA = 0
Serial = 0
atdial = at+cgdcont=1,"IP","internet"
connectdelay = 6000
crtscts = 1
defaultroute = 1
device = /dev/rfcomm0
dialmode = 0
dns1 =
dns2 =
gateway =
idletime = 120
password =
phone = *99***1#
speed = 115200
usepeerdns = 1
username =
#

and
# cat /etc/ppp/peers/Samsung
/dev/rfcomm0
115200
connect "/usr/sbin/chat -v -f /etc/chatscripts/gprs"
#crtscts
noipdefault
usepeerdns
defaultroute
local
connect-delay 6000
remotename Samsung
#

# cat /etc/chatscripts/gprs
'' ATZ OK

AT+CGDCONT=1,"IP","internet"

OK "ATD*99***1#"

CONNECT ''
#

I paired devices with
hcitool cc OK

but when I try to connect with pppd

pppd debug call Samsung

I will get in /var log messages ....

Dec  9 00:55:25 pppd[5254]: pppd 2.4.3 started by root, uid 0
Dec  9 00:55:26 hcid[860]: link_key_request (sba=00:10:60:AA:4A:D1, dba=00:17:D5:1B:84:F0)
Dec  9 00:55:26 chat[5255]: send (ATZ^M)
Dec  9 00:55:26 chat[5255]: expect (OK)
Dec  9 00:55:26 chat[5255]: ATZ^M^M
Dec  9 00:55:26 chat[5255]: OK
Dec  9 00:55:26 chat[5255]:  -- got it
Dec  9 00:55:26 chat[5255]: send (AT+CGDCONT=1,"IP","internet"^M)
Dec  9 00:55:26 chat[5255]: expect (OK)
Dec  9 00:55:26 chat[5255]: ^M
Dec  9 00:55:27 chat[5255]: AT+CGDCONT=1,"IP","internet"^M^M
Dec  9 00:55:27 chat[5255]: OK
Dec  9 00:55:27 chat[5255]:  -- got it
Dec  9 00:55:27 chat[5255]: send (ATD*99***1#^M)
Dec  9 00:55:27 chat[5255]: expect (CONNECT)
Dec  9 00:55:27 chat[5255]: ^M
Dec  9 00:55:28 chat[5255]: ATD*99***1#^M^M
Dec  9 00:55:28 chat[5255]: CONNECT
Dec  9 00:55:28 chat[5255]:  -- got it
Dec  9 00:55:28 chat[5255]: send (^M)
Dec  9 00:55:28 pppd[5254]: Serial connection established.
Dec  9 00:55:28 pppd[5254]: using channel 29
Dec  9 00:55:28 pppd[5254]: Using interface ppp0
Dec  9 00:55:28 pppd[5254]: Connect: ppp0 <--> /dev/rfcomm0
Dec  9 00:55:28 /etc/hotplug/net.agent: assuming ppp0 is already up
Dec  9 00:55:34 pppd[5254]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x9189b7d> <pcomp> <accomp>]
Dec  9 00:55:34 pppd[5254]: rcvd [LCP ConfReq id=0x1 <mru 1300> <asyncmap 0xa0000> <auth pap>]
Dec  9 00:55:34 pppd[5254]: No auth is possible
Dec  9 00:55:34 pppd[5254]: sent [LCP ConfRej id=0x1 <auth pap>]
Dec  9 00:55:34 pppd[5254]: rcvd [LCP ConfRej id=0x1 <pcomp> <accomp>]
Dec  9 00:55:34 pppd[5254]: sent [LCP ConfReq id=0x2 <asyncmap 0x0> <magic 0x9189b7d>]
Dec  9 00:55:34 pppd[5254]: rcvd [LCP ConfReq id=0x2 <mru 1300> <asyncmap 0xa0000>]
Dec  9 00:55:34 pppd[5254]: sent [LCP ConfAck id=0x2 <mru 1300> <asyncmap 0xa0000>]
Dec  9 00:55:34 pppd[5254]: rcvd [LCP ConfNak id=0x2 <asyncmap 0xa0000>]
Dec  9 00:55:34 pppd[5254]: sent [LCP ConfReq id=0x3 <asyncmap 0xa0000> <magic 0x9189b7d>]
Dec  9 00:55:37 pppd[5254]: sent [LCP ConfReq id=0x3 <asyncmap 0xa0000> <magic 0x9189b7d>]
Dec  9 00:55:40 pppd[5254]: sent [LCP ConfReq id=0x3 <asyncmap 0xa0000> <magic 0x9189b7d>]
Dec  9 00:55:43 pppd[5254]: sent [LCP ConfReq id=0x3 <asyncmap 0xa0000> <magic 0x9189b7d>]
Dec  9 00:55:46 pppd[5254]: sent [LCP ConfReq id=0x3 <asyncmap 0xa0000> <magic 0x9189b7d>]
Dec  9 00:55:49 pppd[5254]: sent [LCP ConfReq id=0x3 <asyncmap 0xa0000> <magic 0x9189b7d>]
Dec  9 00:55:52 pppd[5254]: sent [LCP ConfReq id=0x3 <asyncmap 0xa0000> <magic 0x9189b7d>]
Dec  9 00:55:55 pppd[5254]: sent [LCP ConfReq id=0x3 <asyncmap 0xa0000> <magic 0x9189b7d>]
Dec  9 00:55:58 pppd[5254]: sent [LCP ConfReq id=0x3 <asyncmap 0xa0000> <magic 0x9189b7d>]
Dec  9 00:56:01 pppd[5254]: sent [LCP ConfReq id=0x3 <asyncmap 0xa0000> <magic 0x9189b7d>]
Dec  9 00:56:04 pppd[5254]: LCP: timeout sending Config-Requests
Dec  9 00:56:04 pppd[5254]: Connection terminated.
Dec  9 00:56:04 chat[5272]: send (ATZ^M)
Dec  9 00:56:04 chat[5272]: expect (OK)
Dec  9 00:56:05 /etc/hotplug/net.agent: NET unregister event not supported


You would tell ... wrong phone .......
BUT from M$ Windows XP (my notebook) with _same_ Billionton BT card in PCMCIA reduction EVERYTHING WORKS just from scratch without any problem. So I think Win XP has other options in pppd which zaurus does not have.

Please help me. Where I am doing mistake?  What obscured option in pppd I have to turn on to get it working?

Thnx much for any clue or help.

PS: Internet direcctly from phone also works OK.

Another configs:

# cat /etc/bluetooth/hcid.conf
#
# HCI daemon configuration file.
#
# $Id: hcid.conf,v 1.3 2002/07/18 18:12:46 maxk Exp $
#

# HCId options
options {
        # Automatically initialize new devices
        autoinit yes;

        # Security Manager mode
        #   none - Security manager disabled
        #   auto - Use local PIN for incoming connections
        #   user - Always ask user for a PIN
        #
        security auto;

        # Pairing mode
        #   none  - Pairing disabled
        #   multi - Allow pairing with already paired devices
        #   once  - Pair once and deny successive attempts
        pairing multi;

        # PIN helper
        pin_helper /bin/bluepin;
}

# Default settings for HCI devices
device {
        # Local device name
        #   %d - device id
        #   %h - host name
        name "BlueZ (%d)";

        # Local device class
        class 0x120114;

        # Default packet type
        #pkt_type DH1,DM1,HV1;

        # Inquiry and Page scan
        iscan enable; pscan enable;

        # Default link mode
        #   none   - no specific policy
        #   accept - always accept incoming connections
        #   master - become master on incoming connections,
        #            deny role switch on outgoing connections
        #
        #lm accept,master;
        #
        lm accept;

        # Default link policy
        #   none    - no specific policy
        #   rswitch - allow role switch
        #   hold    - allow hold mode
        #   sniff   - allow sniff mode
        #   park    - allow park mode
        #
        #lp hold,sniff;
        #
        lp hold,sniff,park;

        # Authentication and Encryption
        #auth enable;
        #encrypt enable;
}
#

# cat /etc/bluetooth/rfcomm.conf
rfcomm0 {
    bind yes;
    device 00:17:D5:1B:84:F0;
    channel 4;
    comment "Generated by BT dial-up network applet.";
}
#
merli
------
SL-C1000 - pdaxii13 5.3.3 but considering go back to beta1
Wifi D-link DCF-650W CF card - not using
bluetooth Billionton BT CF card and Samsung SGH-i310 GPRS
Pretec Cheetah 133x 4GB SD, Pretec Cheetah 80x 1GB CF

harvell

  • Full Member
  • ***
  • Posts: 241
    • View Profile
    • http://
Can't Get Bt Dun Working With Samsung Sgh-i310
« Reply #1 on: January 13, 2007, 12:34:50 pm »
Great troubleshooting and documenting.  Some of the best I seen on these forums.  Sorry cant help with the details other than it seems like the error log on ppp is saying something with authentication credentials.
C1000 w/...  Cacko Lite (When I use the Z alot for business)... pdaXrom (when I see something cool and want to try it.  Best way for me to learn shell commands)
Eee PC for Mrs. Harvell  
4G SD

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Can't Get Bt Dun Working With Samsung Sgh-i310
« Reply #2 on: January 13, 2007, 01:55:36 pm »
i've this option in my /etc/ppp/peers/orange :

noauth

perhaps it would help...
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

karlto

  • Sr. Member
  • ****
  • Posts: 343
    • View Profile
    • http://
Can't Get Bt Dun Working With Samsung Sgh-i310
« Reply #3 on: January 13, 2007, 02:46:32 pm »
Quote
Dec  9 00:55:34 pppd[5254]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x9189b7d> <pcomp> <accomp>]
Dec  9 00:55:34 pppd[5254]: rcvd [LCP ConfReq id=0x1 <mru 1300> <asyncmap 0xa0000> <auth pap>]
Dec  9 00:55:34 pppd[5254]: No auth is possible
Dec  9 00:55:34 pppd[5254]: sent [LCP ConfRej id=0x1 <auth pap>]
Dec  9 00:55:34 pppd[5254]: rcvd [LCP ConfRej id=0x1 <pcomp> <accomp>]
This appears to be the issue - firstly your end is asking for pcomp and accomp which is rejected at the remote server (probably not an issue), and the remote server is asking for you to authenticate via PAP which you are refusing to do. I'm not sure what the line 'No auth is possible' means, but I'd start by making sure that you have your pap-secrets file set up correctly and the ppp settings are correct for PAP authentication (don't require the remote server to authenticate itself though).
SL6000-L, RC12

merli

  • Full Member
  • ***
  • Posts: 227
    • View Profile
    • http://
Can't Get Bt Dun Working With Samsung Sgh-i310
« Reply #4 on: January 13, 2007, 05:56:27 pm »
Quote
Quote
Dec  9 00:55:34 pppd[5254]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x9189b7d> <pcomp> <accomp>]
Dec  9 00:55:34 pppd[5254]: rcvd [LCP ConfReq id=0x1 <mru 1300> <asyncmap 0xa0000> <auth pap>]
Dec  9 00:55:34 pppd[5254]: No auth is possible
Dec  9 00:55:34 pppd[5254]: sent [LCP ConfRej id=0x1 <auth pap>]
Dec  9 00:55:34 pppd[5254]: rcvd [LCP ConfRej id=0x1 <pcomp> <accomp>]
This appears to be the issue - firstly your end is asking for pcomp and accomp which is rejected at the remote server (probably not an issue), and the remote server is asking for you to authenticate via PAP which you are refusing to do. I'm not sure what the line 'No auth is possible' means, but I'd start by making sure that you have your pap-secrets file set up correctly and the ppp settings are correct for PAP authentication (don't require the remote server to authenticate itself though).
[div align=\"right\"][a href=\"index.php?act=findpost&pid=151108\"][{POST_SNAPBACK}][/a][/div]

It is strange because I am not using any authentication when connecting from windows XP or direct from phone. I will play with some ppp parameters ...

so my file /etc/ppp/pap-secters was clear

Thnx anyway
merli
------
SL-C1000 - pdaxii13 5.3.3 but considering go back to beta1
Wifi D-link DCF-650W CF card - not using
bluetooth Billionton BT CF card and Samsung SGH-i310 GPRS
Pretec Cheetah 133x 4GB SD, Pretec Cheetah 80x 1GB CF

merli

  • Full Member
  • ***
  • Posts: 227
    • View Profile
    • http://
Can't Get Bt Dun Working With Samsung Sgh-i310
« Reply #5 on: January 13, 2007, 07:43:04 pm »
Quote
Quote
Quote
Dec  9 00:55:34 pppd[5254]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x9189b7d> <pcomp> <accomp>]
Dec  9 00:55:34 pppd[5254]: rcvd [LCP ConfReq id=0x1 <mru 1300> <asyncmap 0xa0000> <auth pap>]
Dec  9 00:55:34 pppd[5254]: No auth is possible
Dec  9 00:55:34 pppd[5254]: sent [LCP ConfRej id=0x1 <auth pap>]
Dec  9 00:55:34 pppd[5254]: rcvd [LCP ConfRej id=0x1 <pcomp> <accomp>]
This appears to be the issue - firstly your end is asking for pcomp and accomp which is rejected at the remote server (probably not an issue), and the remote server is asking for you to authenticate via PAP which you are refusing to do. I'm not sure what the line 'No auth is possible' means, but I'd start by making sure that you have your pap-secrets file set up correctly and the ppp settings are correct for PAP authentication (don't require the remote server to authenticate itself though).
[div align=\"right\"][a href=\"index.php?act=findpost&pid=151108\"][{POST_SNAPBACK}][/a][/div]

It is strange because I am not using any authentication when connecting from windows XP or direct from phone. I will play with some ppp parameters ...

so my file /etc/ppp/pap-secters was clear

Thnx anyway
[div align=\"right\"][a href=\"index.php?act=findpost&pid=151120\"][{POST_SNAPBACK}][/a][/div]

!!! Problem solved !!!

There is some problem for LCP to negotiate asyncmap with this phone.
obscured ppp option default-asyncmap solved problem.

Still I dont know why network config applet didnt find DUN on this Samsung mobile phone and I had to make hacks manually. Is there source code to that binary somewhere? Maybe I _could_ fix it :-)
merli
------
SL-C1000 - pdaxii13 5.3.3 but considering go back to beta1
Wifi D-link DCF-650W CF card - not using
bluetooth Billionton BT CF card and Samsung SGH-i310 GPRS
Pretec Cheetah 133x 4GB SD, Pretec Cheetah 80x 1GB CF