Author Topic: Pdaxii13v2  (Read 47691 times)

ZDevil

  • Hero Member
  • *****
  • Posts: 1998
    • View Profile
    • http://
Pdaxii13v2
« Reply #60 on: December 02, 2007, 06:01:58 am »
Would Meanie consider changing the versioning? pdaXii13v2 build 5.5 alpha 5.... isn't this a little bit bizarre?  
« Last Edit: December 02, 2007, 06:12:25 am by ZDevil »

Life is too precious for hacking *too much*
Visit my Z screencap gallery[/color]
My EeePC 701 Black = Debian (Lenny) on IceRocks + Transcend SDHC Class6 8GB + 2GB RAM
My Zaurus SL-C3200 = Debian EABI (kernel 2.6.24.3-yonggun) on a swapped internal Sandisk Extreme III CF 16gb
My Debian EABI feed: http://matrixmen.free.fr/zaurus/debian/
My OpenBSD/Zaurus feeds:  Link1, Link2
[/i][/font][/color][/size]

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Pdaxii13v2
« Reply #61 on: December 02, 2007, 07:46:08 am »
Quote from: ZDevil
Would Meanie consider changing the versioning? pdaXii13v2 build 5.5 alpha 5.... isn't this a little bit bizarre?  

let me explain the versioning here to stop the confusion.

pdaXii13 is the pdaXrom beta1/beta3 compatible edition
pdaXiiv2 (or pdaXii13v2) is the next generation that is compatible with pdaXrom Latest packages, ie r197/r198. it is still backwards compatible with beta1/beta3 packages


the build number of pdaXii has always increased after each release. build 5.4.9 is the last of the pdaXii13(v1), after build 5.5.0, its pdaXii13v2 or pdaXiiv2
the v2 is to signify that the compatability against pdaXrom has changed. so the name would just be pdaXiiv2. build 5.5(.0) is probably the last pdaXii image since updates to the image are going to be via the upgrade feed. once you have gone to pdaXiiv2, updates are all done via the feed, ie by updating the packages rather than running a script to patch the system like in pdaXii13(v1)

the alpha5 only comes into play because that's the version number for the pdaXiiv2 updater. remember that the pdaXii13 flash installer (updater.sh) also has a build number but you don't quote that number when you say what version of pdaXii you have. similarly, the alpha5 or whichever number that follows is the build number for the pdaXiiv2 updater/upgrader.

hope this makes sense.

pdaXiiv2 is updated by running:

ipkg update
ipkg upgrade

the ipkg warning will be removed once the pdaXiiv2 updater is not alpha anymore.
« Last Edit: December 02, 2007, 07:47:47 am by Meanie »
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

Richard

  • Newbie
  • *
  • Posts: 5
    • View Profile
Pdaxii13v2
« Reply #62 on: December 03, 2007, 09:24:39 am »
Meanie,  after my upgrade to 5.5, my card monitor no longer shows a link for USB devices, and it doesn't popup a message box when the card is safe to remove.  Not a big deal, but I kind of liked that feature.  According to my package manager, I have version 1.0.4-6.

Any ideas?

wowo123

  • Jr. Member
  • **
  • Posts: 81
    • View Profile
    • http://
Pdaxii13v2
« Reply #63 on: December 04, 2007, 02:23:34 am »
I'm running pdaXii13 an a c3200 (thx a lot for the great work!) Unfortunalety I realized too late that the fixing 64 MB NAND limit funktion had failed, so I only have 64 MB (real)root and 64 MB /user. After completing my installation of pdaXii13v1 there is no space left on (real)root, but the system is running smoothely without errors and I can install new programs in /. When I tried to do the upgrade to v2alpha5, after a short time there was an error: no space left on device and the upgrade failed. I read the discussion about free space of 30 - 40 MB in /, so I'm afraid I have to do the NAND-partitioning  to 121MB and then do a completely new install.    Or is there any other way to solve the problem?

deniscallies

  • Jr. Member
  • **
  • Posts: 73
    • View Profile
    • http://
Pdaxii13v2
« Reply #64 on: December 06, 2007, 04:43:18 am »
I still have problems with png files. I set the filter in gqview an still there are no symbols showing on desktop. Starting thunar ends with a "cannot open png file" whats the problem?

Denis

wowo123

  • Jr. Member
  • **
  • Posts: 81
    • View Profile
    • http://
Pdaxii13v2
« Reply #65 on: December 06, 2007, 07:23:27 am »
After upgrading openbox in pdaxii13 v2 to 3.4.4-2 the header lines with the titles of the displayed windows are extremely small and so is the title text font and the action icons. This isn't related to the choosen theme or to .../themes/<choosen theme>/gtk/gtkrc. I tried to edit /usr/share/themes/<choosen theme>/openbox-3/themerc but with no success. The old openbox version didn't show this issue. Any hints?

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
Pdaxii13v2
« Reply #66 on: December 06, 2007, 11:48:57 am »
Quote from: deniscallies
I still have problems with png files. I set the filter in gqview an still there are no symbols showing on desktop. Starting thunar ends with a "cannot open png file" whats the problem?

Denis
Meanie recommended to install libpng_1.2.12
post #35 in this thread.
https://www.oesf.org/forum/index.php?s=&...st&p=168563

Do you have the following in /usr/lib/
libpng12.so
libpng12.so.0
libpng12.so.0.12.0
libpng.so
libpng.so.3
libpng.so.3.12.0
« Last Edit: December 06, 2007, 12:28:30 pm by Jon_J »
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

deniscallies

  • Jr. Member
  • **
  • Posts: 73
    • View Profile
    • http://
Pdaxii13v2
« Reply #67 on: December 06, 2007, 02:55:08 pm »
i have reinstalled and upgraded. Now everything went fine. I am a little confused. I did now the same as before  
thanks, Denis

macwiz

  • Full Member
  • ***
  • Posts: 151
    • View Profile
    • http://www.macwiz.co.uk
Pdaxii13v2
« Reply #68 on: January 18, 2008, 01:11:55 pm »
Hi. Will the upgrade work on my c860 which I now have running latest pdaxii13?

Also, where are the feeds for this now, tyrannozaurus is offline.

Thanks

John
Macwiz
c860, never quite lived up to my expectations... my fault I guess
17in MacBook Pro lovely xxxx
iPhone 3G ummm
SE P990i with UIQ3. Never enough RAM.
Pocket Loox 720 used for designing ebooks. Just don't like it though!

macwiz: apple mac support in Oxfordshire
Twitter: @boffinboy

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
Pdaxii13v2
« Reply #69 on: January 18, 2008, 03:15:15 pm »
Quote from: macwiz
Hi. Will the upgrade work on my c860 which I now have running latest pdaxii13?

Also, where are the feeds for this now, tyrannozaurus is offline.

Thanks

John
I think most of the feeds are back up. Antikx has them listed here:
http://www.tyrannozaurus.com/start
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

macwiz

  • Full Member
  • ***
  • Posts: 151
    • View Profile
    • http://www.macwiz.co.uk
Pdaxii13v2
« Reply #70 on: January 28, 2008, 03:50:09 pm »
So er will it run on a c860?
Macwiz
c860, never quite lived up to my expectations... my fault I guess
17in MacBook Pro lovely xxxx
iPhone 3G ummm
SE P990i with UIQ3. Never enough RAM.
Pocket Loox 720 used for designing ebooks. Just don't like it though!

macwiz: apple mac support in Oxfordshire
Twitter: @boffinboy

macwiz

  • Full Member
  • ***
  • Posts: 151
    • View Profile
    • http://www.macwiz.co.uk
Pdaxii13v2
« Reply #71 on: February 07, 2008, 08:35:00 pm »
Quote from: macwiz
So er will it run on a c860?
Guess that's a 'no' or a 'no one's tried it'? Huh?
Macwiz
c860, never quite lived up to my expectations... my fault I guess
17in MacBook Pro lovely xxxx
iPhone 3G ummm
SE P990i with UIQ3. Never enough RAM.
Pocket Loox 720 used for designing ebooks. Just don't like it though!

macwiz: apple mac support in Oxfordshire
Twitter: @boffinboy

adf

  • Hero Member
  • *****
  • Posts: 2807
    • View Profile
    • http://
Pdaxii13v2
« Reply #72 on: February 08, 2008, 03:13:30 am »
Quote from: macwiz
Quote from: macwiz
So er will it run on a c860?
Guess that's a 'no' or a 'no one's tried it'? Huh?
speaking of pdaXii13v2 (which I use as per sig)  has meanie vanished??  I've seen  no posts from him since december
**3100 Zubuntu Jaunty,(working on Cacko dualboot), 16G A-Data internal CF, 4G SD, Ambicom WL-1100C Cf, linksys usb ethernet,  BelkinF8T020 BT card, Belkin F8U1500-E Ir kbd, mini targus usb mouse, rechargeble AC/DC powered USB hub, psp cables and battery extenders.

**6000l  Tetsuized Sharprom, installed on internal flash only 1G sd, 2G cf

hellgeist

  • Newbie
  • *
  • Posts: 5
    • View Profile
Pdaxii13v2
« Reply #73 on: March 07, 2008, 04:56:14 pm »
Quote from: Jon_J
I browsed kkazakov13's feed to see if I had any files that needed updated, that weren't caught in the upgrade process and found these 4 files needed updating.
I checked with the latest "ignored" list and none of these were on it, so I updated these 4 libraries:
glib2_2.14.0_armv5tel.ipk
libgphoto2_2.4.0_armv5tel.ipk
pango_1.18.1_armv5tel.ipk
poppler_0.5.4-1_armv5tel.ipk

When I rebooted, my fonts on the desktop and in GQview are all square boxes.
All the filenames in rox filer are square boxes also.
I'm not sure which one is causing this, but I'll go through them one-by-one and install the previous version.
I'll report back after I uninstall/reinstall prior versions and find the "culprit" that is causing these square boxes to replace my fonts.
EDIT
I found it was pango that was causing my problems, I uninstalled the newer version above and re-installed pango_1.10.0_armv5tel.ipk

I still have the *.png problem with icons, etc..

I couldn't leave well enough alone, and decided to try another upgrade to v2 on my Akita. Historically, I've gotten this same result (missing icons) so I had just stuck with beta3. But after reading your other post about solving the missing icons problem, I thought your fix might be good for Akitas, so I tried it. Unfortunately, in GQview my .png box was already checked, so that didn't change anything. Restarting left me even worse off - a blank screen and a bar, with no icons anywhere. I can add the launcher back, but apps don't open (visibly anyway).

Could be that your solution worked in a prior build of v2 but not the current one? Here's what I did:
  • Starting with pdaxii13, I did the 5.5 upgrade according to Meanie's instructions
  • I reverted to the older version of Pango as per your other post, and installed libpng_1.2.12_armv5tel.ipk. After this I couldn't see applications that opened on the desktop (even rxvt showed up mostly greyed out).
  • I removed Rox and could see wallpaper and icons again, but had to re-add icons to the control bar.
  • After this most apps weren't visible once they opened. Some were, but it was random - for instance, Abiword and Leafpad wouldn't open, but Xpdf would.
  • I added the 4 libraries listed above, and most of my icons reappeared, however there are still some apps that are missing icons - the CF/SD card utility for example, and a notepad app.
I can't find anymore leads as to what it would take to finish fixing this 5.5 upgrade, so I'm probably going to revert to beta3. Hopefully the Akita info in this post might be helpful down the road as bug testing data.

yatza

  • Newbie
  • *
  • Posts: 12
    • View Profile
    • http://
Pdaxii13v2
« Reply #74 on: March 08, 2008, 05:50:14 pm »
Quote from: hellgeist
Unfortunately, in GQview my .png box was already checked, so that didn't change anything.

Hi,
for PNG troubles, try this:
[blockquote]- uninstall whatever libpng version you have installed
- install libpng with the highest version number (currently 2.1.12)
- execute gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders
[/blockquote]
The last line is the trick, it fixed png on my Akita. Original post by walkman can be found here:
https://www.oesf.org/forum/index.php?showto...st&p=171826

Regards,
yatza