Author Topic: Bluetooth Under Debian Eabi  (Read 19654 times)

Chero

  • Hero Member
  • *****
  • Posts: 1140
    • View Profile
    • http://users.telenet.be/zaurususer/Chero
Bluetooth Under Debian Eabi
« Reply #30 on: October 07, 2007, 03:17:12 pm »
Quote from: jpmatrix
each time i plug my belkin cf bt card or when i resume from suspend, i've to type
hciattach /dev/ttyS4 bcsp
for it to work

do you know a way to do that automaticaly ?

http://lkrauss.de/zaurus/billionton-cfbt02-b2.php

Check the site above (it's in german), especially the /etc/bluetooth/uart file. My guess is you have to do something like that to make it work.

Chero.
« Last Edit: October 07, 2007, 03:18:08 pm by Chero »
HP-95LX -> HP Jornada 680 -> SL-C860 -> SL-C3100 -> Fuji u810 -> SL-C1000 -> HTC uni -> SL-C860 -> SL-C760.
March 12 2009 : Back because the Zaurus is one of a kind.
SL-C760 : pdaXrom
Pandora pre-ordered -> received and tested : great device but not my cup of tea -> sold.

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Bluetooth Under Debian Eabi
« Reply #31 on: November 01, 2007, 01:55:03 pm »
argh!
i've just tried again my belkin cf under debian eabi kernel 2.6.23 and it no longer works !!!
the card is discovered but when i hciattach it, it keeps on sending error messages that fill the screen without any chance to type something:

bcsp_recv: Error in BCSP hdr checksum
bcsp_recv: Short BCSP packet

i'll google to find out but anyone succeed in ? i'll try my msi bt dongle too
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Bluetooth Under Debian Eabi
« Reply #32 on: November 01, 2007, 06:52:17 pm »
my MSI usb BT dongle is working under debian eabi.
so i could have a bt dialup networking with my nokia gsm.
i update the top thread for now; i don't know what is happening about my Belkin CF BT...
« Last Edit: November 01, 2007, 06:52:39 pm by jpmatrix »
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

zeigerpuppy

  • Full Member
  • ***
  • Posts: 109
    • View Profile
Bluetooth Under Debian Eabi
« Reply #33 on: December 17, 2007, 06:29:56 am »
I am having a bit of trouble getting my (Socket Rev G I think) bluetooth card working
would like to use PPP via GPRS, had this working OK in pdaXrom

yonggon kernel 2.6.23.9
I have installed bluez-utils

pccardctl ident:
Socket 1
  product info: "Socket", "CF+ Personal Network Card Rev 2.5", "."
  manfid: 0x0104 0x0096
  function: 2 (serial)

hciattach: returns nothing

dmesg:
pccard: PCMCIA card inserted into slot 1
pcmcia: registering new device pcmcia1.0
pcmcia: request for exclusive IRQ could not be fulfilled.
pcmcia: the driver needs updating to supported shared IRQ lines.
ttyS0: detected caps 00000700 should be 00000100
1.0: ttyS4 at I/O 0xc48403f8 (irq = 169) is a 16C950/954

hciattach /dev/ttyS4 bcsp
BCSP initialization timed out

any ideas?
« Last Edit: December 17, 2007, 06:33:51 am by zeigerpuppy »
Zaurus C3100, CE-RH2, Socket lowpower CF Wifi, Socket CF Bluetooth
pdaXrom r198 - testing!, IceWM, Bluetooth modem: Sony Ericsson v600i with 3G.
see some howtos and tips at http://greenant.net/portal/greenant/wiki/Zaurus3100

Vitel

  • Newbie
  • *
  • Posts: 48
    • View Profile
Bluetooth Under Debian Eabi
« Reply #34 on: December 17, 2007, 08:57:53 am »
Quote from: zeigerpuppy
any ideas?
Try this:
Quote
#setserial /dev/ttyS4 baud-base 921600
#hciattach -s 921600 /dev/ttyS4 bcsp
Regards,
Vitel

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Bluetooth Under Debian Eabi
« Reply #35 on: December 17, 2007, 11:31:19 am »
Quote from: Vitel
Quote from: zeigerpuppy
any ideas?
Try this:
Quote
#setserial /dev/ttyS4 baud-base 921600
#hciattach -s 921600 /dev/ttyS4 bcsp

i'm just trying with my (working) Belkin CF BT and i have a "command not found" with the setserial command. I guess you've to install some package to have it working

which download speed do you have with your CF BT ? mine seems stuck to 9.28kb/s but i can reach more than 40 kb/s when using my USB BT dongle... i wonder if the setserial command would give better results.
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

Vitel

  • Newbie
  • *
  • Posts: 48
    • View Profile
Bluetooth Under Debian Eabi
« Reply #36 on: December 17, 2007, 01:44:05 pm »
Quote from: jpmatrix
i'm just trying with my (working) Belkin CF BT and i have a "command not found" with the setserial command. I guess you've to install some package to have it working
apt-get install setserial

Quote from: jpmatrix
which download speed do you have with your CF BT ? mine seems stuck to 9.28kb/s but i can reach more than 40 kb/s when using my USB BT dongle... i wonder if the setserial command would give better results.
I have approximately the same limit for CF BlueTooth (Billionton).
Regards,
Vitel

zeigerpuppy

  • Full Member
  • ***
  • Posts: 109
    • View Profile
Bluetooth Under Debian Eabi
« Reply #37 on: December 17, 2007, 04:22:26 pm »
Quote from: Vitel
Quote from: zeigerpuppy
any ideas?
Try this:
Quote
#setserial /dev/ttyS4 baud-base 921600
#hciattach -s 921600 /dev/ttyS4 bcsp


No joy  

with
setserial /dev/ttyS4 baud_base 921600
hciattach -s 921600 /dev/ttyS4 bcsp

I still get BCSP initialization timed out
Zaurus C3100, CE-RH2, Socket lowpower CF Wifi, Socket CF Bluetooth
pdaXrom r198 - testing!, IceWM, Bluetooth modem: Sony Ericsson v600i with 3G.
see some howtos and tips at http://greenant.net/portal/greenant/wiki/Zaurus3100

laan

  • Newbie
  • *
  • Posts: 31
    • View Profile
    • http://www.freesoftwarebench.org
Bluetooth Under Debian Eabi
« Reply #38 on: January 17, 2008, 04:04:03 pm »
Quote from: zeigerpuppy
Quote from: Vitel
Quote from: zeigerpuppy
any ideas?
Try this:
Quote
#setserial /dev/ttyS4 baud-base 921600
#hciattach -s 921600 /dev/ttyS4 bcsp


No joy  

with
setserial /dev/ttyS4 baud_base 921600
hciattach -s 921600 /dev/ttyS4 bcsp

I still get BCSP initialization timed out

After updating to last Angstrom kernel my Belkin CF BT is working perfectly, no need to change nothing, detected and attached at first, dial-up networking working fine with a V3x

SL 3100
- removed due to low performance
- removed due to gpe-calendar problems
- removed due to lack of stability
- Currently happy Cacko-lite user (Japanized)
---------------------------------- Accesories -----------------------------------------------
Sandisk - Connectplus 128 Wifi (working)
Agere - Hermes II (working)
Belkin F8T020 Bluetooth + Samsung SGH-U700(working)              
Conceptronic CONCF100 (working)
Audiovox RTM-8000 (working)
Huawei e220 HSDPA USB Modem (working with powered USB)

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Bluetooth Under Debian Eabi
« Reply #39 on: January 17, 2008, 04:44:20 pm »
Quote from: laan
Quote from: zeigerpuppy
Quote from: Vitel
Quote from: zeigerpuppy
any ideas?
Try this:
Quote
#setserial /dev/ttyS4 baud-base 921600
#hciattach -s 921600 /dev/ttyS4 bcsp


No joy  

with
setserial /dev/ttyS4 baud_base 921600
hciattach -s 921600 /dev/ttyS4 bcsp

I still get BCSP initialization timed out

After updating to last Angstrom kernel my Belkin CF BT is working perfectly, no need to change nothing, detected and attached at first, dial-up networking working fine with a V3x



great! are you talkin about this kernel ?
zImage-2.6.23-spitz-20080106233423.bin
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

laan

  • Newbie
  • *
  • Posts: 31
    • View Profile
    • http://www.freesoftwarebench.org
SL 3100
- removed due to low performance
- removed due to gpe-calendar problems
- removed due to lack of stability
- Currently happy Cacko-lite user (Japanized)
---------------------------------- Accesories -----------------------------------------------
Sandisk - Connectplus 128 Wifi (working)
Agere - Hermes II (working)
Belkin F8T020 Bluetooth + Samsung SGH-U700(working)              
Conceptronic CONCF100 (working)
Audiovox RTM-8000 (working)
Huawei e220 HSDPA USB Modem (working with powered USB)

nickk9

  • Newbie
  • *
  • Posts: 11
    • View Profile
Bluetooth Under Debian Eabi
« Reply #41 on: July 09, 2008, 10:20:13 am »
I cant get BT worked in eabi. I did all the steps from the first post and when i do 'pon provider' my phone (nokia 6310) asks about passkey, i enter the same passkey from hci.conf and then my nokia displays 'Connecting' progress bar forever. I use BT USB dongle. The very same hardware (phone, usb bt, zaurus) works fine in cacko, so i suppose its not hw problem.

hciconfig hci0 prints 'UP RUNNING PSCAN ISCAN' as it should. RX, TX error counters both zero.

The same BT binding problem i got immediate if i do 'rfcomm connect' instead of rfcomm 'bind', so i believe it is the problem with BT connection itself, not gprs/ppp issue.

Any suggestions ?
« Last Edit: July 09, 2008, 04:49:26 pm by nickk9 »

nickk9

  • Newbie
  • *
  • Posts: 11
    • View Profile
Bluetooth Under Debian Eabi
« Reply #42 on: July 10, 2008, 05:40:07 am »
Seems i solved the problem with http://www.zedd.nl/?p=8