Author Topic: Openoffice  (Read 6557 times)

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Openoffice
« on: September 30, 2007, 01:37:10 pm »
any success ?
i tried apt-get install openoffice and openoffice.org but it seems uninstalable.......
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

T3_slider

  • Full Member
  • ***
  • Posts: 125
    • View Profile
Openoffice
« Reply #1 on: September 30, 2007, 02:50:35 pm »
As in pdaXrom, I would assume that OpenOffice is a massive waste of time. It runs so incredibly slowly for me on pdaXrom that it would be faster to find another computer and use it.

I would stick with AbiWord/Gnumeric if I were you (but I'm not you, so if you really want to try, go ahead...just know that it will be horrendously slow). In my experience, OpenOffice is slow enough on a desktop PC let alone on an embedded device (It runs sufficiently well on my dual core AMD 4400+ processor with 2 Gb of RAM, but on my older computers it takes copious amounts of time starting up).
Conics SL-C3200 running pdaXrom beta3 and XFCE with a Planex WiFi CF card.

Slackware rules!

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
Openoffice
« Reply #2 on: September 30, 2007, 03:11:38 pm »
If you REALLY want OOo on your Z, consider running it remotely over SSH with X forwarding (or just use Abiword/Gnumeric). It will be MUCH faster than trying to run it locally, which will most likely be like trying to run Vista in Bochs on your Z (OK, maybe not that bad, but you get the idea).
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo

T3_slider

  • Full Member
  • ***
  • Posts: 125
    • View Profile
Openoffice
« Reply #3 on: September 30, 2007, 04:16:56 pm »
Capn_Fish makes a good point -- I have run OOo over ssh on my C3200 at reasonable speeds (but you are tethered in the sense that you MUST be near a WiFi hotspot with a GOOD signal -- or use an ethernet card or something I guess...).
Conics SL-C3200 running pdaXrom beta3 and XFCE with a Planex WiFi CF card.

Slackware rules!

ZDevil

  • Hero Member
  • *****
  • Posts: 1998
    • View Profile
    • http://
Openoffice
« Reply #4 on: September 30, 2007, 04:38:10 pm »
The biggest roadblock is java, i think...

Life is too precious for hacking *too much*
Visit my Z screencap gallery[/color]
My EeePC 701 Black = Debian (Lenny) on IceRocks + Transcend SDHC Class6 8GB + 2GB RAM
My Zaurus SL-C3200 = Debian EABI (kernel 2.6.24.3-yonggun) on a swapped internal Sandisk Extreme III CF 16gb
My Debian EABI feed: http://matrixmen.free.fr/zaurus/debian/
My OpenBSD/Zaurus feeds:  Link1, Link2
[/i][/font][/color][/size]

adf

  • Hero Member
  • *****
  • Posts: 2807
    • View Profile
    • http://
Openoffice
« Reply #5 on: September 30, 2007, 10:57:13 pm »
Quote from: ZDevil
The biggest roadblock is java, i think...
I wonder if going kde and using the koffice stuff would be better?  You could even use a diffreent wm, like xfce, if you don't mind longish load times while kde loads ist "K" and dcop stuff...

maybe it would be better, maybe not. at least w/ debian it only takes and "apt-get install koffice" to find out- though it will pull most of kde with it, and use noticeable space
**3100 Zubuntu Jaunty,(working on Cacko dualboot), 16G A-Data internal CF, 4G SD, Ambicom WL-1100C Cf, linksys usb ethernet,  BelkinF8T020 BT card, Belkin F8U1500-E Ir kbd, mini targus usb mouse, rechargeble AC/DC powered USB hub, psp cables and battery extenders.

**6000l  Tetsuized Sharprom, installed on internal flash only 1G sd, 2G cf

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Openoffice
« Reply #6 on: October 01, 2007, 07:12:55 am »
well,
i've apt-get installed kdepim... and launched Korganiser.... it tooks about 3mn to launch but after that it seems usable.....

about openoffice, i least i would like something to view PPT & PPS files under my deb......
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

Meanie

  • Hero Member
  • *****
  • Posts: 2803
    • View Profile
    • http://www.users.on.net/~hluc/myZaurus/
Openoffice
« Reply #7 on: October 01, 2007, 07:37:44 am »
it takes about 3-4 minutes to load openoffice, however, the problem is that only the older version of openoffice is available which does not support open document format yet which on the other hand is supported by abiword...
SL-C3000 - pdaXii13 build5.4.9 (based on pdaXrom beta3) / SL-C3100 - Sharp ROM 1.02 JP (heavily customised)
Netgear MA701 CF, SanDisk ConnectPlus CF, Socket Bluetooth CF, 4GB Kingston CF,  4GB pqi SD, 4GB ChoiceOnly SD, 2GB SanDisk SD USB Plus, 1GB SanDisk USB Plus, 1GB Transcend SD, 2GB SanDisk MicroSD with SD adaptor, Piel Frama Leather Case, GoldX 5-in-1 USB cable, USB hub, USB mouse, USB keyboard, USB ethernet, USB HDD, many other USB accessories...
(Zaurus SL-C3000 owner since March 14. 2005, Zaurus SL-C3100 owner since September 21. 2005)
http://members.iinet.net.au/~wyso/myZaurus - zBook3K

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Openoffice
« Reply #8 on: October 02, 2007, 07:40:22 am »
well, after apt-get install koffice (about one hour later!),
kpresenter launchs itself, i can see a window to open a presenter file then it crashs with this error :

ICE default IO error handler doing an exit()

any help ? (i'm googling to find a clue)
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

adf

  • Hero Member
  • *****
  • Posts: 2807
    • View Profile
    • http://
Openoffice
« Reply #9 on: October 02, 2007, 07:56:20 pm »
Quote from: jpmatrix
well, after apt-get install koffice (about one hour later!),
kpresenter launchs itself, i can see a window to open a presenter file then it crashs with this error :

ICE default IO error handler doing an exit()

any help ? (i'm googling to find a clue)
do you have a decent amount of swap mounted and available?
**3100 Zubuntu Jaunty,(working on Cacko dualboot), 16G A-Data internal CF, 4G SD, Ambicom WL-1100C Cf, linksys usb ethernet,  BelkinF8T020 BT card, Belkin F8U1500-E Ir kbd, mini targus usb mouse, rechargeble AC/DC powered USB hub, psp cables and battery extenders.

**6000l  Tetsuized Sharprom, installed on internal flash only 1G sd, 2G cf

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Openoffice
« Reply #10 on: October 04, 2007, 03:48:11 pm »
i've just tried to create a 256 Mb swapfile then swapon it
tried to launch kpresenter : same error message
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Openoffice
« Reply #11 on: December 19, 2007, 03:36:50 pm »
i've just read this message from arm mailing list :

Quote
There are working OOo RPMS (sans Java, though) for Fedora/ARM (EABI):
http://blogs.linux.ie/caolan/2007/11/20/arm-eabi-port/

i've just download them all and tried to convert them to .deb with alien but the process fails...

any help ?

EDITED: i'm now trying to get the oabi version and apply the oabi/eabi patches listed here:
http://blogs.linux.ie/caolan/2007/11/20/arm-eabi-port/

OABI people can yet try this version:
http://ooo.services.openoffice.org/pub/Ope.../armoabiport01/
« Last Edit: December 19, 2007, 03:41:57 pm by jpmatrix »
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Openoffice
« Reply #12 on: December 19, 2007, 05:35:24 pm »
Quote from: jpmatrix
i've just read this message from arm mailing list :

Quote
There are working OOo RPMS (sans Java, though) for Fedora/ARM (EABI):
http://blogs.linux.ie/caolan/2007/11/20/arm-eabi-port/

i've just download them all and tried to convert them to .deb with alien but the process fails...

any help ?

EDITED: i'm now trying to get the oabi version and apply the oabi/eabi patches listed here:
http://blogs.linux.ie/caolan/2007/11/20/arm-eabi-port/

OABI people can yet try this version:
http://ooo.services.openoffice.org/pub/Ope.../armoabiport01/

no luck : i tried to uncompress the rpm packages as they were eabi. whatever i start (soffice, scalc,...), the program starts, i can see the openoffice slash creen and it seg faults...
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

Amruth

  • Newbie
  • *
  • Posts: 1
    • View Profile
Openoffice
« Reply #13 on: May 12, 2008, 06:15:23 am »
Quote from: jpmatrix
Quote from: jpmatrix
i've just read this message from arm mailing list :

Quote
There are working OOo RPMS (sans Java, though) for Fedora/ARM (EABI):
http://blogs.linux.ie/caolan/2007/11/20/arm-eabi-port/

i've just download them all and tried to convert them to .deb with alien but the process fails...

any help ?

EDITED: i'm now trying to get the oabi version and apply the oabi/eabi patches listed here:
http://blogs.linux.ie/caolan/2007/11/20/arm-eabi-port/

OABI people can yet try this version:
http://ooo.services.openoffice.org/pub/Ope.../armoabiport01/

no luck : i tried to uncompress the rpm packages as they were eabi. whatever i start (soffice, scalc,...), the program starts, i can see the openoffice slash creen and it seg faults...

Hi,

I have a basic question about open office. I want to download the source code for OpenOffice Writer. Could you please let me know any link where an i get the source code.  when i was searching for the source code, I got these files to in two formats, they are
OOo_2.4.0_LinuxIntel_install_en-US_deb.tar.gz
and
OOo_2.4.0_LinuxIntel_install_wJRE_en-US.tar.gz
one contains files in debian format and the other as a set of rpm files. With these files i can only upgrade my existing office version.  My intention is to port open office writer into  hand held devices with Intel's  PXA 255 processor and Omaps processor. Could you please help me out in getting this thing done !!!

Thanks in Advance,

Capn_Fish

  • Hero Member
  • *****
  • Posts: 2342
    • View Profile
    • http://
Openoffice
« Reply #14 on: May 12, 2008, 07:38:57 am »
SL-C750- pdaXrom beta 1 (mostly unused)
Current distro: Gentoo