Author Topic: Key Repeat Speed  (Read 6378 times)

dlj0

  • Full Member
  • ***
  • Posts: 218
    • View Profile
Key Repeat Speed
« on: December 04, 2007, 10:24:11 pm »
I vaguely recall being able to set the keyboard repeat speed in either titchy or Angstom.  It is too fast for my taste in debian; I'd like to slow it down.  Holding a key down even a small fraction of a second (much faster than on my desktop) causes the key to repeat.  How do you do that?
Zaurus:  SL C3100
ROM:  eabi debian/sid

2or0

  • Full Member
  • ***
  • Posts: 217
    • View Profile
    • http://
Key Repeat Speed
« Reply #1 on: December 05, 2007, 05:00:39 am »
Quote from: dlj0
I vaguely recall being able to set the keyboard repeat speed in either titchy or Angstom.  It is too fast for my taste in debian; I'd like to slow it down.  Holding a key down even a small fraction of a second (much faster than on my desktop) causes the key to repeat.  How do you do that?

The 'xset' command is useful to change the speed of rate of key.
xset r rate 1000
or change the number if it is too fast or too slow.
« Last Edit: December 05, 2007, 05:02:35 am by 2or0 »
Zaurus SL-C3200 with Debian armel of kernel 2.6.24-yonggun
Ambicom WL1100C WLAN
1 GB Sandisk SD / 1 GB Lexar SD / 256 MB Dane-Elec CF
-----
Blog http://yonggun.tistory.com (English/Korean)

dlj0

  • Full Member
  • ***
  • Posts: 218
    • View Profile
Key Repeat Speed
« Reply #2 on: December 05, 2007, 09:22:14 am »
Quote from: 2or0
Quote from: dlj0
I vaguely recall being able to set the keyboard repeat speed in either titchy or Angstom.  It is too fast for my taste in debian; I'd like to slow it down.  Holding a key down even a small fraction of a second (much faster than on my desktop) causes the key to repeat.  How do you do that?

The 'xset' command is useful to change the speed of rate of key.
xset r rate 1000
or change the number if it is too fast or too slow.

No joy:  

xset r rate 1000
server does not have extension for "r rate" option

This is with debian/eabi (cortez' kernel) and xserver-kdrive-fbdev 1:1.3.0.0-r19  I'd be happy to try another server if someone could suggest one.
Zaurus:  SL C3100
ROM:  eabi debian/sid

jpmatrix

  • Hero Member
  • *****
  • Posts: 1014
    • View Profile
    • http://matrixmen.free.fr
Key Repeat Speed
« Reply #3 on: December 05, 2007, 10:30:02 am »
Quote from: dlj0
No joy:  

xset r rate 1000
server does not have extension for "r rate" option

This is with debian/eabi (cortez' kernel) and xserver-kdrive-fbdev 1:1.3.0.0-r19  I'd be happy to try another server if someone could suggest one.

same result for me with angstrom kernel 2.6.23 & zdevil rootfs...

this command should work under X, but is there a non X command too ?
**Fujitsu U1010 !!!  
**ex-Zaurus SL-C3000 owner with Debian kernel 2.6.24-yonggun

2or0

  • Full Member
  • ***
  • Posts: 217
    • View Profile
    • http://
Key Repeat Speed
« Reply #4 on: December 05, 2007, 11:48:33 am »
kdrive doesn't seem to support change of the repeat rate of key. Only I could find the command to turn off key repeat.
In console: setterm -repeat off
in X: xset -r
Zaurus SL-C3200 with Debian armel of kernel 2.6.24-yonggun
Ambicom WL1100C WLAN
1 GB Sandisk SD / 1 GB Lexar SD / 256 MB Dane-Elec CF
-----
Blog http://yonggun.tistory.com (English/Korean)

gojira

  • Full Member
  • ***
  • Posts: 122
    • View Profile
Key Repeat Speed
« Reply #5 on: January 18, 2009, 05:53:35 am »
some other options would be: using the xorg server (https://www.oesf.org/forum/index.php?showtopic=26362 https://www.oesf.org/forum/index.php?showtopic=25433) adding xkb to kdrive (https://www.oesf.org/forum/index.php?showtopic=26345) or setting it in the kernel (?)

turning autorepeat off completely is better than nothing but it's annoying to lose autorepeat for space delete return and the cursor keys

attached is my script to turn off autorepeat for normal characters but have it on for editing characters
Zaurus SL-C3200 Debian EABI / Sharp ROM (tetsu v18j), Socket CF Bluetooth (Rev E), BT747 GPS, Canon K30225 CF Wifi.  RIP: Zaurus SL-C860 Sharp ROM (1.40JP).