Author Topic: Multikernel Won't Flash On My Device  (Read 9922 times)

RX Shorty

  • Full Member
  • ***
  • Posts: 124
    • View Profile
    • http://www.lindoboom.nl
Multikernel Won't Flash On My Device
« on: June 20, 2009, 05:42:54 pm »
Hello all,

Well tried the how to on: Here
But when I try to flash to the Mulitkernel it won't work.
It doesn't go past the Runtime 5...

Any ideas?

Thanks!

« Last Edit: June 21, 2009, 07:18:40 pm by RX Shorty »
Owning a Zaurus SL-C860, SL-C3200, SL-6000, Netwalker
Got the GPD Win!

Chero

  • Hero Member
  • *****
  • Posts: 1140
    • View Profile
    • http://users.telenet.be/zaurususer/Chero
Multikernel Won't Flash On My Device
« Reply #1 on: June 21, 2009, 02:47:29 pm »
Quote from: RX Shorty
Hello all,

Well tried the how to on: Here
But when I try to flash to the Mulitkernel it won't work.
It doesn't go past the Runtime 5...

Any ideas?

Thanks!


Are you using the correct kernel for your device ?

I've just sent you an email containing the flash script and kernel I used on the 860 you're trying to flash ...  

also check this site : http://home.arcor.de/bnsmb/public/htdocs/z...he_SL_C760.html
(in German, but easy to read even if you don't speak German)

Have fun,
Chero.
« Last Edit: June 21, 2009, 02:52:44 pm by Chero »
HP-95LX -> HP Jornada 680 -> SL-C860 -> SL-C3100 -> Fuji u810 -> SL-C1000 -> HTC uni -> SL-C860 -> SL-C760.
March 12 2009 : Back because the Zaurus is one of a kind.
SL-C760 : pdaXrom
Pandora pre-ordered -> received and tested : great device but not my cup of tea -> sold.

RX Shorty

  • Full Member
  • ***
  • Posts: 124
    • View Profile
    • http://www.lindoboom.nl
Multikernel Won't Flash On My Device
« Reply #2 on: June 21, 2009, 02:54:29 pm »
Hey

Thanks for the email.
Now I have putted those 2 files on it...
Going to try your link thanks
Owning a Zaurus SL-C860, SL-C3200, SL-6000, Netwalker
Got the GPD Win!

Chero

  • Hero Member
  • *****
  • Posts: 1140
    • View Profile
    • http://users.telenet.be/zaurususer/Chero
Multikernel Won't Flash On My Device
« Reply #3 on: June 21, 2009, 02:58:59 pm »
Just a tip :
It helps if you tell people what device you are trying to flash, maybe put it in your sig.

Good luck,
Chero.
HP-95LX -> HP Jornada 680 -> SL-C860 -> SL-C3100 -> Fuji u810 -> SL-C1000 -> HTC uni -> SL-C860 -> SL-C760.
March 12 2009 : Back because the Zaurus is one of a kind.
SL-C760 : pdaXrom
Pandora pre-ordered -> received and tested : great device but not my cup of tea -> sold.

RX Shorty

  • Full Member
  • ***
  • Posts: 124
    • View Profile
    • http://www.lindoboom.nl
Multikernel Won't Flash On My Device
« Reply #4 on: June 21, 2009, 03:34:59 pm »
Ahh thanks.

Yeah putted in the subtitle that it´s for a 860.
Is it possible that I can´t flash through SD card?
Compact flash does work though
Owning a Zaurus SL-C860, SL-C3200, SL-6000, Netwalker
Got the GPD Win!

Chero

  • Hero Member
  • *****
  • Posts: 1140
    • View Profile
    • http://users.telenet.be/zaurususer/Chero
Multikernel Won't Flash On My Device
« Reply #5 on: June 21, 2009, 03:43:53 pm »
Quote from: RX Shorty
Ahh thanks.

Yeah putted in the subtitle that it´s for a 860.
Is it possible that I can´t flash through SD card?
Compact flash does work though

SD should work, but only when you use one smaller than 1Gb, and correctly partitionned and formatted. It can be a real pain to find the correct "settings" for an SD to be able to use it to flash. (I'm sure it works, I use an SD to flash)

If you have a CF, use that one to make life easier.

Greetz,
Chero.
HP-95LX -> HP Jornada 680 -> SL-C860 -> SL-C3100 -> Fuji u810 -> SL-C1000 -> HTC uni -> SL-C860 -> SL-C760.
March 12 2009 : Back because the Zaurus is one of a kind.
SL-C760 : pdaXrom
Pandora pre-ordered -> received and tested : great device but not my cup of tea -> sold.

RX Shorty

  • Full Member
  • ***
  • Posts: 124
    • View Profile
    • http://www.lindoboom.nl
Multikernel Won't Flash On My Device
« Reply #6 on: June 21, 2009, 03:48:34 pm »
Ahh didn't know about that it doesn't allow to exceed 1 GB.
That explains a lot.
I just bought myself a 8 GB CF, that works pretty well indeed.
Trying to install Zubuntu and try to get the Wifi card that you included working.

Thanks
Owning a Zaurus SL-C860, SL-C3200, SL-6000, Netwalker
Got the GPD Win!

klaxon

  • Newbie
  • *
  • Posts: 21
    • View Profile
Multikernel Won't Flash On My Device
« Reply #7 on: June 21, 2009, 06:00:02 pm »
RX Shorty can you dualboot Zubuntu with Cacko ? It's not working for me with my C860.

RX Shorty

  • Full Member
  • ***
  • Posts: 124
    • View Profile
    • http://www.lindoboom.nl
Multikernel Won't Flash On My Device
« Reply #8 on: June 22, 2009, 03:42:41 pm »
Not yet, still working on some things

Cannot flash the multikernel... it keeps asking for the tools...
« Last Edit: June 22, 2009, 04:49:02 pm by RX Shorty »
Owning a Zaurus SL-C860, SL-C3200, SL-6000, Netwalker
Got the GPD Win!

Chero

  • Hero Member
  • *****
  • Posts: 1140
    • View Profile
    • http://users.telenet.be/zaurususer/Chero
Multikernel Won't Flash On My Device
« Reply #9 on: June 23, 2009, 01:56:00 am »
Quote from: RX Shorty
Not yet, still working on some things

Cannot flash the multikernel... it keeps asking for the tools...

Try to use the Angstrom updater script, but only put the script and "zImage.bin" (= multibootkernel) on the card.

Chero.
HP-95LX -> HP Jornada 680 -> SL-C860 -> SL-C3100 -> Fuji u810 -> SL-C1000 -> HTC uni -> SL-C860 -> SL-C760.
March 12 2009 : Back because the Zaurus is one of a kind.
SL-C760 : pdaXrom
Pandora pre-ordered -> received and tested : great device but not my cup of tea -> sold.

klaxon

  • Newbie
  • *
  • Posts: 21
    • View Profile
Multikernel Won't Flash On My Device
« Reply #10 on: June 23, 2009, 07:44:16 am »
With zImage-kexecboot-2.6.26-r12-c7x0.bin I can't dualboot Zubuntu and Pdaxrom.
Zubuntu works well but I have a "init not found" for Pdaxrom.
I used /proc/cmdline for the kernel-cmdline file.

I didn't retry with Cacko.
« Last Edit: June 23, 2009, 08:43:13 am by klaxon »

RX Shorty

  • Full Member
  • ***
  • Posts: 124
    • View Profile
    • http://www.lindoboom.nl
Multikernel Won't Flash On My Device
« Reply #11 on: June 30, 2009, 05:58:54 pm »
Well managed to fix the problem:

* Angstrom installed (deleted
* Cacko, very nice, but somehow outdated
* PdaXrom, the Uboot installation didn't let me Zaurus boot, so restored the NAND.
* Tried to install the multikernel booter again, and it worked!
* Running Zubuntu, but the mouse isn't working well, it keeps drawing selection forms, so I can't click a thing.
Any ideas?
Owning a Zaurus SL-C860, SL-C3200, SL-6000, Netwalker
Got the GPD Win!

ToneBlind

  • Jr. Member
  • **
  • Posts: 88
    • View Profile
Multikernel Won't Flash On My Device
« Reply #12 on: June 30, 2009, 07:57:46 pm »
The problem that you are having with the mouse might be the calibration of the screen (it seems it's registering constant pressure. and that's why it doesn't let you click on anything but instead is on selection mode.) I didn't have to calibrate myself, but I think there is a calibration script (ts_calibrate, or something like that.)

Did you get Cacko running off SD by any chance? I'm working on it but so far no luck. I've tried different approaches.

ToneBlind

  • Jr. Member
  • **
  • Posts: 88
    • View Profile
Multikernel Won't Flash On My Device
« Reply #13 on: June 30, 2009, 08:02:53 pm »
Quote from: klaxon
With zImage-kexecboot-2.6.26-r12-c7x0.bin I can't dualboot Zubuntu and Pdaxrom.
Zubuntu works well but I have a "init not found" for Pdaxrom.
I used /proc/cmdline for the kernel-cmdline file.

I didn't retry with Cacko.
I'm having the same problem with Cacko (I'm trying to install Cacko to the SD card as well.) I get a kernel panic with the "init not found" message. I managed to extract a NAND backup image, but then I figured that copying the image directly would work, since when the kernel loads the only thing it looks at is the absolute offset in kb of the root area. Still I haven't had any luck though. If I could get kexecboot to look at CF cards I think I might try something different, but it doesn't seem to do that (contrary to the description in the Omegamoon site.)

Chero

  • Hero Member
  • *****
  • Posts: 1140
    • View Profile
    • http://users.telenet.be/zaurususer/Chero
Multikernel Won't Flash On My Device
« Reply #14 on: July 01, 2009, 06:25:09 am »
Quote from: RX Shorty
Well managed to fix the problem:

* Angstrom installed (deleted
* Cacko, very nice, but somehow outdated
* PdaXrom, the Uboot installation didn't let me Zaurus boot, so restored the NAND.
* Tried to install the multikernel booter again, and it worked!
* Running Zubuntu, but the mouse isn't working well, it keeps drawing selection forms, so I can't click a thing.
Any ideas?

check this thread : https://www.oesf.org/forum/index.php?showto...=26510&st=0

Have fun,
Chero.
HP-95LX -> HP Jornada 680 -> SL-C860 -> SL-C3100 -> Fuji u810 -> SL-C1000 -> HTC uni -> SL-C860 -> SL-C760.
March 12 2009 : Back because the Zaurus is one of a kind.
SL-C760 : pdaXrom
Pandora pre-ordered -> received and tested : great device but not my cup of tea -> sold.