Author Topic: Problem Booting  (Read 3729 times)


  • Full Member
  • ***
  • Posts: 104
    • View Profile
Problem Booting
« on: October 23, 2010, 08:07:58 pm »

i use a sl-c3100
i have untar zubuntu-desktop and   spitz-root_addition, taken from :    :    zubuntu 2 for spitz.
on my sd card  (/dev/sda1)
on my sd card i have a swap (/dev/sda2)

on my hda1-2-3-5, i have a debian.

since today, i installed kexecboot (i tried 2.6.2, 2.6.34-rc-3 and 2.6.34-rc4), i can't boot on my debian, kexecboot don't see it (before i use u-boot).
kexecboot sees the zubuntu   zImage on " /mnt/boot/zImage" on sda1. when i try to load it, just, after recognizing the partition on my hda
zubuntu blocks (won't continue) on this message :

     waiting for root device /dev/mmcblk0p1....

the only key of the keyboard who is "recognize" at this point is "on/off"... it tells me that i pressed it when i push it, but the zaurus won't stop. to stop it, i have to remove the battery and the power cable.

what can i do to make something work (old debian, zubuntu... other) ?

ask for others details if needed.
Thank you :)


edit 1 : problem solved after reinstall total of cacko and reinstall zubuntu

edit 2 : after a while booting zubuntu or debian, both on sd card, with kexecboot,  problem reappeared (i don't know why).
it seems that only reinstall cacko doesn't help the problem.
i remembered installing android after cacko. and then, reflashed with kexecboot (2.6.34-rc4) .
but no, still doesn't work.

i obviously miss something, but what ?
does anyone as a clue to pass this :
"waiting for root device /dev/mmcblk0p1..." ???
thank you a lot
« Last Edit: October 24, 2010, 01:15:12 pm by flux »


  • Full Member
  • ***
  • Posts: 161
    • View Profile
Problem Booting
« Reply #1 on: October 25, 2010, 06:58:11 pm »
Some copies of kexecboot out there don't support SD cards well, and some not at all.  Even some 1Gig cards have problems.  I wish I could recommend some that work, but I just gave up and moved everything to CF.
Sharp SL-C3100 - pdaXrom Beta 3
Sharp SL-6000L - pdaXrom Beta 1