Author Topic: Strange behavior when I did a modprobe command  (Read 1474 times)


  • Sr. Member
  • ****
  • Posts: 409
    • View Profile
    • http://
Strange behavior when I did a modprobe command
« on: March 19, 2020, 06:42:06 am »
I've compiled some modules for my TV dvb  stick. When I insert my dvb stick in the usb port , debian loads only some modules. Unfortunately dvb-core, dvb-usb , dib8000 and dvb-usb-dib0700 didn't load. When I've  tried to load them manually a message has appeared telling  that the device or resource is busy.
But when I  shutdown cosmo and plug first my dvb stick on the usb port ,and  after turning on cosmo, the drivers were loaded correctly. Also if I compile the kernel with these drivers inside kernel ( like a monolithic kernel ) , the dvb stick works correctly when I insert it in the usb port. The config is identical except about config_XXX=m  and  config_XXX=y. I think maybe the problem  is  initrd.gz. I've extracted it, but didn't see any pre loaded module.
Thank you all

Just add dvb_usb into etc/initramfs-tools/modules  and run  again  mkinitramfs -o /home/gemini/initramfs-$(uname -r)
After this create a linux image :

./mkbootimg --kernel cosmo/arch/arm64/boot/Image.gz-dtb --ramdisk initramfs-4.4.146 --base 0x40078000 --second_offset 0x00e88000 --cmdline "bootopt=64S3,32N2,64N2 log_buf_len=4M" --kernel_offset 0x00008000 --ramdisk_offset 0x14f88000 --tags_offset 0x13f88000 --pagesize 2048 -o linux-boot-mod.img

and :

dd if=linux-boot-mod.img of=/dev/disk/by-partlabel/DEBIAN_KDE

After boot lsmod shows dvb_usb , dvb_core and rc_core .

and when I 've inserted my dibcom device into usb port :


SOLVED . Better than load all the modules in a monolithic kernel .
« Last Edit: March 25, 2020, 10:19:47 am by cam1965 »


  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: Strange behavior when I did a modprobe command
« Reply #1 on: April 22, 2021, 11:36:02 am »
Thanks, most of it worked for me (except I had to change the path to cosmo).

When I rebooted I lost the use of sudo, so I still have some more tinkering to do :( (messing around with custom kernel to get bluetooth working).
Nokia N900, Cosmo Communicator