Author Topic: 3.5.1 problems  (Read 5336 times)

-G-

  • Newbie
  • *
  • Posts: 15
    • View Profile
3.5.1 problems
« on: September 24, 2004, 01:20:32 pm »
Hi,
I flashed with 3.5.1 wihtout any problems.
I can connect from SuSE 9.1 to the Z using Qtopia, but I cannot get any programs installed.
I have http://openzaurus.org/official/unstable/3.5.1/feed/ in the settings of Qtopia Desktop as a Package feed, but no new programmes are shown.

I desperately need to install Korganizer or KOPI, but I haven't got a clue on how to do it. I would be most grateful for any help

The packages copied (using scp) to the cf card, do not seem to be detected by the Package Manager. Any clues?

Thanks,

-G-

cycojesus

  • Jr. Member
  • **
  • Posts: 60
    • View Profile
    • http://cycojesus.free.fr
3.5.1 problems
« Reply #1 on: September 24, 2004, 03:03:37 pm »
open a terminal and type ipkg install /mnt/cf/<your-package>.ipk
SL-6000L : kexecboot and ArmedZed (on SD) & OpenZaurus/Opie (on flash)

dansawyer

  • Sr. Member
  • ****
  • Posts: 293
    • View Profile
    • http://
3.5.1 problems
« Reply #2 on: September 24, 2004, 03:22:35 pm »
You must make sure your Z networking is fully set up. Make sure the Z has a nameserver configured and that NAT or MASQ, etc. is set up on the server/router box. You can test this; if you can ping a site my name from the Z console it should be working.

Dan

-G-

  • Newbie
  • *
  • Posts: 15
    • View Profile
3.5.1 problems
« Reply #3 on: September 25, 2004, 04:26:48 am »
Quote
open a terminal and type ipkg install /mnt/cf/<your-package>.ip

Thanks. I thought that the Package Manager would see the files in the cf card (this happened in version 3.3.5, but not now). Is this supposed to be like this?

Quote
You must make sure your Z networking is fully set up. Make sure the Z has a nameserver configured and that NAT or MASQ, etc. is set up on the server/router box. You can test this; if you can ping a site my name from the Z console it should be working.

Dan,
I am afraid that I have not managed to sort this out, so I am trying to download the files and install them from the cf card.

I set the "masq" option in the firewall configuration, but I am not sure what to do next.  
Is the nameserver the ip address of my desktop?

Is there anybody with SuSE 9.1 to help on how to connect to the internet with the Z through USB? (so far I can use ssh and QTopia Desktop, so the connection between the Z and the desktop works OK. My problem is perhaps the firewall)

Cheers

-G-

cycojesus

  • Jr. Member
  • **
  • Posts: 60
    • View Profile
    • http://cycojesus.free.fr
3.5.1 problems
« Reply #4 on: September 25, 2004, 04:41:13 am »
Quote
Quote
open a terminal and type ipkg install /mnt/cf/<your-package>.ip

Thanks. I thought that the Package Manager would see the files in the cf card (this happened in version 3.3.5, but not now). Is this supposed to be like this?

Quote
You must make sure your Z networking is fully set up. Make sure the Z has a nameserver configured and that NAT or MASQ, etc. is set up on the server/router box. You can test this; if you can ping a site my name from the Z console it should be working.

Dan,
I am afraid that I have not managed to sort this out, so I am trying to download the files and install them from the cf card.

I set the "masq" option in the firewall configuration, but I am not sure what to do next.  
Is the nameserver the ip address of my desktop?

Is there anybody with SuSE 9.1 to help on how to connect to the internet with the Z through USB? (so far I can use ssh and QTopia Desktop, so the connection between the Z and the desktop works OK. My problem is perhaps the firewall)

Cheers

-G-
I personnaly made a mirror of the feeds, put them on a CF card and then add the following lines into /etc/ipkg.conf :
Quote
src CF_feed file:///mnt/cf/oz/feed
src CF_upgrades file:///mnt/cf/oz/upgrades

then you have two choices :
* from the command-line :
Quote
$ ipkg update
$ ipkg upgrade
$ ipkg install <whatever_package_you_want>

* from GUI :
Quote
1/ install opie-aqpkg
2/ from the menu -> update lists
SL-6000L : kexecboot and ArmedZed (on SD) & OpenZaurus/Opie (on flash)

-G-

  • Newbie
  • *
  • Posts: 15
    • View Profile
3.5.1 problems
« Reply #5 on: September 25, 2004, 06:01:46 am »
Quote
open a terminal and type ipkg install /mnt/cf/<your-package>.ip

I tried this with opie-tabmanager and it seems to have installed it (although portmat returned an error "1", I think).
However I do not see the tabmanager icon anywhere!
Is there anything else I must do so Opie shows it? I rebooted, but still nothing appears.
(sorry for being so clue-less).

Thanks again.

-G-

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
3.5.1 problems
« Reply #6 on: September 25, 2004, 10:36:48 am »
Quote
I thought that the Package Manager would see the files in the cf card (this happened in version 3.3.5, but not now). Is this supposed to be like this?

aqpkg is not finished so I've read and eventually will do what it uesd to (list all available local packages as well as those in feeds).

Quote
Is there anything else I must do so Opie shows it? I rebooted, but still nothing
(sorry for being so clue-less).

You rebooted, so this may not apply (as it ought to be done on reboot) - try ipkg-link:
'ipkg-link mount /mnt/cf' (assuming that's where you put it)

Other than that, check the status file to see what there were no errors creating the symlink, check to see whether the .desktop file is actually in /opt/QtPalmtop/apps/, then wether it's on the /mnt/cf mount, check if it's in the package, etc.


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

-G-

  • Newbie
  • *
  • Posts: 15
    • View Profile
3.5.1 problems
« Reply #7 on: September 25, 2004, 11:20:34 am »
Quote
You rebooted, so this may not apply (as it ought to be done on reboot) - try ipkg-link:
'ipkg-link mount /mnt/cf' (assuming that's where you put it)

Erm... what does that do? I suspect that the package was installed in the ram area.

I also tried the checkers game, same story. It does not appear anywhere.
I cannot believe that I am the only one with this problem...

Thanks,
-G-

lardman

  • Hero Member
  • *****
  • Posts: 4512
    • View Profile
    • http://people.bath.ac.uk/enpsgp/Zaurus/
3.5.1 problems
« Reply #8 on: September 25, 2004, 11:31:03 am »
Quote
Erm... what does that do? I suspect that the package was installed in the ram area.
:-D

ipkg-link creates symlinks from wherever you installed the package so that it appears to be on the root (e.g. the file /mnt/ram/opt/QtPalmtop/bin/jeode is linked to /opt/QtPalmtop/bin/jeode, etc.). This, therefore, applies to anything installed anywhere other than / (root), even ram.

Did you get any errors when you installed them?


Si
C750 OZ3.5.4 (GPE, 2.6.x kernel)
SL5500 OZ3.5.4 (Opie)
Nokia 770
Serial GPS, WCF-12, Socket Ethernet & BT, Ratoc USB
WinXP, Mandriva

-G-

  • Newbie
  • *
  • Posts: 15
    • View Profile
3.5.1 problems
« Reply #9 on: September 27, 2004, 09:09:36 am »
Quote
ipkg-link creates symlinks from wherever you installed the package

In the 3.3.5 version, the ipkg-link must have been executed automatically after installing every package, so I did not know of this linking afterwards.
Now, everything seems to install from the cf card (thanks lardman & cycojesus!)

Cheers

-G-