Author Topic: Bluemonkey Bluetooth (bt0100m) On C860  (Read 3010 times)

lenkov

  • Newbie
  • *
  • Posts: 4
    • View Profile
Bluemonkey Bluetooth (bt0100m) On C860
« on: December 10, 2004, 11:45:59 pm »
I bought a BlueMonkey CF Bluetooth card that identify itself as BT0100M. I tried to set it up following the instructions from:

http://www.zaurususergroup.com/modules.php...ename=Bluetooth

but this don't help me at all.  I don't get a bluetooth icon on the bar (after I unplug/plug the card) and hciconfig is not giving anything.

I have C860 with Cacko 1.21B, 1Gb SD.

Thanks,

ElZauruso

  • Newbie
  • *
  • Posts: 6
    • View Profile
Bluemonkey Bluetooth (bt0100m) On C860
« Reply #1 on: December 11, 2004, 08:32:33 am »
Hi,

I had the same BT0100M Problem... until I found the Thread below, named
"DCF650 Bluetooth...." ...

lenkov

  • Newbie
  • *
  • Posts: 4
    • View Profile
Bluemonkey Bluetooth (bt0100m) On C860
« Reply #2 on: December 13, 2004, 08:19:14 pm »
I did everything according to the thread below:
https://www.oesf.org/forums/inde...?showtopic=2363

and also I tried everything from:

http://www.shirtpocket.co.uk/spforum/index.php?showtopic=30

but without any success.

I have all the packages installed, and I have this in the uart file:
# cat uart
"Socket", "CF+ Personal Network Card Rev 2.5":/dev/ttyS3 bcsp 230400
"Bluetooth BT0100M", "", "":/dev/ttyS3 bcsp

I don't know is this normal, but hciconfig report the card as down, and I can't bring it up:

# hciconfig
hci0:   Type: UART
        BD Address: 00:00:00:00:00:00 ACL MTU: 0:0  SCO MTU: 0:0
        DOWN
        RX bytes:12 acl:0 sco:0 events:0 errors:0
        TX bytes:6 acl:0 sco:0 commands:0 errors:0
# hciconfig hci0 up
Can't init device hci0. Permission denied(13)


I have the following modules active:
# lsmod
Module                  Size  Used by
hci_uart               12480   2
serial_cs               4864   0  (unused)
rfcomm                 33488   0
l2cap                  16608   2  [rfcomm]
bluez                  32192   2  [hci_uart rfcomm l2cap]
pxa_bi                 21440   0  (unused)
net_fd                 25024   0  (unused)
usbdcore               34544   0  [pxa_bi net_fd]
usbdmonitor             5248   0
sharp_mmcsd_m          25936   2


"sdptool browse" fails with
Inquiring ....
Inquiry failed

I'm attaching also my dmsg output....

I did full reinstall of my zaurus (cacko 1.21b), but this doesn't helped.

Anybody has some idea?

tumnus

  • Hero Member
  • *****
  • Posts: 1176
    • View Profile
    • http://www.cpinkney.org.uk
Bluemonkey Bluetooth (bt0100m) On C860
« Reply #3 on: December 14, 2004, 03:21:05 am »
That isn't the Bluemonkey card. There seems to be a card identified as BT0100M that gets rebranded a lot or sold as an equivalent. I think someone on the old Sharp DevNet forums got that working, but the archives for those still have to be imported here.

Cacko ROM also implements the BlueZ stuff differently to what is used on the Sharp ROMs and what the Bluetooth howto assumes.
# Search the Zaurus Howtos ## Search the Zaurus FAQs ## Find Z software at ELSI #
--------------------
UK SL5500 with Sharp ROM 3.13, SL5600 with Sharp ROM 1.32 - SuSE 9.0 Pro, Windows XP Home
Qualendar for Calendar and Todo
Socket Bluetooth CF Card (Rev F), Kingmax 512MB MMC Card, Palm Tungsten T Stylus,
Pretec CF->Smartmedia Adapter, Semsons Universal Battery Extender

zmiq2

  • Sr. Member
  • ****
  • Posts: 383
    • View Profile
    • http://
Bluemonkey Bluetooth (bt0100m) On C860
« Reply #4 on: December 14, 2004, 03:42:38 am »
when hciconfig command says BD address:00:00..., it can be because of two reasons:

1) the card is not activated yet
 do a:
  #hciconfig hci0 up
  # hciconfig

2) the card/drivers is not properly configured.

Please, try option 1) and tell us how it goes.

HTH
sl-c750, archos av580, socket cf [bt, wifi, modem], noname cf lan, audiovox rtm800 gsm-gprs cf, rom: sharp -> oz3.5.3 -> cacko -> oz3.5.4.1

lenkov

  • Newbie
  • *
  • Posts: 4
    • View Profile
Bluemonkey Bluetooth (bt0100m) On C860
« Reply #5 on: December 14, 2004, 09:01:23 pm »
Quote
when hciconfig command says BD address:00:00..., it can be because of two reasons:

1) the card is not activated yet
 do a:
  #hciconfig hci0 up
  # hciconfig

2) the card/drivers is not properly configured.

Please, try option 1) and tell us how it goes.

HTH
I did this already (see my previos post). It says: Can't init device hci0. Permission denied(13)

But I think I found the solution for this problem. You just install a fresh cacko 1.21b (without any editional packages) and just edit the uart file.

in this case the system seems to work perfectly well.

it looks like the all the help on this site is for a different ROM or old version of the ROM.... If you don't install anything on the top of cacko 1.21b -- it just worked.


Anyway -- thanks for the help everyone.

Lenkov
pix.lenkov.com

Zuber

  • Sr. Member
  • ****
  • Posts: 277
    • View Profile
    • http://www.shirtpocket.co.uk
Bluemonkey Bluetooth (bt0100m) On C860
« Reply #6 on: December 16, 2004, 04:07:31 pm »
Card "should" work with standard rom as well.

Got our own simplified (imho) instructions on it at :

http://www.shirtpocket.co.uk/spforum/index.php?showtopic=30

Problem is, just tried it with the C3000 and it does not work.

tumnus,

Any chance of a C3000 freindly version ? (Please, Pritty Please, Pritty Please with suger on to...    )
Zuber
ShirtPocket Ltd.
www.shirtpocket.co.uk

tumnus

  • Hero Member
  • *****
  • Posts: 1176
    • View Profile
    • http://www.cpinkney.org.uk
Bluemonkey Bluetooth (bt0100m) On C860
« Reply #7 on: December 16, 2004, 05:50:47 pm »
Yeah, the Cacko  ROM comes with BlueZ already installed. Keep forgetting that.

Zuber,

As for the SL- 3000, that isn't working yet because the BlueZ drivers need recompiling for the 3000's newer kernel. I have PMed you about this.
# Search the Zaurus Howtos ## Search the Zaurus FAQs ## Find Z software at ELSI #
--------------------
UK SL5500 with Sharp ROM 3.13, SL5600 with Sharp ROM 1.32 - SuSE 9.0 Pro, Windows XP Home
Qualendar for Calendar and Todo
Socket Bluetooth CF Card (Rev F), Kingmax 512MB MMC Card, Palm Tungsten T Stylus,
Pretec CF->Smartmedia Adapter, Semsons Universal Battery Extender

rogerbowering

  • Newbie
  • *
  • Posts: 29
    • View Profile
Bluemonkey Bluetooth (bt0100m) On C860
« Reply #8 on: January 09, 2005, 04:52:42 am »
Hi

I've installed Cacko 1.22 and am using the 'new' Bluemonkey CF card

I'm not sure (from reading the previous stuff) whether I need to do any of the stuff in the detailed Shirtpocket instructions, but I'm assuming I need to run the command line instructions

I'm a technical illiterate but when I do the:
-----------------------------------------------------------------------
If you have set a password for your unit on power on, this will also now be the password for su.

Now type : ./termon [ENTER]
(That is full stop, forward slash using shift key and then termon without any spaces. Ignore the funny spacing, this fixes it)
-----------------------------------------------------------------------
....I get No such file or directory

Also, exactly how do you text edit the configuration files, uart, etc.  I've been copying them to CF, transferring to PC, using Notepad to edit them and then getting them back via CF. Is there an easier way?

Please bear with me as I'm a non-techie who'd like to get his BlueTooth working

Thanks

maslovsky

  • Hero Member
  • *****
  • Posts: 1426
    • View Profile
    • http://my-zaurus.narod.ru
Bluemonkey Bluetooth (bt0100m) On C860
« Reply #9 on: January 18, 2005, 11:32:52 am »
This card should be working out of the box in Cacko 1.22.

Quote
Hi

I've installed Cacko 1.22 and am using the 'new' Bluemonkey CF card