Author Topic: Rc10 Out For Testing..  (Read 45860 times)

Laze

  • Hero Member
  • *****
  • Posts: 704
    • View Profile
    • http://www.pdaXrom.org
Rc10 Out For Testing..
« on: May 16, 2005, 02:37:22 pm »
Sorry for the very crude release - http://212.10.30.205/rc10/
Feeds are located in the folders - excuse the mess :-)

Update C1000 version is out
.. with USB Host working and pre. gfx accel. Calibration screen is portrait mode. To enable mouse support edit startx and add  "-mouse /dev/input/mouse0" in xserver args. Resizing of partions doesn't work yet.

As always visit our site for banners and donations - new website is almost done and will be "released" soon ;-) We are still working on the latest new stuff for the website - if you look "hard" you will probally find it anyway..

But please, please, please consider donating - we are very low on cash always and we still haven't got a C3000 - althoug we have a C1000 due to kind hardware donation - so expect a C1000 version soon ™ - although hardware accelerated will be a while..

Generic:
Code: [Select]
xmms skips beginning of tracks    http://www.pdaxrom.org/buglist.php?doaction=showbug&bugid=258
XPDF closes when opening a file    http://www.pdaxrom.org/buglist.php?doaction=showbug&bugid=185
No suspend when in console w/out X11      http://www.pdaxrom.org/buglist.php?doaction=showbug&bugid=108
ppp dealer starts pppd with password on commandline    http://www.pdaxrom.org/buglist.php?doaction=showbug&bugid=106
Rotation and fonts        http://www.pdaxrom.org/buglist.php?doaction=showbug&bugid=47
qpkg reinstalls already installed programs as ....    http://www.pdaxrom.org/buglist.php?doaction=showbug&bugid=266
usb storage function not working anymore!  http://www.pdaxrom.org/buglist.php?doaction=showbug&bugid=252
SD card crashes on resume    http://www.pdaxrom.org/buglist.php?doaction=showbug&bugid=245
pppconfig segfault (reproducable)      http://www.pdaxrom.org/buglist.php?doaction=showbug&bugid=253

Misc:
- Many, many bugsfixes that got lost in the frenzy of new hardware etc.
- xpdf 100% running and stable with all pdfs (except for version 7)
- CF stuff
- TSLIB stuff
- matchbox-pdaxrom vendor related
- matchbox-icewm vendor related
- libmatchbox updated
- matchbox-panel updated
- matchbox-desktop updated
- SDL calibration problems with stuff like dosbox
- font setup for mb-applet-menu - fonts in menu 100% configurable
- Many "default" programs updated and installed.
- Installing SD/CF/Root sizes in installer
- better package manager with checkboxes and info
- "Raster" lines on remove applet icon menu
- Better text for calibration screen
- colors in term/bash

----------------------------------------------
6000 related:
Bugs:
0. DON'T USE THE NAND TOOLS
1. Wireless is not working using the utils
2. Many of the config utils are still 7x0 centric
3. Video driver is not hardware accelerated
4. Many keys are not defined etc.

Feel free to edit/fix the pythons programs so they work for the 6000 :-)

To use wireless "follow" the instructions here ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/README

This is a fast whip up so please post any problems etc. you encounter here and I will try to keep it updated and help out and again:
« Last Edit: May 24, 2005, 03:39:37 am by Laze »
C760 running pdaXrom lastest ;-)
SL5500 Running Cacko Qtopia
512 MB SD Card, 128 MB CF Card, Prism2 CF Wlan.

Always visit http://www.pdaXrom.org for latest news.

ScottYelich

  • Hero Member
  • *****
  • Posts: 992
    • View Profile
    • http://www.zaurususergroup.com/modules.php?opmodload&namephpWiki&filei
Rc10 Out For Testing..
« Reply #1 on: May 16, 2005, 03:10:29 pm »
7x0 components mirrored:  http://zaurus.spy.org/feeds/cacko/pdaXrom/1.1.0/rc10/
(as of time of this post, only)

Scott
« Last Edit: May 16, 2005, 03:10:48 pm by ScottYelich »

adf

  • Hero Member
  • *****
  • Posts: 2807
    • View Profile
    • http://
Rc10 Out For Testing..
« Reply #2 on: May 16, 2005, 04:57:12 pm »
very cool.. I've been looking forward to this.
**3100 Zubuntu Jaunty,(working on Cacko dualboot), 16G A-Data internal CF, 4G SD, Ambicom WL-1100C Cf, linksys usb ethernet,  BelkinF8T020 BT card, Belkin F8U1500-E Ir kbd, mini targus usb mouse, rechargeble AC/DC powered USB hub, psp cables and battery extenders.

**6000l  Tetsuized Sharprom, installed on internal flash only 1G sd, 2G cf

david_dahan

  • Newbie
  • *
  • Posts: 43
    • View Profile
    • http://
Rc10 Out For Testing..
« Reply #3 on: May 16, 2005, 06:33:55 pm »
Seems that Fn key is not functioning , cant type the blue characters ....

thanks,
David.
SL-C750 running pdaXrom 1.1.0 Beta1
512MB SD
Linux SuSE 10.0 Laptop + desktop

Laze

  • Hero Member
  • *****
  • Posts: 704
    • View Profile
    • http://www.pdaXrom.org
Rc10 Out For Testing..
« Reply #4 on: May 17, 2005, 04:11:25 am »
David: When posting such problems please write what Zaurus you are using.
C760 running pdaXrom lastest ;-)
SL5500 Running Cacko Qtopia
512 MB SD Card, 128 MB CF Card, Prism2 CF Wlan.

Always visit http://www.pdaXrom.org for latest news.

david_dahan

  • Newbie
  • *
  • Posts: 43
    • View Profile
    • http://
Rc10 Out For Testing..
« Reply #5 on: May 17, 2005, 05:21:37 am »
Quote
David: When posting such problems please write what Zaurus you are using.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=80145\"][{POST_SNAPBACK}][/a][/div]


Sorry , I'm using C750 .

David.
SL-C750 running pdaXrom 1.1.0 Beta1
512MB SD
Linux SuSE 10.0 Laptop + desktop

Laze

  • Hero Member
  • *****
  • Posts: 704
    • View Profile
    • http://www.pdaXrom.org
Rc10 Out For Testing..
« Reply #6 on: May 17, 2005, 08:23:44 am »
david: What stuff is missing more precisly?
C760 running pdaXrom lastest ;-)
SL5500 Running Cacko Qtopia
512 MB SD Card, 128 MB CF Card, Prism2 CF Wlan.

Always visit http://www.pdaXrom.org for latest news.

david_dahan

  • Newbie
  • *
  • Posts: 43
    • View Profile
    • http://
Rc10 Out For Testing..
« Reply #7 on: May 17, 2005, 09:02:34 am »
Quote
david: What stuff is missing more precisly?
[div align=\"right\"][a href=\"index.php?act=findpost&pid=80175\"][{POST_SNAPBACK}][/a][/div]


Laze : Can not type all characters that are controlled by the Fn key (* , : ^ , = , + , [], <>, @)

The brightness control is also not working (Fn+3 , Fn+4) .

thanks for your help ...
David.
SL-C750 running pdaXrom 1.1.0 Beta1
512MB SD
Linux SuSE 10.0 Laptop + desktop

jerrybme

  • Hero Member
  • *****
  • Posts: 639
    • View Profile
    • http://
Rc10 Out For Testing..
« Reply #8 on: May 17, 2005, 12:48:33 pm »
Quote
Laze : Can not type all characters that are controlled by the Fn key (* , : ^ , = , + , [], <>, @)

The brightness control is also not working (Fn+3 , Fn+4) .

thanks for your help ...
David.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=80181\"][{POST_SNAPBACK}][/a][/div]
I noted the same, simple work-around until it is fixed is to use the X-virtual keyboard for special characters & Fn keys.

Cheers,
Jerry
SL-C3100
Angstrom-GPE
Lexar SD 1 GB
PQI 2GB CF
Ambicom WL1100 CF

Laze

  • Hero Member
  • *****
  • Posts: 704
    • View Profile
    • http://www.pdaXrom.org
Rc10 Out For Testing..
« Reply #9 on: May 17, 2005, 01:24:45 pm »
The bug has been located - fixed ipks will be available soon...
C760 running pdaXrom lastest ;-)
SL5500 Running Cacko Qtopia
512 MB SD Card, 128 MB CF Card, Prism2 CF Wlan.

Always visit http://www.pdaXrom.org for latest news.

plcg

  • Jr. Member
  • **
  • Posts: 68
    • View Profile
    • http://
Rc10 Out For Testing..
« Reply #10 on: May 17, 2005, 02:19:08 pm »
Hi,

On my C700, "Suspend" menu doesn't work anymore.

And although my wifi card (Linksys WCF12) is connected to my router (Inventel DW200), Gaim is unable to connect and Dillo exits when i type "www.google.fr" and then "enter"...

Did i forget something ?
Thanks.

plcg
C760 & Pdaxrom 1.1.0beta1 / Transcend 512 MB CF
C1000 & Cacko 1.23 full / PQI 1 GB SD/ Hitachi 2GB microdrive
Linksys WCF12 CF WiFi Card

david_dahan

  • Newbie
  • *
  • Posts: 43
    • View Profile
    • http://
Rc10 Out For Testing..
« Reply #11 on: May 17, 2005, 04:38:01 pm »
Hi ,

Networking via samba is not working anymore on RC10 . I flashed back to RC9 ,  installed samba and it is working.

thanks,
SL-C750 running pdaXrom 1.1.0 Beta1
512MB SD
Linux SuSE 10.0 Laptop + desktop

BarryW

  • Hero Member
  • *****
  • Posts: 690
    • View Profile
    • http://
Rc10 Out For Testing..
« Reply #12 on: May 17, 2005, 04:54:32 pm »
How do you start a gui other than twm?

sl-6000
What's this button do??

C3100
Distro changes almost weekly...

C3200
Distro also changes almost weekly...  :)

Hardware hacks and stuff.

adf

  • Hero Member
  • *****
  • Posts: 2807
    • View Profile
    • http://
Rc10 Out For Testing..
« Reply #13 on: May 17, 2005, 07:39:35 pm »
I flashed to pdaX on my 6k briefly.

fn keys don't seem to work at least "=" didn't work. You already knew the keymap was imperfect, though.

The partition resizing is a problem.  there isn't really enough room for a decent installation
on the default partitioning scheme.

I really don't like twm.  reminds of when I screw stuff up on my desktop
that's a quibble, though.

I think I will have to go backup my pocketworkstaion to free up my sd card, put the feed on a cf card and give this another shot.  

keep at it-- I've seen pdaX on a 760, and was really impressed. would love to see equal functionality on my 6k
**3100 Zubuntu Jaunty,(working on Cacko dualboot), 16G A-Data internal CF, 4G SD, Ambicom WL-1100C Cf, linksys usb ethernet,  BelkinF8T020 BT card, Belkin F8U1500-E Ir kbd, mini targus usb mouse, rechargeble AC/DC powered USB hub, psp cables and battery extenders.

**6000l  Tetsuized Sharprom, installed on internal flash only 1G sd, 2G cf

adf

  • Hero Member
  • *****
  • Posts: 2807
    • View Profile
    • http://
Rc10 Out For Testing..
« Reply #14 on: May 17, 2005, 07:57:59 pm »
?!

very strange. I had loaded pdaX over sharp..and got a really basic emergency looking desktop..restored to guylhem rom.... then flashed to pdaX and got a beautiful gui.  I wouldn't have thought that would happen at all. I wonder what my partitions look like...

I need to go figure out the wireless if I can.

It would be nice, though, if the apps obeyed the window manager in portrait rotation. a landscape aterm in a portrait disply isn't really necessary, is it?

really #$$!!!ing nice, guys,
Thanks!
« Last Edit: May 17, 2005, 08:03:16 pm by adf »
**3100 Zubuntu Jaunty,(working on Cacko dualboot), 16G A-Data internal CF, 4G SD, Ambicom WL-1100C Cf, linksys usb ethernet,  BelkinF8T020 BT card, Belkin F8U1500-E Ir kbd, mini targus usb mouse, rechargeble AC/DC powered USB hub, psp cables and battery extenders.

**6000l  Tetsuized Sharprom, installed on internal flash only 1G sd, 2G cf