Author Topic: C860 Schematics  (Read 19920 times)

louigi600

  • Sr. Member
  • ****
  • Posts: 471
    • View Profile
C860 Schematics
« on: March 13, 2007, 04:18:53 pm »
I've a C860 that no longer charges the battery.
It would be really handy if I had the schematic diagram to help me track down where the dammage is.
Anyone know where I can get it ... or even better can send me a copy ?
« Last Edit: March 14, 2007, 11:04:36 am by louigi600 »
Regards
David

SL-c760*  pdaXrom latest
SL-c860    pdaXrom latest ;-)
SL-c1000  pdaXrom Latest
Acer Aspire One running slackware and Clash
Toshiba AC100 running ARMedslack and Clash

*with some hardware problems but good for testing

speculatrix

  • Administrator
  • Hero Member
  • *****
  • Posts: 3694
    • View Profile
C860 Schematics
« Reply #1 on: March 13, 2007, 07:08:22 pm »
hmmm, noone ever seems to have found a really detailed hardware schematic of the zauruses.

however, a number of people with charging problems have found that there's an internal protective fuse which can blow, and can be replaced with care. search forums for "fuse"?
Gemini 4G/Wi-Fi owner, formerly zaurus C3100 and 860 owner; also owner of an HTC Doubleshot, a Zaurus-like phone.

pelrun

  • Sr. Member
  • ****
  • Posts: 366
    • View Profile
    • http://
C860 Schematics
« Reply #2 on: March 13, 2007, 09:01:57 pm »
The schematics are in the service manuals, which sadly are not freely available.

That said, you don't need them in this case - the problem is all too common. Repair instructions are in this thread: https://www.oesf.org/forums/index.php?showtopic=11539

...however it appears that the links are broken to the photos showing the location of the fuses.
SL-C3100 with usb power mod running debian eabi
pdaXii13 still on the NAND for dualbooting
16GB SDHC! (a new one, after I sat on the old one and it went kaput)
D-Link 660 wifi, Socket Bluetooth rev H
External 9800mAh LiIon battery and slimline dvd drive
Homebrew microphone and remote

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
C860 Schematics
« Reply #3 on: March 13, 2007, 11:47:21 pm »
Quote
The schematics are in the service manuals, which sadly are not freely available.

That said, you don't need them in this case - the problem is all too common. Repair instructions are in this thread: https://www.oesf.org/forums/index.php?showtopic=11539

...however it appears that the links are broken to the photos showing the location of the fuses.
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]
[a href=\"http://cacko.oesf.org/downloads/fuses/Main%20protection%20fuse%20pic_1.jpg]http://cacko.oesf.org/downloads/fuses/Main...use%20pic_1.jpg[/url]
http://cacko.oesf.org/downloads/fuses/Char...use%20pic_2.jpg
It's a shame cacko.oesf.org has been down for awhile. (Actually since before Christmas '06, during the time the forums went down). There's a lot of useful stuff over there that seems to have vanished.
EDIT:
I just happen to have those two pictures in the links above.
(I like to save everything that's seems interesting or useful, that may also vanish because cyberspace is cyberspace)
I'll post them here, since offroadgeek increased the size limit for attachments.

Sorry, I cannot upload the pics to the forum, attachments stopped working again today.
They are sitting on my desktop if anyone wants them, you can wait until the forum attachments are fixed, or pm me with an email address. Total size of the two pics is 1.77MB
« Last Edit: March 14, 2007, 12:47:56 am by Jon_J »
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

Antikx

  • Hero Member
  • *****
  • Posts: 1147
    • View Profile
    • http://tyrannozaurus.com
C860 Schematics
« Reply #4 on: March 14, 2007, 02:15:23 am »
If you email them to me I can putem up on ty.
antikx at gmail dot com
Kanpai,
-Antikx (Twitter, Mugshot and PodNova)
C1000 - pdaXrom R198 (Celestial Environment)
tyrannozaurus.com
[img]http://www.tyrannozaurus.com/files/category_pictures/general_1.png\" border=\"0\" class=\"linked-sig-image\" /]
Zaurus news/blogs feed from Zaurus users
Free Windows, Linux, or Web RSS readers.
Featured pages at tyrannozaurus:
Sharp Petition, ScummVM, Cacko, pdaXii13, and Celestial Environment

Jon_J

  • Hero Member
  • *****
  • Posts: 1853
    • View Profile
    • http://
C860 Schematics
« Reply #5 on: March 14, 2007, 02:25:22 am »
just sent them
C3100 Multiboot-->Angstrom 2007.12-r18 | Cacko 1.23 | ArchLinuxARM
C3200 pdaxii13v2-5.5-alpha4 Akita on NAND

Ambicom WL1100C-CF Wifi - Ambicom CF modem - Ambicom CF GPS - Belkin-F5D5050 USB LAN
Socket CF Bluetooth rev K - Iogear 4 port USB micro hub - pocket CF card reader
Targus mini USB optical mouse - 2 Targus SD card readers

danr

  • Full Member
  • ***
  • Posts: 138
    • View Profile
    • http://
C860 Schematics
« Reply #6 on: March 14, 2007, 04:43:22 am »
Quote
I've a C860 that no lobger charges the battery.
It would be really handy if I had the schematic diagram to help me track down where the dammage is.
Anyone know where I can get it ... or even better can send me a copy ?
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

I notice from your signature that you're using r121 on your C860.  I have the same issue as you, which is not a hardware problem, but a software problem with r121.  See [a href=\"https://www.oesf.org/forums/index.php?showtopic=21490&st=45&p=142480&#entry142480]here[/url] for further information.
SL-C860 running Debian EABI on top of Angstrom 2.6 kernel

louigi600

  • Sr. Member
  • ****
  • Posts: 471
    • View Profile
C860 Schematics
« Reply #7 on: March 14, 2007, 06:48:25 am »
Quote
I notice from your signature that you're using r121 on your C860.  I have the same issue as you, which is not a hardware problem, but a software problem with r121.  See here for further information.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=156215\"][{POST_SNAPBACK}][/a][/div]
In my case it's a hardware issue for sure because it worked untill I plugged power with polarity inverted ... and then it stopped working.
But I'm intrested to learn more about your software problem.
Regards
David

SL-c760*  pdaXrom latest
SL-c860    pdaXrom latest ;-)
SL-c1000  pdaXrom Latest
Acer Aspire One running slackware and Clash
Toshiba AC100 running ARMedslack and Clash

*with some hardware problems but good for testing

danr

  • Full Member
  • ***
  • Posts: 138
    • View Profile
    • http://
C860 Schematics
« Reply #8 on: March 14, 2007, 07:55:52 am »
Quote
Quote
I notice from your signature that you're using r121 on your C860.  I have the same issue as you, which is not a hardware problem, but a software problem with r121.  See here for further information.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=156215\"][{POST_SNAPBACK}][/a][/div]
In my case it's a hardware issue for sure because it worked untill I plugged power with polarity inverted ... and then it stopped working.
But I'm intrested to learn more about your software problem.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=156218\"][{POST_SNAPBACK}][/a][/div]

I have the problem where pdaXrom r121 doesn't seem to recharge the battery, which stays at the same level even when power is supplied.  kenya suggests a fix in post #54 on the page I linked to, with an updated apm ipkg, but that didn't seem to make any difference.  For the time being, I'm recharging my SL-C860 battery in my unused SL-C5500, after filing off the sticking-out bit on the battery of course  
SL-C860 running Debian EABI on top of Angstrom 2.6 kernel

louigi600

  • Sr. Member
  • ****
  • Posts: 471
    • View Profile
C860 Schematics
« Reply #9 on: March 14, 2007, 08:31:28 am »
Quote
I have the problem where pdaXrom r121 doesn't seem to recharge the battery, which stays at the same level even when power is supplied.  kenya suggests a fix in post #54 on the page I linked to, with an updated apm ipkg, but that didn't seem to make any difference.  For the time being, I'm recharging my SL-C860 battery in my unused SL-C5500, after filing off the sticking-out bit on the battery of course 
[div align=\"right\"][a href=\"index.php?act=findpost&pid=156223\"][{POST_SNAPBACK}][/a][/div]
Odd ... on mine it worked fine untill I made mints of fuses (I hope) .... if you use OZ or cacko does it charge the battery again ?
Regards
David

SL-c760*  pdaXrom latest
SL-c860    pdaXrom latest ;-)
SL-c1000  pdaXrom Latest
Acer Aspire One running slackware and Clash
Toshiba AC100 running ARMedslack and Clash

*with some hardware problems but good for testing

danr

  • Full Member
  • ***
  • Posts: 138
    • View Profile
    • http://
C860 Schematics
« Reply #10 on: March 14, 2007, 09:31:41 am »
Odd ... on mine it worked fine untill I made mints of fuses (I hope) .... if you use OZ or cacko does it charge the battery again ?
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]
[/quote]

It seems to be a known problem, see [a href=\"https://www.oesf.org/forums/index.php?showtopic=21490&st=73#]this report posted by iczer3
.  Charging was working fine for me on rc12, which I used previously.
SL-C860 running Debian EABI on top of Angstrom 2.6 kernel

Antikx

  • Hero Member
  • *****
  • Posts: 1147
    • View Profile
    • http://tyrannozaurus.com
C860 Schematics
« Reply #11 on: March 14, 2007, 10:54:58 am »
Quote
just sent them
[div align=\"right\"][a href=\"index.php?act=findpost&pid=156209\"][{POST_SNAPBACK}][/a][/div]
Aww crud. Sorry Jon_J
I meant: tyrannozaurus at gmail dot com
I didn't snatch antikx@gmail.com fast enough and someone else took it. *sigh*
Please send again.
Kanpai,
-Antikx (Twitter, Mugshot and PodNova)
C1000 - pdaXrom R198 (Celestial Environment)
tyrannozaurus.com
[img]http://www.tyrannozaurus.com/files/category_pictures/general_1.png\" border=\"0\" class=\"linked-sig-image\" /]
Zaurus news/blogs feed from Zaurus users
Free Windows, Linux, or Web RSS readers.
Featured pages at tyrannozaurus:
Sharp Petition, ScummVM, Cacko, pdaXii13, and Celestial Environment

louigi600

  • Sr. Member
  • ****
  • Posts: 471
    • View Profile
C860 Schematics
« Reply #12 on: March 14, 2007, 11:03:59 am »
Quote
It seems to be a known problem, see this report posted by iczer3.  Charging was working fine for me on rc12, which I used previously.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=156238\"][{POST_SNAPBACK}][/a][/div]

Well that never happened to me when my C860 was working correctly. I di run it down several times until it suspended for critical battery charge (and a few times I pushed it till it just froze).
Untill now it allways charged.
I've no idea, right now,  why this is happening to some C860 devices, but I will look into it.
Regards
David

SL-c760*  pdaXrom latest
SL-c860    pdaXrom latest ;-)
SL-c1000  pdaXrom Latest
Acer Aspire One running slackware and Clash
Toshiba AC100 running ARMedslack and Clash

*with some hardware problems but good for testing

Antikx

  • Hero Member
  • *****
  • Posts: 1147
    • View Profile
    • http://tyrannozaurus.com
C860 Schematics
« Reply #13 on: March 14, 2007, 12:33:14 pm »
posted:
http://www.tyrannozaurus.com/?q=wiki/ChargingCircuitC860
Or browse to: http://www.tyrannozaurus.com
Click on Wiki -> ZaurusKnowledgeBase -> HardwareKnowledgebase -> ChargingCircuitC860
Kanpai,
-Antikx (Twitter, Mugshot and PodNova)
C1000 - pdaXrom R198 (Celestial Environment)
tyrannozaurus.com
[img]http://www.tyrannozaurus.com/files/category_pictures/general_1.png\" border=\"0\" class=\"linked-sig-image\" /]
Zaurus news/blogs feed from Zaurus users
Free Windows, Linux, or Web RSS readers.
Featured pages at tyrannozaurus:
Sharp Petition, ScummVM, Cacko, pdaXii13, and Celestial Environment

grog

  • Hero Member
  • *****
  • Posts: 692
    • View Profile
    • http://
C860 Schematics
« Reply #14 on: March 14, 2007, 12:53:23 pm »
FWIW, I've yet to have any problems charging my 860 on any ROM so far.
GROG!