Author Topic: 2g Sd Working In Sharp 3.1 (ospack)  (Read 6846 times)

jocasmi

  • Jr. Member
  • **
  • Posts: 99
    • View Profile
    • http://
2g Sd Working In Sharp 3.1 (ospack)
« on: June 30, 2007, 07:54:34 pm »
Hi, after lot of in an outs, probing in TheKompany rom without success, I try this modifyied sd driver

 http://cambuca.ldhs.cetuc.puc-rio.br/~miguel/zaurus/

and I have been able to make a 2G ext2 partition on a Kingston Regular SD, and the system mounts and recognizes it without problems.

I'm thinking about taking sdcontrol file from Sharp ROM to TheKompany.
Perhaps, this is the missed point. I don't know.

A big step for the human being  

Any suggestion will be appreciated.

Greets
« Last Edit: June 30, 2007, 08:07:13 pm by jocasmi »
SL-C3200 Sharp Rom, Meanie's X/QT and Pocket Workstation
Wifi Linksys WCF12, SD 1GB Kingston (Ellite Pro)

SL-5500S Cacko Crow 30/30 home on SD
SD 1GB Kingston (the good one)
CF 1GB Kingston


Juanjo Santiso
Barcelona
EU

chrisl

  • Jr. Member
  • **
  • Posts: 87
    • View Profile
    • http://web.mac.com/iepfreaks/iWeb/Site/Main%20Page.html
2g Sd Working In Sharp 3.1 (ospack)
« Reply #1 on: June 30, 2007, 10:41:33 pm »
Quote
Hi, after lot of in an outs, probing in TheKompany rom without success, I try this modifyied sd driver

 http://cambuca.ldhs.cetuc.puc-rio.br/~miguel/zaurus/

and I have been able to make a 2G ext2 partition on a Kingston Regular SD, and the system mounts and recognizes it without problems.

I'm thinking about taking sdcontrol file from Sharp ROM to TheKompany.
Perhaps, this is the missed point. I don't know.

A big step for the human being   

Any suggestion will be appreciated.

Greets
[div align=\"right\"][a href=\"index.php?act=findpost&pid=164046\"][{POST_SNAPBACK}][/a][/div]

kb7sqi from this forum has modified a tkc ROM incorporating the new driver that allows for storage of 2 gigs and greater. Hopefully he'll get that to me sometime tonight. I have used this driver successfully with the Cacko Crow 64-0 setup and also with OZ OPIE. I used maslovsky's directions for swapping the original sd driver with a modified driver with success. I'm hoping to use kb7sqi's ROM with the 30/30 crow zimage if I can get my hands on a copy of the zimage.

Chris--
Zaurus SL-5500, Kodak CF 32 & 256 MB, generic (pqi) 1 GB SD & polaroid 1 GB SD, tkc 2a3 with home on SD, Belkin F5D6060 CF WiFi Card, MacBook Pro 1.8 GHz Core Duo, OS X 10.4.10

qx773

  • Full Member
  • ***
  • Posts: 219
    • View Profile
2g Sd Working In Sharp 3.1 (ospack)
« Reply #2 on: July 01, 2007, 01:15:32 am »
I tried the mmc_sd2g driver on my C760, but it results in a segmentation fault when I try to insmod.  The same general technique of modifying the sharp_mmcsd_m.o file should work for the C760, though.

jocasmi

  • Jr. Member
  • **
  • Posts: 99
    • View Profile
    • http://
2g Sd Working In Sharp 3.1 (ospack)
« Reply #3 on: July 01, 2007, 06:50:48 am »
qx733, That segmentation fault was what happened whe I tried the driver in its original state directly in TK on my collie.

There is a modified driver for the former C series at Tetsu's site, I attach you a copy (in a reply below). I hope it works for you.

It seems that kb7sqi work and Chris testing are dealing with success.

Anyway, maybe it should be useful to set up an effort to organize the information related to sl-5500 which is messed and often difficult to find quickly at the forum.

Roms, drivers or patchs, scripts, setups...

I think our colllie deserves it. Here in Spain is still possible to find "brand new" SL-5500, with spanish localized keyboard.

I have no hacking skills, but this is a matter of sharing skills and efforts.

This is for me and state-of-the-art machine. Let's think about it.

Any suggestion?



Greets.
« Last Edit: July 01, 2007, 03:37:22 pm by jocasmi »
SL-C3200 Sharp Rom, Meanie's X/QT and Pocket Workstation
Wifi Linksys WCF12, SD 1GB Kingston (Ellite Pro)

SL-5500S Cacko Crow 30/30 home on SD
SD 1GB Kingston (the good one)
CF 1GB Kingston


Juanjo Santiso
Barcelona
EU

qx773

  • Full Member
  • ***
  • Posts: 219
    • View Profile
2g Sd Working In Sharp 3.1 (ospack)
« Reply #4 on: July 01, 2007, 11:04:59 am »
Thanks.  There is a problem with that zip file.  The sd-link11b_us_jpn_arm.ipk file in the zip file is not the actual ipk but a message in HTML displaying a 404 error:

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<HTML><HEAD>
<TITLE>404 Not Found</TITLE>
</HEAD><BODY>
<H1>Not Found</H1>
The requested URL /data/link11b/sd-link11b_us_jpn_arm.ipk was not found on this server.<P>
</BODY></HTML>

qx773

  • Full Member
  • ***
  • Posts: 219
    • View Profile
2g Sd Working In Sharp 3.1 (ospack)
« Reply #5 on: July 01, 2007, 12:37:45 pm »
Will someone please post the original SL-C760 sharp_mmcsd_m.o file so that I can compare it with the SL-5500 sharp_mmcsd_m.o file?  Perhaps we can perform some code splicing of the relevant sections necessary to get 2GB SD cards to work on the SL-C760.  The SL-C760 file is located in:

/lib/modules.rom/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/sharp_mmcsd_m.o

I accidentally erased mine by following the installation instructions for the modified SL-5500 version of sharp_mmcsd_m.o.  What you should do is delete the link to the sharp_mmcsd_m.o file before copying the modified sharp_mmcsd_m.o file to:

/lib/modules/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/sharp_mmcsd_m.o

The link resides in, "modules", not, "modules.rom".  The original sharp_mmcsd_m.o resides in, "modules.rom".

jocasmi

  • Jr. Member
  • **
  • Posts: 99
    • View Profile
    • http://
2g Sd Working In Sharp 3.1 (ospack)
« Reply #6 on: July 01, 2007, 03:34:43 pm »
You're right this is a fake ipk. I've found this one instead, that seems to be the right one.

 [ Invalid Attachment ]

You can get the replacement sdiomgr.zip from here.

https://www.oesf.org/forums/index.php?showtopic=17208&st=30

Hope it works. If so, maybe it would be better to post the link in a new topic with the filename, to make it easy to find.
« Last Edit: July 01, 2007, 03:43:09 pm by jocasmi »
SL-C3200 Sharp Rom, Meanie's X/QT and Pocket Workstation
Wifi Linksys WCF12, SD 1GB Kingston (Ellite Pro)

SL-5500S Cacko Crow 30/30 home on SD
SD 1GB Kingston (the good one)
CF 1GB Kingston


Juanjo Santiso
Barcelona
EU

qx773

  • Full Member
  • ***
  • Posts: 219
    • View Profile
2g Sd Working In Sharp 3.1 (ospack)
« Reply #7 on: July 01, 2007, 05:58:01 pm »
Thank you.

chrisl

  • Jr. Member
  • **
  • Posts: 87
    • View Profile
    • http://web.mac.com/iepfreaks/iWeb/Site/Main%20Page.html
2g Sd Working In Sharp 3.1 (ospack)
« Reply #8 on: July 01, 2007, 08:38:32 pm »
Quote
Thank you.
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

Just so you know, kb7sqi posted Sharp ROMs and tkc ROMS that have the new 2 gig SD driver built in. The link is:

[a href=\"https://www.oesf.org/forums/index.php?showtopic=24306&st=0&#entry164115]https://www.oesf.org/forums/index.php?showt...=0&#entry164115[/url]

All but one of the images posted are modified to allow for the home on SD script.

Chris--
Zaurus SL-5500, Kodak CF 32 & 256 MB, generic (pqi) 1 GB SD & polaroid 1 GB SD, tkc 2a3 with home on SD, Belkin F5D6060 CF WiFi Card, MacBook Pro 1.8 GHz Core Duo, OS X 10.4.10