Author Topic: Battery showing -1 %, otherwise working fine, bar random shutdowns  (Read 577 times)

sup

  • Newbie
  • *
  • Posts: 34
    • View Profile
Some time ago, Android started to report battery charge "-1%" (that is a minus sign there). It seems to work otherwise. I can charge the phone and it works for about a day before turning off without any warning. But it is annoying to have no idea about the charge and also Google Play refuses to install or update any apps. Have you ever seen anything like that on Cosmo or on other phones? I tried googling but it does not seem common at all. Could this be a software issue or should I order a new battery? (Planet computers want to charge 95 pounds for it - it costs about 40 when I order it online and it is somewhat easy to replace, once one gets rid of that adhesive between the battery and the metal plate holding it in place).

LinuxGuy

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Re: Battery showing -1 %, otherwise working fine, bar random shutdowns
« Reply #1 on: November 14, 2020, 11:37:12 pm »
Very strange - for me, it sounds  not like a mere battery issue... did PC only suggest to change the battery?!

sup

  • Newbie
  • *
  • Posts: 34
    • View Profile
Re: Battery showing -1 %, otherwise working fine, bar random shutdowns
« Reply #2 on: November 15, 2020, 08:04:20 am »
Their customer service is crap, unfortunately. I described the problem but I am not sure they read it at all. They want me to send it to them without any advice on what might be causing it and insisting on replacing the CoDi*. They vaguely suggested that often "the CoDI has the OLED panel itself broken, which can create some shortages." I started a parallel thread ( https://www.oesf.org/forum/index.php?topic=36418.0 ) if it is possible to just remove the CoDi altogether because of this. I am also not sure if it is just a battery issue. But appart from the "-1%", everything works. I think the random shutdowns occur when the battery drains completely - the software has no way of knowing so it just shuts down since there physically is not enough charge to power the phone remaining. I will probably try to reinstall the device in case this is something to do with software but I doubt that as well.

But communicating with them is hard, I repeatedly ask the same questions over and over, number them and I get a response in one third of the times and usually responding to just half of the questions. They never even acknowledged the battery issue is weird or that they are aware of its nature. Basically support level of some big company that has clueless people at the front level, but I would expect better from such a small company as Planet Computers is.


* Glass on top of CoDi is cracked after I dropped the phone, but it failed months before I cracked it due to this issue https://www.oesf.org/forum/index.php?topic=36278.0 - and given its battery demans, I found out I prefer turning it off anyway, it does not deliver on its promise. Also, I am not happy that they want me to pay for replacing something that was broken _before_ I managed to break it on my own (which they know, we communicated about it when it happened).