OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

4 Pages V  < 1 2 3 4 >  
Reply to this topicStart new topic
> Opera7.55 For Oz/opie 3.5.4-rc
skliarieh
post Apr 10 2006, 07:29 AM
Post #16





Group: Members
Posts: 13
Joined: 9-November 05
Member No.: 8,502



QUOTE(Greg2 @ Apr 10 2006, 06:54 AM)
QUOTE(skliarieh @ Apr 10 2006, 07:01 AM)
I use OZ 3.5.4 opie on SL-5500. It segfaulted for me as well:

# opera
/opt/QtPalmtop/bin/opera
QDir::readDirEntries: Cannot read the directory: ../apps
opera: Could not find "ini/standard_voice.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
-snip-

Guys,

If this is the ‘only’ opera ipk that you have tried to install... then there should only be one opera.ini on your system? If this is true then your ipkg-link has missed a symlink. To correct this, in terminal do:
CODE
ipkg-link mount /media/card/packages
or to be sure that you have a symlink do:
CODE
ln -s /media/card/packages/opt/QtPalmtop/opera/.opera /home/root/.opera
For the record this has been tested on the collie and poodle with the final release of OZ3.5.4.

Greg

I’ll attach an image of your post here:
*



Ok, I managed to launch opera. tongue.gif
Turns out that the package looks into directory /packages/... for its files, assuming that it was installed onto SD and /packages is link to the SD.

I have altboot to boot opie from SD, so I don't have the /packages directory.
After I did following commands, opera started working:
cd /
ln -s / packages

The opera.ini has assumption that home directory is /root. On OpenZaurus the home directory is /home/root:
cd /
ln -s /home/root

The .opera symlink in root's home directory must point to /opt/QtPalmtop/opera, and not /opt/QtPalmtop/opera/.opera (as I initially thought).

Still, the opera start is not flawless - I have got following messages during launch:
# opera
/opt/QtPalmtop/bin/opera
QDir::readDirEntries: Cannot read the directory: ../apps
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: libvxm.so: cannot open shared object file: No such file or directory
QDir::readDirEntries: Cannot read the directory: /media/ROM/.operasave
QDir::readDirEntries: Cannot read the directory: /var/.operasave
QDir::readDirEntries: Cannot read the directory: /media/card/.operasave

blink.gif
Go to the top of the page
 
+Quote Post
Greg2
post Apr 10 2006, 07:58 AM
Post #17





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



QUOTE(skliarieh @ Apr 10 2006, 10:29 AM)
I have altboot to boot opie from SD, so I don't have the /packages directory.

OK... that is the problem. You should have removed the postinst script from the ipk ‘before’ installing for your setup with altboot. Now you will have to find and remove the symlinks to /packages and rerun the ipkg-link script. smile.gif

Greg
Go to the top of the page
 
+Quote Post
Storm
post Jun 6 2006, 03:48 PM
Post #18





Group: Members
Posts: 156
Joined: 29-March 05
From: Virginia
Member No.: 6,736



All right, this is making me crazy. I have tried everything I know to get this working. Between the bash problem and the suspend problem, I decided to roll back from Hentges 3.5.4.1 to 3.5.4rc. I've gotten everything back up and running except Opera.

I was running 7.55.6079, however I decided to try the 7.55.OZ3.5.4 version this go round. So I got rid of *opera* on the entire system, and installed 7.55.OZ3.5.4. Followed the advice in this thread, including making sure the symlink to /root/.opera pointed to /media/card/packages/opt/QtPalmtop/opera and reinstalling qpf-helvetica-240. I still get

# opera
/opt/QtPalmtop/bin/opera
opera: Could not find "ini/standard_voice.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_voice.ini"
Segmentation fault

Anyone got any pointers?

Thanks,
--Storm
Go to the top of the page
 
+Quote Post
skliarieh
post Jun 6 2006, 09:44 PM
Post #19





Group: Members
Posts: 13
Joined: 9-November 05
Member No.: 8,502



QUOTE(Storm @ Jun 6 2006, 03:48 PM)
All right, this is making me crazy. I have tried everything I know to get this working. Between the bash problem and the suspend problem, I decided to roll back from Hentges 3.5.4.1 to 3.5.4rc. I've gotten everything back up and running except Opera.

I was running 7.55.6079, however I decided to try the 7.55.OZ3.5.4 version this go round. So I got rid of *opera* on the entire system, and installed 7.55.OZ3.5.4. Followed the advice in this thread, including making sure the symlink to /root/.opera pointed to /media/card/packages/opt/QtPalmtop/opera and reinstalling qpf-helvetica-240. I still get

# opera
/opt/QtPalmtop/bin/opera
opera: Could not find "ini/standard_voice.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_voice.ini"
Segmentation fault

Anyone got any pointers?

Thanks,
--Storm
*


Create symlink /opt/QtPalmtop/opera/ini to point to /media/card/packages/opt/QtPalmtop/opera/ini

opera needs to be run using sharp-compat-libs. Verify, that
# ls -l /opt/QtPalmtop/bin/opera
lrwxrwxrwx 1 root root 28 Mar 13 02:15 /opt/QtPalmtop/bin/opera -> /opt/QtPalmtop/bin/runcompat

On 5500 I strongly recommend you to go with root-on-SD, it would free up you from many headaches. I think it is good tradeoff against 16MB ROM that you would loose.
Go to the top of the page
 
+Quote Post
Storm
post Jun 7 2006, 02:41 AM
Post #20





Group: Members
Posts: 156
Joined: 29-March 05
From: Virginia
Member No.: 6,736



QUOTE(skliarieh @ Jun 7 2006, 01:44 AM)
Create symlink /opt/QtPalmtop/opera/ini to point to /media/card/packages/opt/QtPalmtop/opera/ini


Did that. Now its only complaining about standard_mouse.ini:

/opt/QtPalmtop/bin/opera
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_mouse.ini"
Segmentation fault

Searched, there is no standard_mouse.ini on my system.

QUOTE
opera needs to be run using sharp-compat-libs. Verify, that
# ls -l /opt/QtPalmtop/bin/opera
lrwxrwxrwx    1 root    root          28 Mar 13 02:15 /opt/QtPalmtop/bin/opera -> /opt/QtPalmtop/bin/runcompat


It is.

QUOTE
On 5500 I strongly recommend you to go with root-on-SD, it would free up you from many headaches. I think it is good tradeoff against 16MB ROM that you would loose.
*


It is.


Thanks,
--Storm
Go to the top of the page
 
+Quote Post
nik42
post Jun 7 2006, 05:42 AM
Post #21





Group: Members
Posts: 2
Joined: 23-June 05
Member No.: 7,430



QUOTE(Storm @ Jun 7 2006, 12:41 PM)
Did that. Now its only complaining about standard_mouse.ini:

/opt/QtPalmtop/bin/opera
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_mouse.ini"
Segmentation fault

Searched, there is no standard_mouse.ini on my system.

Thanks,
--Storm
*


Hi,

I had the same problem and just copied the "standard_mouse.ini" from my desktop installation of opera. That's working fine.

nik
Go to the top of the page
 
+Quote Post
Greg2
post Jun 7 2006, 10:38 AM
Post #22





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



QUOTE(nik42 @ Jun 7 2006, 09:42 AM)
I had the same problem and just copied the "standard_mouse.ini" from my desktop installation of opera. That's working fine.

I just had to d/l an opera rpm and extract the "standard_mouse.ini" from it and copy it to my recent (5-24-06) OZ/Opie build to make this work. To 'keep' it working I had to edit the opera.ini with:
CODE
command control and content navigation by voice enabled=0
This will be the last bit of help I have to offer in this thread. sad.gif

As the OZ devs work to improve their distro... this 'old opera ipk' becomes less and less compatible with it. Just to be 'very' clear on this... I'm 'not' placing the OZ devs at fault here!

In case you haven't read any of these... FYI:
http://article.gmane.org/gmane.comp.handhe...aurus.devel/825
and
http://www.oesf.org/forums/index.php?showtopic=19827

So... for the record the opera binary can be 'made' (very ugly hack) to work. But... your on your own now making (or trying to make) it work.

As a side note... maybe in the future we will have an up to date Konqueror that will have a smaller footprint. smile.gif

Greg
Go to the top of the page
 
+Quote Post
LukeLuke
post Jul 3 2006, 10:57 PM
Post #23





Group: Members
Posts: 167
Joined: 25-August 05
Member No.: 7,943



where opera, by the default, search the ini files?

I have try to creste the symbolic link and when i launch opera it go in segmentation fault, i have modify the opera ini like say Greg2. And now opera say:

# opera
/opt/QtPalmtop/bin/opera
opera: Could not find "ini/standard_voice.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_voice.ini"
Segmentation fault


but the the link are right !

what can i do ?

THANKS

Bye
Go to the top of the page
 
+Quote Post
LukeLuke
post Jul 3 2006, 11:34 PM
Post #24





Group: Members
Posts: 167
Joined: 25-August 05
Member No.: 7,943



OKKKK!!!!! NOW IT' S OK!

I post my configuration step for make work opera:

1- verify that the /root/ and the /home/root/ have:

.opera -> /mnt/card/opt/QtPalmtop/opera/.opera
.operasave -> /mnt/card/opt/QtPalmtop/opera/.operasave

2 - Edit file opera.ini and verify this string:

command control and content navigation by voice enabled=0
[Disk Cache]
; Small: Size=2000, Medium: Size=3000, Large: Size=4000
Size=16000


3 - verify that the symbolic link in /usr/share/opera is right, in my Z the link was to -> /media/card/packages/opt/QtPalmtop/opera/ but in my SD is not the directory Packages, so i link to -> /media/card/opt/QtPalmtop/opera/

4 - if you don't have the standard_mouse.ini get this pippo.bmp and rename in standard_mouse.ini. Copy this file in the directory ini of the opera.

Bye
Luca
Attached File(s)
Attached File  pippo.bmp ( 1.25K ) Number of downloads: 166
 
Go to the top of the page
 
+Quote Post
LukeLuke
post Jul 4 2006, 04:46 AM
Post #25





Group: Members
Posts: 167
Joined: 25-August 05
Member No.: 7,943



i have a question:

with this porting of opera isn't possible to configure the proxy ???

I try to configure it by the gui but there isn't a form for insert the proxy ......
I try to configure it by the opera.ini file, but when the opera start, it's cancel my manual setting....

how can i do ?

THANKS

Bye
Go to the top of the page
 
+Quote Post
MrBryan
post Jul 6 2006, 09:43 PM
Post #26





Group: Members
Posts: 14
Joined: 3-March 06
Member No.: 9,281



quote: 3 - verify that the symbolic link in /usr/share/opera is right, in my Z the link was to -> /media/card/packages/opt/QtPalmtop/opera/ but in my SD is not the directory Packages, so i link to -> /media/card/opt/QtPalmtop/opera/

end quote


This worked for me -- but i installed to root because i have root on SD

so i did:

rm /usr/share/opera

and ln -s /opt/QtPalmtop/opera /usr/share/opera

and installed qte-font-helvetica-small, qte-font-helvetica-large (common, fixed, etc)

works great.


Cheers
Go to the top of the page
 
+Quote Post
guitara
post Jul 8 2006, 08:36 PM
Post #27





Group: Members
Posts: 13
Joined: 5-February 06
Member No.: 9,075



Ok i think a summary is in order here. I'm sure the original ipk could be modified easily to include the proper path changes. But, since I don't know how to repackage, here goes. To install opera follow the instructions under the proper heading. I'll repost Greg's instructions for ease of use here as well. Thanks to mr Squishy, Greg, and the others in this thread. I've tested this on a fresh install. You don't need to worry aout editing any ini files, or copying anything else over.

1) Install the sharp-compat-libs, opie-sh and the qte-font-helvetica-large ipk (or the helvetica size of your choice) from the opie feed.

2) Copy the attached ipk to your CF-card and open a terminal:

CODE
cd /media/cf
ipkg -d sd --force-depends install opera_7.55.OZ3.5.4_arm.ipk
cd
ipkg-link add opera


3) Go to the Settings tab, click "Reload Icons"

4) Go to the Settings tab, click on Libraries, List, Applications, Opera Browser and click okay.

If you have root on internal flash:
CODE
rm /usr/share/opera
ln -s /opt/QtPalmtop/opera /usr/share/opera


If you have root on SD:
CODE
rm /usr/share/opera
ln -s /media/card/opt/QtPalmtop/opera /usr/share/opera


If you have root on CF:
CODE
rm /usr/share/opera
ln -s /media/cf/opt/QtPalmtop/opera /usr/share/opera

Attached File(s)
Attached File  opera_7.55.OZ3.5.4_arm.ipk ( 2.47MB ) Number of downloads: 124
 
Go to the top of the page
 
+Quote Post
walts
post Jul 13 2006, 01:02 PM
Post #28





Group: Members
Posts: 57
Joined: 20-April 04
From: Florida, USA
Member No.: 2,933



I admit to being a n00b and stupid, so please don't flame me.
I have Opie 3.5.4.1 installed on a c1000 (Akita), and I want very much to run Opera, since the included Konqueror browser is so bad.

I have tried to follow the instructions in this thread:

QUOTE(guitara @ Jul 9 2006, 04:36 AM)
Ok i think a summary is in order here. I'm sure the original ipk could be modified easily to include the proper path changes. But, since I don't know how to repackage, here goes. To install opera follow the instructions under the proper heading. I'll repost Greg's instructions for ease of use here as well. Thanks to mr Squishy, Greg, and the others in this thread. I've tested this on a fresh install. You don't need to worry aout editing any ini files, or copying anything else over.

1) Install the sharp-compat-libs, opie-sh and the qte-font-helvetica-large ipk (or the helvetica size of your choice) from the opie feed.

Where? I have the opie feed as http://ewi546.ewi.utwente.nl/mirror/www.op...4.5.1/feed/opie (if I typed that correctly) and there is nothing "sharp-compat" there. The others are installed.

QUOTE
2) Copy the attached ipk to your CF-card and open a terminal:

CODE
cd /media/cf
ipkg -d sd --force-depends install opera_7.55.OZ3.5.4_arm.ipk
cd
ipkg-link add opera


3) Go to the Settings tab, click "Reload Icons"

done.

QUOTE
4) Go to the Settings tab, click on Libraries, List, Applications, Opera Browser and click okay.

Again, nothing. There is no Libraries icon on the settings tab.

QUOTE
If you have root on internal flash:
CODE
rm /usr/share/opera
ln -s /opt/QtPalmtop/opera /usr/share/opera


*

Done.

The Opera icon is in my Applications tab, and when I click on it, it "flashes" once and stops.
I see lots of log entries in ths thread showing things that went wrong. Please where are the log files? I could probably learn more about what' going wrong if I could look at them.
Go to the top of the page
 
+Quote Post
LukeLuke
post Jul 13 2006, 02:07 PM
Post #29





Group: Members
Posts: 167
Joined: 25-August 05
Member No.: 7,943



if you launch opera from the konsole, the Z what say?

bye
Go to the top of the page
 
+Quote Post
walts
post Jul 14 2006, 04:53 AM
Post #30





Group: Members
Posts: 57
Joined: 20-April 04
From: Florida, USA
Member No.: 2,933



QUOTE(LukeLuke @ Jul 13 2006, 10:07 PM)
if you launch opera from the konsole, the Z what say?

bye
*


Thanks for the reply.

Running from /home/root (freshly started Konsole) is says

CODE
opera: symbol lookup error: opera: undefined symbol: _7QString.shared_null



Walt
Go to the top of the page
 
+Quote Post

4 Pages V  < 1 2 3 4 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd September 2014 - 12:22 AM