OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Debian + 5500, No Internet From Zaurus!
kr5kernel
post Nov 18 2005, 08:33 PM
Post #1





Group: Members
Posts: 17
Joined: 17-June 04
From: Michigan
Member No.: 3,725



Ok so I have been following these how-to's to the t, perhaps i am forgetting something.

dmesg look slike this when I plug in the zaurus:
usb 1-2.2: new full speed USB device using address 13
usb0: register usbnet at usb-0000:00:02.0-2.2, Sharp Zaurus SL-5x00

ok, so its picking it up, then i run ifconfig:

ifconfig usb0 192.168.129.1 netmask 255.255.255.0 up
usb0 Link encap:Ethernet HWaddr 36:A3:3B:A7:C8:E4
inet addr:192.168.129.1 Bcast:192.168.129.255 Mask:255.255.255.0
inet6 addr: fe80::34a3:3bff:fea7:c8e4/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1098 errors:0 dropped:0 overruns:0 frame:0
TX packets:1392 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:144629 (141.2 KiB) TX bytes:132297 (129.1 KiB)

great, so i can ssh into the zaurus no problem, and i can ping my desktop (192.168.2.101) no problem from the zaurus

So I am guessing it must have somethign to do with the masquearading / gateway.

here are the routing tables for the zaurus:

root@collie:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.129.1 * 255.255.255.255 UH 0 0 0 usbd0
192.168.129.0 * 255.255.255.0 U 0 0 0 usbd0
default 192.168.129.1 0.0.0.0 UG 0 0 0 usbd0

the default gateway takes like 10 seconds before it shows up, /etc/resolv.conf is set for the router, same as my desktop (192.168.2.1 the router)

I cant ping ip's or hostnames though from the zaurus, it just times out, nor can i ping the ip of the router.

anyone have any suggesstions / things I can try?
Go to the top of the page
 
+Quote Post
jocasmi
post Oct 17 2007, 04:53 PM
Post #2





Group: Members
Posts: 99
Joined: 4-December 06
From: Barcelona, Spain
Member No.: 13,088



QUOTE(kr5kernel @ Nov 18 2005, 08:33 PM) *
Ok so I have been following these how-to's to the t, perhaps i am forgetting something.

dmesg look slike this when I plug in the zaurus:
usb 1-2.2: new full speed USB device using address 13
usb0: register usbnet at usb-0000:00:02.0-2.2, Sharp Zaurus SL-5x00

ok, so its picking it up, then i run ifconfig:

ifconfig usb0 192.168.129.1 netmask 255.255.255.0 up
usb0 Link encap:Ethernet HWaddr 36:A3:3B:A7:C8:E4
inet addr:192.168.129.1 Bcast:192.168.129.255 Mask:255.255.255.0
inet6 addr: fe80::34a3:3bff:fea7:c8e4/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1098 errors:0 dropped:0 overruns:0 frame:0
TX packets:1392 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:144629 (141.2 KiB) TX bytes:132297 (129.1 KiB)

great, so i can ssh into the zaurus no problem, and i can ping my desktop (192.168.2.101) no problem from the zaurus

So I am guessing it must have somethign to do with the masquearading / gateway.

here are the routing tables for the zaurus:

root@collie:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.129.1 * 255.255.255.255 UH 0 0 0 usbd0
192.168.129.0 * 255.255.255.0 U 0 0 0 usbd0
default 192.168.129.1 0.0.0.0 UG 0 0 0 usbd0

the default gateway takes like 10 seconds before it shows up, /etc/resolv.conf is set for the router, same as my desktop (192.168.2.1 the router)

I cant ping ip's or hostnames though from the zaurus, it just times out, nor can i ping the ip of the router.

anyone have any suggesstions / things I can try?



It's correct, that usb0 inet address? It seems to be the same address in the gateway.
Sorry if this is a silly question.

Go to the top of the page
 
+Quote Post
freizugheit
post Oct 17 2007, 07:41 PM
Post #3





Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811



Type the following commands using su:

route addd default gw 192.168.129.1
route add -host 192.168.129.1 usbod

I hope the above will help.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th December 2014 - 05:00 PM