OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

5 Pages V  « < 3 4 5  
Reply to this topicStart new topic
> SL 5500 TCK ROM 2.0 Aplha 3 with Home on SD script
Ventmore
post Apr 27 2006, 09:17 AM
Post #61





Group: Members
Posts: 62
Joined: 16-April 06
Member No.: 9,632



I have just installed this ROM, with the home on SD, and the async kernel.

It seems to be working a treat, however, my wireless network card no longer works. It worked fine on Sharp ROM 2.86 (I think) and 3.13 without any tweaking of the /etc/pcmcia/wlan-ng.conf file, but it now refuses to work with tkrom.

The device does detect a card, and labels it as an Intersil PRISM2 11Mbps card, but when I go into the network settings, it says there is no network available.

I tried adding the card manually to the wlan-ng.conf file, but that doesn't work either.

I don't want to go back to the Sharp ROM, as this one is great...apart from this problem smile.gif

All input appreciated
Ventmore
Go to the top of the page
 
+Quote Post
Ventmore
post Apr 29 2006, 09:02 AM
Post #62





Group: Members
Posts: 62
Joined: 16-April 06
Member No.: 9,632



Well...I've just gone trhough the whole process again, and this time it is working perfectly.

This time, I installed the wireless card after the initial flash. It was working fine, so I went ahead and flashed the async kernel. I checked the card again, and again it worked. After that, as the card was working, I ran:

prep-home-sd.sh -s 20 -t -c

Success!!!

The only thing I did differently, was to run the prep script with -c instead of -i. Also, I haven't reset again to clear the RAM out, but I don't think that should make a difference...in fact...I'll try that now.

Still working, and all of my apps are still intact smile.gif

Cheers
Ventmore
Go to the top of the page
 
+Quote Post
Ventmore
post Apr 30 2006, 03:14 PM
Post #63





Group: Members
Posts: 62
Joined: 16-April 06
Member No.: 9,632



Ok...I've lost it again. The card shows that it is recognised, as usual, but no network connection is hown, and if I run opera, it pops a net connection box, but there is nothing in the list.

Also, when I insert the card now, the light comes on and stays on, whereas, when it's working properly, the light only comes on when connected.

Any help would be very welcome
Ventmore
Go to the top of the page
 
+Quote Post
kb7sqi
post Nov 20 2006, 11:03 AM
Post #64





Group: Members
Posts: 28
Joined: 17-June 05
From: Winston Salem, NC
Member No.: 7,376



I know this is an older thread, but I thought I'ld let everyone know that I took some time to mess w/ my old 5500 last night and I was successful in taking the /root/etc/rc.d/rc.sysinit script from the TKC ROM 2.0 Alpha 3 and modifying both the original TKC 1.0 ROM and the Sharp 3.13 ROM w/ the script. The process was pretty quick and easy. While doing it I went ahead and replaced the /lib/modules.rom/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/sharp_mmcsd_m.o module w/ the patched one that is also mentioned here in the thread. My reasoning for doing this is, I never had much luck w/ the Cacko ROM/Kernel being stable w/ home on my sd card. The TKC ROM 2 has always ran stable. Anyway, I was getting errors when trying to use tun.o and ipsec.o modules w/ the TKC kernel. Both worked fine w/ the Original Sharp Kernel/3.13 ROM. So, now I have the 3.13 ROM running vpnc w/ no problems and still have my /home on my SD card. Everything is stable. Besides, re-installing alot of packages, I'm pretty happy using the stock Sharp ROM for now, but I'm going to revisit this area eventually and make an new updated ROM for my 5500. If anyone is interested in the initrd.bin files, feel free to drop me an email. I usually read the site daily when I can, but hardly ever post. I haven't used my Z in awhile because of work, but I've been growing tired of my Palm PDA's again & have a re-newed interest in the Z. In fact I just bought a 5600 today & will hopefully have 6000 this week. I'm also looking forward to getting a 3200 to replace the 3000 I sold to loc4me last year along w/ my Palm LifeDrive and a TX. He just got those not too long ago and has been having fun w/ lately. :-)
Go to the top of the page
 
+Quote Post
arniel
post Nov 21 2006, 07:05 AM
Post #65





Group: Members
Posts: 103
Joined: 2-February 04
From: UK
Member No.: 1,563



QUOTE(kb7sqi @ Nov 20 2006, 07:03 PM)
I know this is an older thread, but I thought I'ld let everyone know that I took some time to mess w/ my old 5500 last night and I was successful in taking the /root/etc/rc.d/rc.sysinit script from the TKC ROM 2.0 Alpha 3 and modifying both the original TKC 1.0 ROM and the Sharp 3.13 ROM w/ the script.  The process was pretty quick and easy.  While doing it I went ahead and replaced the /lib/modules.rom/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/sharp_mmcsd_m.o module w/ the patched one that is also mentioned here in the thread.  My reasoning for doing this is,  I never had much luck w/ the Cacko ROM/Kernel being stable w/ home on my sd card.  The TKC ROM  2 has always ran stable.  Anyway, I was getting errors when trying to use tun.o and ipsec.o modules w/ the TKC kernel.  Both worked fine w/ the Original Sharp Kernel/3.13 ROM.  So, now I have the 3.13 ROM running vpnc w/ no problems and still have my /home on my SD card.  Everything is stable.  Besides, re-installing alot of packages, I'm pretty happy using the stock Sharp ROM for now, but I'm going to revisit this area eventually and make an new updated ROM for my 5500.  If anyone is interested in the initrd.bin files, feel free to drop me an email.  I usually read the site daily when I can, but hardly ever post.  I haven't used my Z in awhile because of work, but I've been growing tired of my Palm PDA's again & have a re-newed interest in the Z.  In fact I just bought a 5600 today & will hopefully have 6000 this week.  I'm also looking forward to getting a 3200 to replace the 3000 I sold to loc4me last year along w/ my Palm LifeDrive and a TX.  He just got those not too long ago and has been having fun w/ lately.  :-)
*


I'd certainly be interested in a new ROM for the 5500, looks like things have stagnated a bit... all the alternatives to OZ are at least 2 years old. In fact, I just installed Cacko 2.4.18 w/1.6.2 yesterday as I'm looking for a more stable alternative to OZ, but of course it's not a pretty/functional and I've yet to get some useful IPKs together for pdf reading and opera.
Go to the top of the page
 
+Quote Post
tux
post Jul 19 2007, 04:48 AM
Post #66





Group: Members
Posts: 450
Joined: 12-August 03
From: Leeds, UK
Member No.: 346



cool.gif

Just thought I'd bump this thread up a bit.

The threads about using the tweaked Sharp and TKC roms that have home on sd with the >2gb drivers seem to have made it more topical.

(Oh and thanks very much to kb7sqi for the work and the product!)biggrin.gif

If any admin reads this and has the time would it be possible to move this thread to the 5500 general forum?

If that happened would it be possible to make it a sticky thread? smile.gif

If that happened perhaps the two other threads mentioned above could also be made sticky?

Cheers biggrin.gif
Go to the top of the page
 
+Quote Post

5 Pages V  « < 3 4 5
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 1st November 2014 - 03:14 AM