OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Linux Filesystem And File Access Privileges, after formatting hdd3 as ext2
matthis
post Aug 20 2007, 07:38 AM
Post #1





Group: Members
Posts: 218
Joined: 12-February 06
From: Tokyo
Member No.: 9,124



I have formatted my sl-c3200's hard drive as ext2, and moved back the files that were on it before, when it was in fat (dos?). Since then, I have trouble dealing with files as normal zaurus user, and have to do things as root. I have tried chown -R zaurus /hdd3/ but it doesn't change anything...
Any suggestions?
Go to the top of the page
 
+Quote Post
Capn_Fish
post Aug 20 2007, 08:10 AM
Post #2





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



try moving the files off the disk as root, then becoming a normal user and copying them back. chowning the directory to a normal user makes the directory the user's, but not the files/dirs inside of it. Copying the files back to it as a normal user should solve that issue.
Go to the top of the page
 
+Quote Post
T3_slider
post Aug 20 2007, 11:32 AM
Post #3





Group: Members
Posts: 125
Joined: 26-December 06
Member No.: 13,449



That's why he added the -R option, which does recursively make all directories/files belong to the user (unless I'm mistaken). I always do chown -R user:group, but your syntax looks fine (assuming your data is mounted at /hdd3).

You may also want to check your fstab file to see if it is mounting it read-only or something like that.
Go to the top of the page
 
+Quote Post
Meanie
post Aug 20 2007, 03:37 PM
Post #4





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(matthis @ Aug 21 2007, 01:38 AM)
I have formatted my sl-c3200's hard drive as ext2, and moved back the files that were on it before, when it was in fat (dos?). Since then, I have trouble dealing with files as normal zaurus user, and have to do things as root. I have tried chown -R zaurus /hdd3/ but it doesn't change anything...
Any suggestions?
*



if you have installed the tetsu kernel without also installing the associated modules, then i have observed the same behaviour. after installing the modules, all become as it should....
Go to the top of the page
 
+Quote Post
matthis
post Aug 21 2007, 05:27 AM
Post #5





Group: Members
Posts: 218
Joined: 12-February 06
From: Tokyo
Member No.: 9,124



Thanks for your suggestions.

- I'd rather not copy all files off and on again... wink.gif
- I already had the tetsu kernel modules installed.

I'll look further into the issue. What would be the normal mounting command options to have in rc.rofilesys? I have "mount -t ext2 -o noatime /dev/${IDE1}3 /hdd3"

thanks for your help
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2014 - 02:12 AM