OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Netswitch Locks Up Z When Usb-lan Plugged In, What can I do to get netswitch to work?
Jon_J
post Oct 25 2007, 09:37 AM
Post #1





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



I have a C3100 with cacko lite 1.23 and all USB modules installed
I have been trying to get my Belkin USB to LAN adapter to work, and it always locked up my Zaurus until I uninstalled netswitch 0.4
This dongle uses the pegasus driver.
Cacko has the pegasus.o driver in /lib/modules/2.4.20/kernel/drivers/usb
and netswitch has pegasus.o in /lib/modules/2.4.20/kernel/drivers/usb/net
I renamed the driver that was included in cacko so the one installed by netswitch would load.
I still have lockups as soon as I plug in my dongle.
WhenI uninstall netswitch, and rename the cacko installed pegasus.o back to its original name, I don't have lockups anymore.
But the pegasus driver won't load. I tried many things in this thread, but nothing seems to work.
http://www.oesf.org/forum/index.php?showtopic=24949

How can I use meanie's netswitch package without it locking up my Z?

Thank you,
Jon
Go to the top of the page
 
+Quote Post
Jon_J
post Oct 25 2007, 03:34 PM
Post #2





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



I found an alternative way to connect my USB LAN dongle in a very roundabout way, see thread below.
http://www.oesf.org/forum/index.php?showtopic=24949
I would still like to use Meanie's netswitcher someday and have it work like it is supposed to work.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st December 2014 - 07:52 AM