OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V  < 1 2  
Reply to this topicStart new topic
> Apt-get In Zubuntu, How to install new packages
ofels
post May 9 2009, 06:47 AM
Post #16





Group: Members
Posts: 142
Joined: 4-December 06
From: Lake Constance, Germany
Member No.: 13,087



QUOTE(whykickamoocow @ May 9 2009, 01:13 AM) *
Thanks for the help guys but i think its a little ove rmy head now,im still pretty new to linux and i think i have a hell of a way b4 im up to your standrds. I did a lsmod and this is what it came up with, i realy dont know what im looking at.

CODE

orinoco_cs 13860 0
orinoco 40916 1 orinoco_cs
hermes 5824 2 orinoco_cs,orinoco
hostap_cs 54772 3
hostap 104900 1 hostap_cs


The operating system loads some driver modules into the kernel if required. Which ones are loaded can be gathered via the lsmod command.
On zubuntu it is a known issue that for some prism chipset based cards the orinoco and hermes driver modules get loaded as well as the hostap module.
This will lead to incompatibility and faulty behavior of the card.
What you should do: Edit the file /etc/modprobe.d/blacklist.conf and the lines

CODE

blacklist orinoco
blacklist orinoco_cs
blacklist hermes
blacklist hermes_cs


hostap and hostap_cs must not be blacklisted.

Then reboot. This will prevent the orinoco and hermes modules from being loaded and should make things a lot better (though it is not very convenient for a newcomer, but hey, it is a Zaurus and you opted for some hacks by installing zubuntu smile.gif )

After the reboot lsmod should not show the orinoco and hermes modules being loaded and there should be a wlan0 network interface if you do ifconfig.

I hope this helps, if not, ask smile.gif

Oliver
Go to the top of the page
 
+Quote Post
speculatrix
post May 10 2009, 11:51 AM
Post #17





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



if despite blacklisting the hermes and and orinoco modules they still appear in lsmod, then find the files under the /lib/modules directory, and rename them "slightly" - stick an "_" on the end of the file names.
Go to the top of the page
 
+Quote Post
whykickamoocow
post May 13 2009, 04:08 AM
Post #18





Group: Members
Posts: 23
Joined: 11-March 09
Member No.: 33,360



Yeah that seemed to have worked,when i do a lsmod i dont see the orinoco or the hermes anymore, when i do the ifconfig i get the wifi0 and the wlan0 and both seem to look ok. when i use wifi radar to connect to my router it connects but it cant find the ip addy,swo its sort of halfway there but i still cant connect to the internet.Anybody got any ideas?

Regards whykick
Go to the top of the page
 
+Quote Post
whykickamoocow
post May 13 2009, 04:54 AM
Post #19





Group: Members
Posts: 23
Joined: 11-March 09
Member No.: 33,360



I also get this message when i try this

CODE
root@Zubuntu:~# iwconfig wlan0 essid sukmebeautifull mode managed
root@Zubuntu:~# ifup wlan0
There is already a pid file /var/run/dhclient.wlan0.pid with pid 0
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wifi0: unknown hardware address type 801
Can't create addrlist socket
Failed to bring up wlan0.
root@Zubuntu:~# ifup wlan0
There is already a pid file /var/run/dhclient.wlan0.pid with pid 0
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wifi0: unknown hardware address type 801
Can't create addrlist socket
Failed to bring up wlan0.
root@Zubuntu:~#




Regards whykick
Go to the top of the page
 
+Quote Post
same
post May 13 2009, 09:12 AM
Post #20





Group: Members
Posts: 51
Joined: 29-October 07
From: barcelona
Member No.: 20,873



QUOTE(whykickamoocow @ May 13 2009, 04:54 AM) *
I also get this message when i try this

CODE
root@Zubuntu:~# iwconfig wlan0 essid sukmebeautifull mode managed
root@Zubuntu:~# ifup wlan0
There is already a pid file /var/run/dhclient.wlan0.pid with pid 0
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wifi0: unknown hardware address type 801
Can't create addrlist socket
Failed to bring up wlan0.
root@Zubuntu:~# ifup wlan0
There is already a pid file /var/run/dhclient.wlan0.pid with pid 0
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wifi0: unknown hardware address type 801
Can't create addrlist socket
Failed to bring up wlan0.
root@Zubuntu:~#




Regards whykick


it seems you have a dhcp problem now, check this topic to try to fix it: http://www.oesf.org/forum/index.php?showtopic=26435
Go to the top of the page
 
+Quote Post
whykickamoocow
post May 13 2009, 04:24 PM
Post #21





Group: Members
Posts: 23
Joined: 11-March 09
Member No.: 33,360



I would just like to thank everbody on here who has help me out with this, at last i got it connected with wep, to all those who are like me a complete newbie, please just follow this post to get connected to your router. At times you will feel like banging your head but if you follow this post then all the hard must be done for you, im not sure on a cpl of thingsi have done to make this work, i need to read up about it,but at the end of the day it worked. thanks again.

Regards whykick
Go to the top of the page
 
+Quote Post

2 Pages V  < 1 2
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd August 2014 - 09:36 PM