OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Z Won't Write To Sd
uriahgreer
post Jun 11 2010, 04:18 PM
Post #1





Group: Members
Posts: 15
Joined: 3-March 10
Member No.: 64,496



With the new driver (fantastic, btw) I've been using an 8 gig sandisk class2 sdhc card in my z3200 for the past couple months without a hitch.

Until now.

I can't fathom why, but I am completely unable to write to or delete files from the sd card when it's in my zaurus. In my netbook, piece of cake. I tried rebooting. I tried flicking the switch back and forth. I unchecked that box that said "protection" in the files menu. I even went on windows and un-archived, and un-read-only'ed every file and folder just for kicks. No soap. I can read files, no problem. But I can't save to or edit anything on it.

And if it's a hardware issue, I can't wrap my head around it--I put in a 2gig non-sdhc and wrote and deleted sans trouble.

I'm on Cacko 1.23. Any thoughts? I'd greatly appreciate it.
Go to the top of the page
 
+Quote Post
xamindar
post Jun 12 2010, 01:16 AM
Post #2





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



You didn't format that card as ntfs did you?
Go to the top of the page
 
+Quote Post
uriahgreer
post Jun 12 2010, 07:16 PM
Post #3





Group: Members
Posts: 15
Joined: 3-March 10
Member No.: 64,496



QUOTE(xamindar @ Jun 12 2010, 04:16 AM) *
You didn't format that card as ntfs did you?

Negative. Properties says, "FAT32". Never even tried formatting it. I can't fathom it... Works fine in my other SD slots... Just not on my terrier. No idea what could've prompted it...
Go to the top of the page
 
+Quote Post
xamindar
post Jun 12 2010, 07:48 PM
Post #4





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



Could also be file system corruption on that particular SD card. Linux will mount damaged filesystems as read only. Did you try running a filesystem scan in windows on that card to see if it was able to fix anything? That doesn't explain why it works fine in your netbook though.
Go to the top of the page
 
+Quote Post
uriahgreer
post Jun 13 2010, 08:12 PM
Post #5





Group: Members
Posts: 15
Joined: 3-March 10
Member No.: 64,496



Well, I actually did try that, and that came up nada as well. So I did what I probably should've done in the first place: I backed up all the files, formatted the card (fat32), and then put the files back.

Problem gone.

Not technically solved, of course, as it seems I'll never know what'd happened, but at least it does write correctly now. Thanks so much for the timely responses tho! I am glad to see these forums still kicking, and I'm sure I'll need help with some other things in the near future (my list is reaching critical mass). Good health, and happy coding! (Or is that bashing? ...hacking? Or is that a misnomer? ...You get me.)
Go to the top of the page
 
+Quote Post
koan
post Jun 14 2010, 11:57 AM
Post #6





Group: Members
Posts: 328
Joined: 25-February 04
From: UK
Member No.: 2,025



QUOTE(uriahgreer @ Jun 14 2010, 02:12 PM) *
Not technically solved, of course, as it seems I'll never know what'd happened, but at least it does write correctly now.


Perhaps Flash memory wear and tear ? By reformatting the bad blocks got mapped out... ?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th July 2014 - 11:52 AM