OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

6 Pages V  « < 2 3 4 5 6 >  
Reply to this topicStart new topic
> Software for the SL-6000, (and feeds)
GoLinux
post Dec 2 2004, 06:34 PM
Post #46





Group: Members
Posts: 82
Joined: 24-January 04
From: Boston, USA
Member No.: 1,531



Gramps,

try this one:

http://cyberphreak.com/zaurus/feed/

the guy who maintain it owns only the SL-6000L, as far as I know.

You may also want to have a look at his Zaurus page:

http://cyberphreak.com/zaurus/

If it can help, this is the list of all programs I have installed and work on my SL-6000L (not all downloaded from the above feed, by the way):

Backgammon 0.9.5
FreeNote 1.9.2pre
Javachess 1.0
Kino2 0.3 (but with mplayer from version 0.22)
Opie-reader 0.7h
Opie-tetrix 1.5-1
Petittrack 1.2.0 (Satellite Tracking software, I'm an Amateur Radio operator)
Powerchord 0.0.7
Qpdf2 freetype-2.2.1-20040217 (this is the version I found working best)
ResistorUI 1.5.0-0.9 (utility to "translate" resistors' color code)
ZUC 1.1 (conversion utility: ounces to grams, miles to kilometers, etc.)

About half of those programs can run at full 640x480 resolution. The rest works best with "display with magnified screen" checked, which will switch the Z to 320x240.

Enjoy the Z!!! wink.gif
Go to the top of the page
 
+Quote Post
neuroshock
post Dec 2 2004, 08:30 PM
Post #47





Group: Members
Posts: 269
Joined: 12-September 04
From: North Carolina, USA
Member No.: 4,562



You should find some good software and feeds in this thread:

software thread

Good Luck,
NeuroShock
Go to the top of the page
 
+Quote Post
gramps
post Dec 3 2004, 03:58 PM
Post #48





Group: Members
Posts: 13
Joined: 22-November 04
Member No.: 5,570



Thanks guys that was a big help!
Go to the top of the page
 
+Quote Post
guylhem
post Dec 5 2004, 08:26 AM
Post #49





Group: Members
Posts: 577
Joined: 17-March 04
Member No.: 2,365



externe.net/zaurus/feed/6000 (fixed missing Packages)
Go to the top of the page
 
+Quote Post
BarryW
post Dec 6 2004, 12:13 AM
Post #50





Group: Members
Posts: 693
Joined: 4-June 04
From: Ohio
Member No.: 3,570



QUOTE(guylhem @ Dec 5 2004, 07:26 AM)
externe.net/zaurus/feed/6000 (fixed missing Packages)

Would this be externe.net/zaurus/feeds/6000/ ??
Go to the top of the page
 
+Quote Post
cosmos7
post Dec 13 2004, 06:33 PM
Post #51





Group: Members
Posts: 15
Joined: 8-December 04
Member No.: 5,838



Since I couldn't find a shfs port anywhere, I built one myself. Keep in mind this will probably only work on the SL-6000L, and even then likely only on the stock ROM due to the kernel module. I've tested the package on my Z, and it installs/uninstalls cleanly, but I have no other hardware / configurations to test it on. Use at own risk... biggrin.gif

http://files.tokomak.net/zaurus/shfs_0.35_...harprom_arm.ipk
Go to the top of the page
 
+Quote Post
soundwave106
post Dec 16 2004, 06:04 AM
Post #52





Group: Members
Posts: 108
Joined: 29-November 04
Member No.: 5,667



To anyone who has gotten prboom to work, can you post some information on what you did? I keep getting "Segmentation Fault" errors whenever I run prboom on my SL-6000L. I used the IPKs here: http://www.gnurou.org/zaurus/feed
Go to the top of the page
 
+Quote Post
the_oak
post Dec 17 2004, 07:14 PM
Post #53





Group: Members
Posts: 426
Joined: 10-February 04
From: Virginia, USA
Member No.: 1,794



biggrin.gif Tree!Explorer QT is just about the nicest file manager I have used. The 1.7.0 version at http://www.killefiz.de/zaurus/ works very well with the Sharp rom 1.12 that came on the SL-6000. When it first starts, it is in Japenese (I think) but since I don't have Japenese fonts installed, the words across the top just look like boxes with letters beside them. If you click on the box beside the (V) for view, you can select English then everything works great (providing you speak English). You can also select French which looks like it works too. (Not completely sure since I don't speak French).
Go to the top of the page
 
+Quote Post
soundwave106
post Dec 18 2004, 01:37 PM
Post #54





Group: Members
Posts: 108
Joined: 29-November 04
Member No.: 5,667



Yeah, TreeExplorer is great. smile.gif

Might as well post what I'm keeping on my SL-6000L so far aside from the standard Qtopia apps. This is using the standard Sharp ROM 1.12. Yeah, I've been busy. smile.gif

Applications:
FreeNoteQT (1.10.0)
FBVNCServer-SL6000 (0.9.5) (+ Added to rc.local) (* The zaurus version you typically find on feeds will cause massive problems, get the version from http://sdgsystems.com/download.html)
Hancompresenterviewer (1.6.0)
Kismet (3.0.1c-20031228) (* Signifigant hacking required)
Neic (1.0.1) (IRC client)
Neocal-Qtopia (1.7.7)
Opie Keypebble (0.9.1-20020703) (VNC viewer)
Pure-FTPD (1.0.16-1) (+ Added to /etc/rc.local)
Python-exe (0.2)
Qazoo (0.8.1) (Yahoo IM)
QPDF2 (freetype-2.2.1-20040217)
QPE Filemanager (qpe-filemanager-vga) (1.5.0-2)
GAIM (qpe-gaim) (0.4-1cxx0) (* Signifigant hacking required)
Terminal (qpe-terminal-vga) (1.5.0-3)
QPEAlarmClock (2.0.0)
Qtopia-Sysinfo (1.0.1)
QTRDesktop (1.2.0) (Remote Desktop application)
RSync (2.5.6) (* Cannot get server to work, haven't tried client sync. I find it easier to use a Windows program called FTPSync and/or write custom stuff.)
SQLite3 (0.8.6)
TKCPlayer (2.0-031101)
TKCZip (2.0-031205)
Treeexplorer (1.6.0)
TXImage (0.2)
ZBedic (0.9.2-2 + many dictionaries, Wikipedia, etc.)
ZEditor (2.2.6English)
Zuc (1.1) (units conversion)

Games:
BustEm-Demo (1.2)
Froot (0.7.1)
Heretic (* More for giggles, I've found it unplayable. I run in 480x640 mode, oddly enough the mappings aren't bad and its faster that way.)
Interstellar-Flames-Demo (1.0)
KPacman (0.3.1-0.1)
Nethack (* Signifigant hacking required)
Opie Tetrix (1.5-1)
QPE-Minesweep (1.5.0-1)
Vectroids (1.1.0)
Zemufe (0.9.2-2) (Front end for ZNester)
ZNester (7.1-1) (* Added a custom znester.rc file so that the keymappings are wonky and reversed. If anyone wants the file I'd be happy to drop a web page on it. I'd love to disable sound, if anyone knows how to do this please let me know.)
ZSolitare (1.0)

Unix utilities:
ArmUtils (1)
Nano (0.9.23)

Libraries and drivers:
eon-libflac (1.0)
gconv-tiny (2.2.4-2)
irk-zaurus (0.11.0) (Taurus keyboard driver)
kismet-QT (2.0.0)
libSDL (1.2.6-zports_c7x0-1)
libSDL-mixer (1.2.5cvs-1)
libSDL-net (1.2.5cvs-1)
libgaim (0.73-1)
libgaim-protocols (0.73-1)
libgaim-ssl (0.73-1)
libgcrypt1 (1.1.9-3)
libglib2.0 (2.2.1)
libgnutls7 (0.8.10-2)
libopie1 (1.0.2)
libopie2 (1.8.2)
libpcap0 (0.7.2)
libpng (2.1.0.9)
libyahoo2 (0.7.4.2)
openssl-0.9.7a (0.9.7a)
qazoosounds (0.8)
zlib (1.1.2)
zlib1 (1.1.4)

I also followed these instructions (http://www.zaurususergroup.com/modules.php?op=modload&name=phpWiki&file=index&pagename=Samba%20over%20non-USB) to enable Samba all the time when connected; changed the passwords (so pure-ftpd is more secure), added mount / unmount USB commands, etc.

The following software I remember explicitly not working:
tkcRadio
MAME emulators (MaxMame works, but is dog slow. zMame doesn't work at all. Help us out here, coders smile.gif )
prboom (segment faults on my machine)

I'd love to see a Genesis emulator sometime for the Zaurus.

There's probably other software I tried that I can't remember that works, but I didn't like. smile.gif
Go to the top of the page
 
+Quote Post
dfisher
post Jan 9 2005, 07:19 AM
Post #55





Group: Members
Posts: 51
Joined: 30-May 03
From: Toronto,Ontario
Member No.: 66



Hi,

I used to love using qconsole on my SL-5500 with it's tabbed sessions and readible fonts. Does anyone know of a version compiled for use with the SL-6000's higher resolution screen?

Thanks,
Doug
Go to the top of the page
 
+Quote Post
hatchetman
post Jan 10 2005, 07:53 AM
Post #56





Group: Members
Posts: 60
Joined: 3-November 04
Member No.: 5,332



Sorry I don't have a link handy, but I've used the qkonsole application found on the zaurus software archive website without a problem on my 6000. Select unmagnify and it will give you the higher resolution.
Go to the top of the page
 
+Quote Post
dfisher
post Jan 11 2005, 07:44 AM
Post #57





Group: Members
Posts: 51
Joined: 30-May 03
From: Toronto,Ontario
Member No.: 66



Nice.

Thanks a lot hatchetman!

Doug
Go to the top of the page
 
+Quote Post
inode0
post Jan 12 2005, 12:53 PM
Post #58





Group: Members
Posts: 97
Joined: 15-December 04
Member No.: 5,933



Thought I'd make the stuff I have compiled on my 6k available for others to use if they wish.
The list thus far includes

bc_1.06_arm.ipk
bison_1.875_arm.ipk
bzip2_1.0.2_arm.ipk
cowsay_3.03_arm.ipk
ddate_2.0_arm.ipk
diffutils_2.8.1_arm.ipk
flex_2.5.4a_arm.ipk
gawk_3.1.4_arm.ipk
grep_2.5.1a_arm.ipk
heimdal_0.6.3_arm.ipk
hesiod_3.0.2i_arm.ipk
less_382_arm.ipk
m4_1.4.2_arm.ipk
minicom_2.00.0_arm.ipk
miscfiles_1.4.2_arm.ipk
mtr_0.67_arm.ipk
ntpdate_4.2.0_arm.ipk
rcs_5.7_arm.ipk
screen_4.0.2_arm.ipk
sed_4.1.2_arm.ipk
sharutils_4.2.1_arm.ipk
strace_4.5.8_arm.ipk
tar_1.15_arm.ipk
units_1.80_arm.ipk
which_2.16_arm.ipk

You can find the packages and notes about them at Zaurus Packages.

Please read any notes about a package before installing as some have special needs.

Enjoy.

John
Go to the top of the page
 
+Quote Post
inode0
post Jan 17 2005, 08:27 PM
Post #59





Group: Members
Posts: 97
Joined: 15-December 04
Member No.: 5,933



QUOTE(inode0 @ Jan 12 2005, 08:53 PM)
You can find the packages and notes about them at Zaurus Packages.

Please read any notes about a package before installing as some have special needs.
*


Well, I have added some more. Not all are thoroughly tested so if you notice anything funny please drop me a note so I can fix it. Here is the current list, and it likely won't change for a while except for bug fixes. While it isn't clear from the list below: links, lynx, and wget are all SSL enabled.

CODE
bc_1.06_arm.ipk           gcal_3.01_arm.ipk        ntpdate_4.2.0_arm.ipk
bind_9.3.0_arm.ipk        gnupg_1.4.0_arm.ipk      openssl-devel_0.9.7e_arm.ipk
bison_1.875_arm.ipk       grep_2.5.1a_arm.ipk      patch_2.5.4_arm.ipk
bzip2_1.0.2_arm.ipk       heimdal_0.6.3_arm.ipk    rcs_5.7_arm.ipk
coreutils_5.2.1_arm.ipk   hesiod_3.0.2i_arm.ipk    screen_4.0.2_arm.ipk
cowsay_3.03_arm.ipk       host_9.3.0_arm.ipk       sed_4.1.2_arm.ipk
cpio_2.6_arm.ipk          less_382_arm.ipk         sh-utils_2.0_arm.ipk
ddate_2.0_arm.ipk         librt_2.2.2_arm.ipk      sharutils_4.2.1_arm.ipk
diffutils_2.8.1_arm.ipk   links_0.98_arm.ipk       socat_1.4.1.0_arm.ipk
dig_9.3.0_arm.ipk         lynx_2.8.5_arm.ipk       strace_4.5.8_arm.ipk
fileutils_4.1_arm.ipk     m4_1.4.2_arm.ipk         stunnel_4.07_arm.ipk
find_4.1.20_arm.ipk       minicom_2.00.0_arm.ipk   tar_1.15_arm.ipk
findutils_4.1.20_arm.ipk  miscfiles_1.4.2_arm.ipk  units_1.80_arm.ipk
flex_2.5.4a_arm.ipk       mtr_0.67_arm.ipk         wget_1.9.1_arm.ipk
gawk_3.1.4_arm.ipk        nslookup_9.3.0_arm.ipk   which_2.16_arm.ipk


Enjoy.

John
Go to the top of the page
 
+Quote Post
xenophobe
post Jan 18 2005, 02:49 AM
Post #60





Group: Members
Posts: 25
Joined: 29-September 04
From: Ukraine
Member No.: 4,801



TO: inode0
Pls fix link onto your openssl_0.9.7e_arm.ipk package.
Go to the top of the page
 
+Quote Post

6 Pages V  « < 2 3 4 5 6 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th December 2014 - 10:53 PM