OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> trivial infuriating problem
jamesannan
post Jul 21 2004, 05:41 AM
Post #1





Group: Members
Posts: 119
Joined: 8-July 04
Member No.: 3,955



I had the Kopi java thing working fine last week...then reinstalled everything to a SD card. Grrrrrrrr...

And now I try to compile and run a trivial applet (ie evm -appletviewer /mnt/card/java/HelloWorld.html where the html file just contains a link to the class file), and get an error like

FileNotFoundException:/mnt/card/java/HelloWorld/class.class

Of course the class file is actually just /mnt/card/java/HelloWorld.class, so why is it looking for this nonexistent file? Obbviously I have something wrong in a pathname somewhere, but I'm buggered if I can work it out. Any ideas?

James
Go to the top of the page
 
+Quote Post
javalori
post Jul 21 2004, 07:09 AM
Post #2





Group: Members
Posts: 6
Joined: 21-June 03
From: Calgary
Member No.: 191



Can you post the reference to the class file that appears in the HTML file? It's difficult to say, without seeing that wink.gif
Go to the top of the page
 
+Quote Post
jamesannan
post Jul 21 2004, 01:19 PM
Post #3





Group: Members
Posts: 119
Joined: 8-July 04
Member No.: 3,955



Ah....

I had the ref to "HelloWorld.class" (and had tried all combinations of full/relative pathname, with/wthout extension) but had not noticed that it should have been HelloWorldApplet!

Oops!

thanks for the hint..

James
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st September 2014 - 08:10 AM