OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Still can't ping the zaurus, And I've exhausted google....
tekniklr
post Sep 2 2004, 11:21 AM
Post #1





Group: Members
Posts: 2
Joined: 2-September 04
From: Ithaca, NY
Member No.: 4,443



Alright, I've been trying to do this on my own, but it's been at least 5 days and I'm basically just going in circles.

My zaurus is a SL-5000D running OpenZaurus 3.2. My computer is running gentoo with kernel version 2.6.7.

I've tried various combinations of instructions from docs and forums all over the place (From OZ, ethernet over usb. ppp over usb, even other threads from this forum) and I'm still at the exact place I started.

No matter what I seem to do, or how many kernel configuration permutations I seem to try, I still cannot ping the zaurus:
CODE
root@minips1 /usr/src/linux # ping 192.168.129.201
PING 192.168.129.201 (192.168.129.201) 56(84) bytes of data.
From 192.168.129.1 icmp_seq=1 Destination Host Unreachable
From 192.168.129.1 icmp_seq=2 Destination Host Unreachable
From 192.168.129.1 icmp_seq=3 Destination Host Unreachable
From 192.168.129.1 icmp_seq=4 Destination Host Unreachable
From 192.168.129.1 icmp_seq=5 Destination Host Unreachable
From 192.168.129.1 icmp_seq=6 Destination Host Unreachable

--- 192.168.129.201 ping statistics ---
7 packets transmitted, 0 received, +6 errors, 100% packet loss, time 6000ms
, pipe 4


I plug in the zaurus, and see the following in my syslog:
CODE
Sep  2 14:04:01 localhost kernel: usb 2-1: new full speed USB device using address 2
Sep  2 14:04:01 localhost kernel: usb0: register usbnet at usb-0000:00:1d.1-1, Sharp Zaurus SL-5x00
Sep  2 14:04:01 localhost kernel: usbcore: registered new driver usbnet
at which point hotplug sets up my usb0 network.
CODE
root@minips1 /usr/src/linux # lsmod
Module                  Size  Used by
wlan_wep                6144  1
usbnet                 13192  0
ath_pci                55716  0
wlan                  105472  3 wlan_wep,ath_pci
ath_hal               125008  2 ath_pci
ehci_hcd               26436  0
uhci_hcd               29136  0


I have the following line in my /etc/conf.d/net file:
CODE
iface_usb0="192.168.129.1 pointopoint 192.168.129.201 netmask 255.255.255.0"
(I have also tried 192.168.129.200, instead of 192.168.129.1, with the same results) which appears to be working as the output of the below commands shows:
CODE
root@minips1 /home/tekniklr # ifconfig usb0
usb0      Link encap:Ethernet  HWaddr E6:3D:50:73:2F:0E  
         inet addr:192.168.129.1  Bcast:192.168.129.255  Mask:255.255.255.0
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:0 errors:80828 dropped:0 overruns:0 frame:0
         TX packets:6 errors:12 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:0 (0.0 b)  TX bytes:276 (276.0 b)

root@minips1 /home/tekniklr # route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.129.0   *               255.255.255.0   U     0      0        0 usb0
10.0.0.0        *               255.255.255.0   U     0      0        0 ath0
loopback        localhost.local 255.0.0.0       UG    0      0        0 lo
default         10.0.0.1        0.0.0.0         UG    0      0        0 ath0

If've also tried this, which doesn't give me better results:
CODE
root@minips1 /home/tekniklr # route add -host 192.168.129.201 usb0
root@minips1 /home/tekniklr # route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.129.201 *               255.255.255.255 UH    0      0        0 usb0
192.168.129.0   *               255.255.255.0   U     0      0        0 usb0
10.0.0.0        *               255.255.255.0   U     0      0        0 ath0
loopback        localhost.local 255.0.0.0       UG    0      0        0 lo
default         10.0.0.1        0.0.0.0         UG    0      0        0 ath0


My kernel has the following relevant configuration:
CODE
Device Drivers  --->
    USB support  --->
 [*] Enfore USB bandiwdth allocation
 <M> EHCI HCD (USB 2.0) support
 <M> UHCI HCD (most Intel and VIA) support
 <M> Multi-purpose USB Networking Framework
 [*] Embedded ARM Linux links (iPaq, ...)
 [*] Sharp Zaurus (stock ROMs)
 [*] CDC Ethernet support (smart deviced such as cable modems)
 USB Gadget Support  --->
     <*> Support for USB Gadgets
     <*>   USB Gadget Drivers (Ethernet Gadget)  --->
    Networking support  --->
 <*> PPP (point-to-point protocol) support
 <*> PPP support for sync tty ports
 <*> PPP Deflate compression
 <*> PPP BSD-Compress compression
(one of the many tutorials I looked at said PPP was needed).

On the zaurus side, Ive verified that usbd0 is up and running with IP 198.168.129.201, and that it is accepting sync connections from '192.168.129.0/24 (default)' (though I've also tried 'All'). I've tried running
CODE
# route add default gw 192.168.129.1
SIOCADDRT: Network is unreachable
(same results whether I'm trying to use 192.168.129.1 or 192.168.129.200 on my computer).

Anyway, I've recompiled my kernel no less than 15 times already, just trying whatever different things I can think of, and am now completely at a loss. I don't know if I missed a step or what, but I've gone over everything so much that I don't think I'd be able to find the problem myself anyway.

Any ideas? Please?
Go to the top of the page
 
+Quote Post
lardman
post Sep 2 2004, 12:16 PM
Post #2





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



Try posting to the openzaurus-users mailing list (link on the openzaurus.org contacts page). It's probably also worth sitting on #openzaurus on irc to see whether anyone there has any ideas.

I presume you've seen the earlier posts on this site about getting connectivity to work with 2.6.x kernels?:

http://www.oesf.org/forums/inde...wtopic=4544&hl=


I've just upgraded my linux box to 2.6.x so I shall also be looking at how this stuff works (tomorrow). What fun ;-)


Si
Go to the top of the page
 
+Quote Post
tekniklr
post Sep 2 2004, 01:24 PM
Post #3





Group: Members
Posts: 2
Joined: 2-September 04
From: Ithaca, NY
Member No.: 4,443



QUOTE(lardman @ Sep 2 2004, 08:16 PM)
I presume you've seen the earlier posts on this site about getting connectivity to work with 2.6.x kernels?:

http://www.oesf.org/forums/inde...wtopic=4544&hl=

Yeah, from that and other sources I've seen, it looks everything should just work with the kernel config I have in 2.6.x.... but it's not. I'll try posting this o that mailing list, though I'm beginning to worry it's a lost cause.
Go to the top of the page
 
+Quote Post
h2gofast
post Sep 15 2004, 12:47 PM
Post #4





Group: Members
Posts: 33
Joined: 11-September 04
Member No.: 4,550



http://www.linux-migration.org/ch05s08s02.html
this worked for me with 2.6.8
Go to the top of the page
 
+Quote Post
alan
post Oct 5 2004, 05:22 AM
Post #5





Group: Members
Posts: 221
Joined: 19-March 04
Member No.: 2,411



i had the same situation untill i turned off my firewall... Not a good solution, but at l(e)ast it works...
Go to the top of the page
 
+Quote Post
jamesm
post Oct 5 2004, 05:55 AM
Post #6





Group: Members
Posts: 102
Joined: 7-September 04
From: UK
Member No.: 4,489



QUOTE(tekniklr)
I have the following line in my /etc/conf.d/net file:
CODE 
iface_usb0="192.168.129.1 pointopoint 192.168.129.201 netmask 255.255.255.0"


I doubt this would be the cause of all your problems, and I don't even know if this is right, but....

Should pointopoint actually read pointtopoint?

(I'm only pointing this out as it jumped off the page at me for some reason) smile.gif
Go to the top of the page
 
+Quote Post
cvmiller
post Oct 5 2004, 07:58 AM
Post #7





Group: Members
Posts: 242
Joined: 31-March 04
Member No.: 2,592



QUOTE
# route add default gw 192.168.129.1
SIOCADDRT: Network is unreachable
(same results whether I'm trying to use 192.168.129.1 or 192.168.129.200 on my computer).


This doesn't look like a good sign. If route refuses to add the route, that usually means that the interface really isn't up (or it doesn't have the correct subnet).

Perhaps you could tell us what "ifconfig -a" reports on the Zaurus.

Have you considered using something other than the USB for connectivity? I use WLAN at home between my Linux desktop, and the Zaurus and it works great!

I hope this helps,

Craig...
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd July 2014 - 01:40 AM