OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

14 Pages V  < 1 2 3 4 > »   
Reply to this topicStart new topic
> fast 6000 kernel, along with special libsdl
tumnus
post Oct 21 2004, 11:26 PM
Post #16





Group: Members
Posts: 1,176
Joined: 3-October 03
From: UK
Member No.: 547



Just thought I'd point out that the pre-emptive kernel patch hardly improves responsiveness and at the same time can break kernel module compatibility in weird ways (The modules still load but they do not work properly, which sounds like what is going on here).
Go to the top of the page
 
+Quote Post
gab74
post Oct 21 2004, 11:50 PM
Post #17





Group: Members
Posts: 344
Joined: 24-May 04
Member No.: 3,411



Do you have substitute the modules files too ???
I've no problem to update the kernel....follwing the howto from http://externe.net/zaurus/modules.php?op=m...order=0&thold=0

my problem i s during boot as i said at the top of this topic....
problem not yet solved.....
Go to the top of the page
 
+Quote Post
amdonati
post Dec 2 2004, 06:17 AM
Post #18





Group: Members
Posts: 155
Joined: 14-January 04
Member No.: 1,434



Hi Guylhem,

I tried your Kernel, but as others, I could not see my SD card (altough the MMCSD module correctly loaded) and therefore I had to come back to the standard kernel.

Have you been able to solve this issue, as well as some others (like to usbhost driver not working)?
I would really like to have the faster kernel.

Could you also check your libSDL?
I am using it as it is the best one, in my opinion for the Tosa, but having it packed in an ipk and with some of the issues discussed Here (Exult, keys mapped incorrectly for some games while rotated...) solved would be really great!

Thanks for the support,

Cheers,
Adalberto
Go to the top of the page
 
+Quote Post
smuelas
post Dec 2 2004, 07:08 AM
Post #19





Group: Members
Posts: 110
Joined: 15-October 04
Member No.: 5,026



Thanks a lot for the version of the kernel with no FPS. Now it runs wonderfuly in my 6000 with Xqt-Debian.
Smuelas
Go to the top of the page
 
+Quote Post
amdonati
post Dec 2 2004, 07:59 AM
Post #20





Group: Members
Posts: 155
Joined: 14-January 04
Member No.: 1,434



QUOTE
Thanks a lot for the version of the kernel with no FPS. Now it runs wonderfuly in my 6000 with Xqt-Debian.
Smuelas


Is the kernel without FPS monting SD cards correctly?

Adalberto
Go to the top of the page
 
+Quote Post
guylhem
post Dec 5 2004, 08:03 AM
Post #21





Group: Members
Posts: 577
Joined: 17-March 04
Member No.: 2,365



Hello

All that's strange. I use this kernel on a daily basis, and I do use my SD card without any problem. For reversed keyboard, just use the exports with SDL. The only real "bug" I have is with wifi, where I sometimes have to do insmod. [why?]

usbd stuff works.

Did you try to insmod the sharpmmc module by hand? Did you have any error ? Could you try the non FPS kernel and report me how it works? (pm or email - I don't check the forum very often)

Regarding the loosing focus problem, I could reproduce that bug. I have no idea where it comes from :-) I did tweak everything too much, will try to fix that soon.
Go to the top of the page
 
+Quote Post
guylhem
post Dec 5 2004, 08:06 AM
Post #22





Group: Members
Posts: 577
Joined: 17-March 04
Member No.: 2,365



hubcapboy, any news? that's very very strange. It works like a charm for some people and it seems to have problem with others.

Maybe the 530 Mhz overclock is at fault? I will try to release a new version without overclocking at boot time (yet with overclock support)
Go to the top of the page
 
+Quote Post
amdonati
post Dec 5 2004, 03:35 PM
Post #23





Group: Members
Posts: 155
Joined: 14-January 04
Member No.: 1,434



I'll give another try to the kernel ASAP.I'll let you know what's happening to me! tongue.gif

Cheers,
Adalberto
Go to the top of the page
 
+Quote Post
hubcapboy
post Dec 5 2004, 04:42 PM
Post #24





Group: Members
Posts: 61
Joined: 14-October 04
Member No.: 5,019



yea I restored and was back in action pretty quick, but there was definitely no magic involved in booting the new kernel. just plain didn't kick over.

haven't tried it since, I was playing around with oz x.2, hopefully in time that will turn from a port to the 6k to a package FOR the 6k. It's fun to play around with but not superior to sharp based on usability yet.
Go to the top of the page
 
+Quote Post
amdonati
post Dec 8 2004, 01:30 AM
Post #25





Group: Members
Posts: 155
Joined: 14-January 04
Member No.: 1,434



Guylhem,
I trieds to install both of your kernels, and I have the same problems with both.
When the kernel starts, I have a "Cramfs wrong magic", than I have a lot "inode #.. was a directory with children, remving those too".
The sharp_mmcsd is loaded, but then I receive a lot of "pxa_sd_stopclock: clock stop time out"
Than I have a lot of "VFS: Disk changedetected on device mmcd (60,1)"

At the end the system starts and seem to work corrcetly, apart that I cannto see the SD.
I tried with 2 cards (both ext2), with the same result.

I can forward my dmesg, if this could be useful, just remember me how to output it to a file unsure.gif

Thanks,
cheers,
Adalberto
Go to the top of the page
 
+Quote Post
Zar2Cool
post Dec 10 2004, 02:41 AM
Post #26





Group: Members
Posts: 11
Joined: 29-September 04
Member No.: 4,804



I am having the same issues as amdonati.
It does not look like the ext2 filesystem is compiled into the kernel.
Least it's not listed in /proc/filesystems

Also, my socket CF ethernet card does not work.

Seems fast tho.
Go to the top of the page
 
+Quote Post
guylhem
post Dec 11 2004, 11:25 AM
Post #27





Group: Members
Posts: 577
Joined: 17-March 04
Member No.: 2,365



amdonati, Zar2Cool : the error messages you see are normally hidded. This is not a bug. Regarding the CF - I think you found the bug: I did not compile ext2 in. I will try to compile a module for you. Same for socket ethernet and other peripherals I don't have :-)

Will post an update on externe.net soon
Go to the top of the page
 
+Quote Post
ambience713
post Dec 11 2004, 01:14 PM
Post #28





Group: Members
Posts: 6
Joined: 20-October 04
Member No.: 5,119



guylhelm, thanks for the kernel. I have been using the kernel with no ill effect (except on crash when overclocked to 520). I really enjoy the automatic SAMBA share on the Windows. biggrin.gif

But is there a way to get the SDL and SNES9X to work properly? I am only getting 1/8th of screen, "-FS" doesn't work. Thanks.
Go to the top of the page
 
+Quote Post
Zar2Cool
post Dec 11 2004, 02:27 PM
Post #29





Group: Members
Posts: 11
Joined: 29-September 04
Member No.: 4,804



I grabbed the source and recompiled the kernel with ext2 support. My SD card now works fine.
How do I tell the overclocking is working. The vids seem to play faster, but it's hard to tell.

Can't get the socket CF to work. How do you compile modules for this thing?
Go to the top of the page
 
+Quote Post
amdonati
post Dec 12 2004, 06:45 AM
Post #30





Group: Members
Posts: 155
Joined: 14-January 04
Member No.: 1,434



Than this was my problem too! :-)

I am eagerly waiting for the new kernel with ext2 biult in.

Unfortunately here I cannot compile it :-(

I have also a socket CF and Socket BT (rev.f), will the modules be included?

Zar2Cool: to check the actual speed of your Z, try QclockChange

Adalberto
Go to the top of the page
 
+Quote Post

14 Pages V  < 1 2 3 4 > » 
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd December 2014 - 10:26 AM