OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
AntiPasta doesn't have a personal statement currently.
Personal Info
AntiPasta
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 13-June 06
Profile Views: 469*
Last Seen: 24th June 2006 - 01:18 AM
Local Time: Jul 11 2014, 04:49 PM
4 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

AntiPasta

Members


Topics
Posts
Comments
Friends
My Content
14 Jun 2006
Well, it seems like I'm amongst the legions of people having problems with their SD card on their 5x00... I read the other topics but my problem is a bit different than the others, I think.

When I got my Z (B500, OZ3.5.4, OPIE 1.2.1), I tried using my cheapo MMC with it - which didn't work. The automount window never popped up, and dmesg reported loads of timeout errors (I can specify those if you're interested).

So I did some research, found out a lot of people use Kingston SD's in their Z, went out and bought a Kingston 512mb. I tried it in the store, OPIE popped up the automount window (allowing one to choose which files to scan for etc.), tried a 'mount' in the console and the card was mounted. So I figured it worked.

Took it home, decided to reformat it to ext2 (did a mke2fs /dev/mmcda1), but the card never functioned properly. It would mount, but upon doing a 'touch /media/card/testfile' I would get "Input/Output Error". Tried numerous other things, such as reformatting in my PC, didn't get satisfactory results.
Once I did manage to format it in my PC, create a textfile on it (using the PC), and reading that on the Zaurus - however, when I placed another file on it using the PC the Z wouldn't read the card.
Fdisk sometimes works perfectly, sometimes I get 'Couldn't read /dev/mmcda' errors.

So I tried the instructions here. Once again the 'new storage media detected' window pops up, but still I can't use the card properly.

So just now I fired up fdisk, removed all partitions, removed & reinserted the card (without umounting, I realize now), restarted fdisk and suddenly it shows 4 partitions not ending on cylinder boundaries and having different logical & physical locations??

Meanwhile, dmesg reports occasional stuff like "sd_write_single(237032) : select error" and "pxa_sd_wait_response: responce time out (cmd=07 MMC_STAT=0x2142)"

Anyone have a clue? I already took contact spray to the SD slot, to no avail, edited fstab like someone suggested, and all the above.
13 Jun 2006
Good day, folks,

my first post on the board! If there's any place where I am supposed to make a more formal introduction, please be so kind to let me know.

Anyhow. After drooling over Zaurii for months I came across a cheap used SL-B500 which I promptly bought. The previous owner imported it and installed OpenZaurus 3.5.4 with Opie 1.2.1.
Apart from a host of SD/MMC related troubles (which I shall bore you with some other time), the date keeps resetting to March 14th! (which also appears to be the kernel build date). Does this sound familiar to anybody?
Thanks in advance,

Anton
Last Visitors
AntiPasta has no visitors to display.

Comments
Other users have left no comments for AntiPasta.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 11th July 2014 - 06:49 AM