OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
ophb1 doesn't have a personal statement currently.
Personal Info
ophb1
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 24-January 04
Profile Views: 141*
Last Seen: 10th February 2004 - 07:34 PM
Local Time: Sep 21 2014, 12:04 AM
9 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

ophb1

Members


Topics
Posts
Comments
Friends
My Content
21 Feb 2004
Esteemed Zaurites,

Once again I appeal to your collective wisdom
to point out my stupidity. This is posted in the
software section but I'm not really sure how to
classify it.

The problem happens when trying to play the following
audio stream on an SL-C860 using mplayer (kino2
version):

http://hotspotshawaii.com/awed/irh20k.asx

The audio is intermittent and one of the "percents"
on the mplayer status line is huge (believe it's
the audio codec cpu usage in percent). I'm fairly
confident that the stream is O.K..

For example, mplayer on my main linux box plays
this stream fine. And I even used mplayer's
"dumpstream" option on the zaurus and then played
that file on my main linux box. It worked again.
But playing this file on the zaurus behaves the same
as when playing it live.

To be fair, I tried another mplayer version on the
zaurus (mplayer-w100_1.0rc2.1-1_arm.ipk) and the
same thing occurs. So if anyone is inclined,
please try this stream and tell me what happens.

That and any comments would be appreciated. For
those who have made it this far, an mplayer log is
attached from playing "stream.dump" on the zaurus.
The "selected audio codec" part looks the same as
when playing the stream on the main linux box. And
note the several hundred % figure on the status
line near the end of the log. It's quite puzzling
at least to me.

Thanks for your attention.

====================================================

$ /usr/local/bin/mplayer stream.dump
MPlayer 0.91-3.3.1 © 2000-2003 MPlayer Team
Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/zaurus/.mplayer/config
Reading /home/zaurus/.mplayer/codecs.conf: can't open '/home/zaurus/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: 49 audio & 136 video codecs
font: can't open file: /home/zaurus/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Failed to open /dev/rtc: Device or resource busy (mplayer should be setuid root or /dev/rtc should be readable by the user.)
Using usleep() timing
Can't open input config file /home/zaurus/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config

Playing stream.dump
ASF file format detected.
============ ASF Stream group == START ===
object size = 32
stream count=[0x1][1]
stream id=[0x1][1]
max bitrate=[0x4f8c][20364]
============ ASF Stream group == END ===
Clip info:
name: IRH-Live 20k
author: Internet Radio Hawai`i
copyright: 2001
comments:
==========================================================================
Requested audio codec family [wmadmo] (afm=dmo) not available (enable it at compilation)
Requested audio codec family [divx] (afm=acm) not available (enable it at compilation)
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 22050 Hz, 2 ch, 16 bit (0x10), ratio: 2501->88200 (20.0 kbit)
Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (ffmpeg))
==========================================================================
Checking audio filter chain for 22050Hz/2ch/16bit -> 22050Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 22050 hz, little endian signed int
AF_pre: 22050Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 22050Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 22050Hz/2ch/16bit -> 22050Hz/2ch/16bit...
Video: no video
Starting playback...
A: 1.8 771.9% 0%
Exiting... (Quit)
27 Jan 2004
Hi,

With much thanks to ZUG resources, I've set up an ethernet over usb network between
zaurus (sl-c860) and linux laptop, with the latter using dialup-ppp for internet connection.

I plan to keep the laptop's dialup net connection for now but eventually would like to replace
the usb tether with wireless. So I hope to find out whether an 802.11b ad-hoc (peer to peer)
network would be one solution. Would such a wireless peer to peer network allow the zaurus
to access the internet using the laptop's dialup connection (as may be done using the
ethernet over usb)?

Any thoughts on this isuue would be appreciated. Thanks.
24 Jan 2004
Hi,

My simple network consists of the zaurus sl-c860 and a linux laptop, connected by ethernet over usb. The laptop is running RH8 (2.4.18) and is connected to the net by dialup-ppp.So far the network seems to be setup correctly.I can ping and ssh from the laptop to the zaurus and vice versa. I can even ping and ssh from the zaurus to the outside world.

The problem is when I fire up the zaurus netfront browser, it doesn't connect to the net. There's a connection prompt (No connection to the network. Connect now?) to which I reply "yes". Then a connection setup error dialog appears (Cannot found the device card for communication).

So it's as if the browser isn't aware of the ethernet over usb. I've gotten this far by rummaging through the various user groups. Any recommendations would be appreciated.

Thanks.
Last Visitors
ophb1 has no visitors to display.

Comments
Other users have left no comments for ophb1.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 21st September 2014 - 12:04 AM