OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
seachicken doesn't have a personal statement currently.
Personal Info
seachicken
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 13-October 04
Profile Views: 58*
Last Seen: 6th May 2006 - 09:26 PM
Local Time: Aug 27 2014, 05:08 PM
17 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

seachicken

Members


Topics
Posts
Comments
Friends
My Content
31 Oct 2004
Kphone-4.04 now working for PC-Phone calls smile.gif
I've successfully called a real phone in the UK from my Zaurus in Japan.

I've only used it with the sipphone.com service, here are my tips to get it working.
    [1] There seems to be a problem with the sipphone.com service (not kphone), I contacted their technical support and they gave me a workaround. Now by dialing 099 + country + area + number I am able to successfully make voice calls to real telephones. You should just be able to dial 00+country+area+number but this doesn't work.

    [2] I have found that the stereo headphones I have make a perfectly acceptable mic and earpiece. Just use the right ear as the earpiece and the left ear as the mic. The mic quality is not very good, but usable for phone calls. I have also used a Japanese mobile phone "hands-free" set. In this case you also need a 2.5mm->3.5mm jackplug adapter. The audio quality from this mic much louder and clearer than using headphones for a mic. A final idea for an audio setup is to get an adapter used to connect 2 mono mics into a stereo jack, you can plug a mic into one input and an earpiece into the other. I haven't tried this myself, but I think it should work.

    [3] kphone 4.04 works better than kphone-pi -0.97. Both are able to make calls, but kphone-pi cannot hang up. The application just stops responding to user input once the connection has been made. To terminate the call with kphone-pi you must kill the kppi process, and get the other party to hang up their end. Kphone 4.04 works correctly, just click the Hangup button to disconnect the call.

    [4] Both kphone and kphone-pi have problems registering with the sipphone.com service. You need to be registered with the service (the client normally registers you with sipphone.com when it starts up) before you can successfully make a call. The only way I have found to get registered is to start a second client when the first client is still running. For some reason the second client pops up a dialog box asking you for your password and then successfully registers, the first client doesn't do this and eventually times out trying to register. This is a bit messy, hopefully someone can figure out an elegant solution.
Finally, what to expect...
The calls are pretty cheap, and the audio quality is very good, however there is often a delay on the line of about one second and this is quite difficult to get used to (perhaps this delay will not be so bad when calling from the US). Also, the sipphone.com service offers 5 minutes of calls free each day to various countries, very nice, but I have yet to be able to make a free call with them with any client (including their own in WindowsXP).. this may of course change at any time, or be peculiar to my setup, since things in the world of SIP phoning seem pretty volatile.
20 Oct 2004
Have successfully built kphone for RC5.
It runs and worked successfully with the echo server 612@fwd.pulver.com

BUT I was testing it sending the window to another X-server.
When I try to display on the Zaurus X-server, kphone crashes: "Broken pipe".

Any ideas why this might be (the application linked to the X and QT libs)?

Andy
14 Oct 2004
I'm making an ipk for the locate command. This is taken from another Zaurus release and is not a port of the linux locate, but a script that produces its own smaller database file.

It comes with a readme file that explains its usage and it would be a shame to exclude it from the ipk, but I have no idea where to put it. Is there a standard place on the pdaxrom distribution?
14 Oct 2004
I installed an ipk (from the command line with ipkg install) to /mnt/card and it doesn't appear when I do an ipkg status, which looks like it just prints out /usr/lib/ipkg/status

However, qpkg shows the package I installed in its "Installed" tab.

Can anyone shed some light on what's going on.
In particular how do I get the details of installed packages?
13 Oct 2004
I've built my first ipk, actually 2. less and tcsh and they both seem to work on RC5.

Ok, it's not much, but it's a start and I would like to contribute the ipks, assuming they're useful... but I've no idea how to do this.

GREAT job on the OS by the way, and also the tutorials on how to build using the SDK.
Didn't have any problems at all building on Mandrake 10.
Last Visitors
seachicken has no visitors to display.

Comments
Other users have left no comments for seachicken.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 27th August 2014 - 09:08 AM