OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
Stilgar doesn't have a personal statement currently.
Personal Info
Stilgar
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 22-October 04
Profile Views: 305*
Last Seen: 10th February 2008 - 02:18 PM
Local Time: Jul 31 2014, 07:38 PM
43 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

Stilgar

Members


Topics
Posts
Comments
Friends
My Content
19 Aug 2006
I've encoded a movie to a 320x240 , mp3 encoding. I've tried playing it with mplayer on a C3000 machine. However, it uses libsdl which is not functioning too well on this machine.
The -vo fbdev option makes mplayer play this movie in a smaller scale. I found a thread (http://www.oesf.org/forums/index.php?showtopic=20473) explaining how to fix it up for fbdev playing on a C860. However, the problem is that I cannot control mplayer - no stopping, skipping forward or backward. Makes it not really usable even if I manage to view it correctly full screen.

The error spit out from SDL (inside mplayer) is something in the lines of:
Can't detect machine defaulting to SL5000D detected machine is 'Sharp SL-5000D'

Any suggestions? How to make SDL work correctly with this? Or on a different direction - how to encode movies for playing with the built in opie player?
17 Jul 2006
I was playing around with the new (and cool) OZ 3.5.4.1 . I have a spitz machine (C3000) and when trying SDL, every SDL program I used would not work well - I'd get it duplicated 3 times over the screen, interleaved with the background.
Apperently SDL patches are quite shaky, but I was wondering if I'm the only one expiriencing this - maybe a reflash would fix some things.
That's what Mickey told about the SDL patches:
QUOTE
I'm afraid the SDL patch for Qt/Embedded based environment needs _much_
work. It is a pretty ugly mess that grew historically. Starting with the
japanese guys forking SDL 1.2.5 years ago and not contributing their
changes back to mainline. What's worse, they added SharpROM specific
code that was hardly usable for anything other than a Zaurus.

The SDL patches would need a complete overhaul and recreating from
scratch trying to get it into mainline. It's just a question of who's
motivated enough to do that.
17 Jul 2006
I am attracted by Socket's small form-factor when it comes to CF cards - There would be no reason to take out the bluetooth card every time I fold my zaurus. The question is - how do I get my hands on such a card cheaply? Each retail site is as high as 90$ (without shipment) and I can't find them on eBay (there's only one for sale going on now). Is anyone familiar with a cheap store for such?

Thanks!
6 May 2006
I'm trying to debug a problem with my zaurus (you can read about it's unique situation in http://www.oesf.org/forums/index.php?showtopic=19234 ).
For that, I need an image of /dev/mtdblock0 (preferably also of /dev/mtdblock1) which you can get using the dd command.
If someone can please get both of those images and send them to me, I will be very gratefull.
5 May 2006
I do apologize for the long post. I have tried many things (detailed here) before asking help from this forum. At the moment (after 2 days of fiddling), there are many threads to the story. I will, however, try to make it short.

The zaurus wouldn't boot (with misc. kernel patnics) a few days ago. Figuring out I couldn't debug it, I tried getting into rescue mode with the updater.sh.rescue (an old-time friend).
That's where I had a surprise waiting. The CF card would not be recognized by the updater menu (Holding OK while powering on, then 4->1->Y). It would yell something about missing CF card and then rebooting.

Right. There's the D+B rescue boot console. Boots pretty well, except for one (not surprising by now) thing: the /sbin/cardmgr would output an error message (something like encountering an unexpected word or ")".).
Then, I could not access /dev/hdc, even for backup purpose. I'd get the error that block-major-3 is missing (as well as block-major-22 on /dev/hda). Great.

Obviously, something was wrong with the rescue boot rootfs. I could not flash a new kernel/distro, as the CF card would not be recognized by the updater (Which uses the emergency rootfs to boot when upgrading).
Using an SD card was an obvious solution along the way. However, when I use it, the updater is yelling misc messages about /var/lib/pcmcia/stab missing (which may be correct, since it's using the rescue rootfs, which is somewhat broken).

Booting again into the rescue rootfs and diagnosing things a bit, I found out that /sbin/cardmgr is broken! it's md5sum with an old version of cardmgr was different. Moreover, mounting /dev/mtdblock2 and copying cardmgr from there to /sbin/cardmgr on the rescue rootfs and then restarting pcmcia, works.
However, /dev/root on the rescue partition is /dev/ram0 -> the kernel is extracted dynamically from the rom (mtdblock1 maybe?) to the ram.

Right now, my ROM (cacko 1.23b) wouldn't boot, due to misc kernel panics, and I am unable to upgrade to any other distro (or even sharp's original rom) because the rootfs is fucked up.
What I'd like to know, is that:
1. Wouldn't a NAND restore will rewrite /dev/mtdblock1 ?
2. Is the rootfs actually taken from mtdblock1?
3. Fortunately, I have a backup of mtdblock1 I manually made after some previous restore. I would like to copy it (via dd) to /dev/mtdblock1 on my Z. However, I am unable to mount it (via loopback interface) to check what's inside and see if there I have a correct version of cardmgr. Does anyone know about the image structure of /dev/mtdblock1?

I will appreciate any help.
Last Visitors
Stilgar has no visitors to display.

Comments
Other users have left no comments for Stilgar.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 31st July 2014 - 11:38 AM