OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
xiangzi doesn't have a personal statement currently.
Personal Info
xiangzi
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 16-July 05
Profile Views: 42*
Last Seen: 25th October 2005 - 08:51 PM
Local Time: Dec 27 2014, 10:14 AM
4 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

xiangzi

Members


Topics
Posts
Comments
Friends
My Content
5 Aug 2005
Hi,

Anyone have any suggestions for where to get a headset w/ microphone
for the C3000 / C3100? Sounds like earlier Zauri had a 2.5mm jack,
but now they are 3.5mm. I have seen lots and lots of single-jack 2.5mm
headsets for cell phones. Also have found lots of dual-jack 3.5mm headsets
for computers etc. But has anyone come across a single-jack 3.5mm one??
16 Jul 2005
So I've got this Tamarack TC3299CE compact flash ethernet card for my new C3100 (still with Sharp ROM). It claims to be supported by a Linux driver. I noticed it is also even specifically supported by OpenBSD for Zaurus in their NE2000 driver: OpenBSD/zaurus.

I think the card itself is ok; when I plug it into a Powerbook using the pcmcia adaptor, it lights up the "ACT" and "LINK" lights. However when I put it in the Zaurus I just get a momentary flash of the "ACT" light and then nothing. (No card slot on my Linux PC so can't test that one.)

Zaurus system info reports:
3.3V 16-bit PC Card [suspended]
product info: "CF", "10Base-Ethernet", "1.0", ""
function: 6 (network)

There are some NE2000 entries in /etc/pcmcia/config, and the product info is almost exactly the same as the Billionton CF entry (but the fourth "" field is missing, so just to be sure I added a separate entry like this:)

card "Tamarack TC3299CE"
version "CF", "10 Base-Ethernet", "1.0", ""
bind "pcnet_cs"

Below are the system log messages when I plug the card in. So it looks like the show stopper may be that it wants a net/8390.o module which isn't on the Zaurus. sad.gif Anyone know if there's a compiled one available somewhere which I could just drop in? Or point me at some instructions for cross-compiling kernel modules for the Zaurus?

Thanks a lot for any help!!


Jul 16 13:05:58 localhost kernel: eth0: NE2000 Compatible: io 0xf6000300, irq 13
5, hw_addr 00:10:60:F1:F2:9C
Jul 16 13:05:58 localhost kernel: pxa_pcmcia_suspend(0)
Jul 16 13:05:58 localhost kernel: pxa_pcmcia_suspend(0)
Jul 16 20:06:00 localhost atd[193]: okay. Alarm rang.
Jul 16 20:06:00 localhost atd[193]: next: -1
Jul 16 20:06:00 localhost atd[193]: waitfor 0
Jul 16 20:06:00 localhost atd[193]: Current RTC date/time is 16-7-2005, 20:06:00
.
Jul 16 20:06:00 localhost atd[193]: Alarm date/time is 1-1-1970, 00:00:00.
Jul 16 20:06:00 localhost atd[193]: Waiting for alarm...
Jul 16 13:06:02 localhost kernel: pxa_pcmcia_init(0)
Jul 16 20:06:02 localhost cardmgr[79]: shutting down socket 0
Jul 16 20:06:02 localhost cardmgr[79]: executing: './network stop eth0'
Jul 16 20:06:03 localhost cardmgr[79]: executing: 'modprobe -r 8390'
Jul 16 20:06:03 localhost /etc/hotplug/net.agent: NET unregister event not suppo
rted
Jul 16 20:06:09 localhost cardmgr[79]: initializing socket 0
Jul 16 20:06:09 localhost cardmgr[79]: socket 0: Tamarack TC3299CE
Jul 16 20:06:09 localhost cardmgr[79]: executing: 'modprobe 8390'
Jul 16 20:06:09 localhost cardmgr[79]: + modprobe: Can't locate module 8390
Jul 16 20:06:09 localhost cardmgr[79]: modprobe exited with status 255
Jul 16 20:06:09 localhost cardmgr[79]: module /lib/modules/2.4.20/net/8390.o not
available
Jul 16 20:06:09 localhost cardmgr[79]: executing: './network start eth0'
Jul 16 13:06:09 localhost kernel: eth0: NE2000 Compatible: io 0xf6000300, irq 13
5, hw_addr 00:10:60:F1:F2:9C
Jul 16 20:06:09 localhost /etc/hotplug/net.agent: how do I bring interfaces up o
n this distro?
Jul 16 20:06:09 localhost /etc/hotplug/net.agent: register event not handled
Jul 16 13:06:09 localhost kernel: pxa_pcmcia_suspend(0)
Jul 16 20:06:10 localhost cardmgr[79]: executing: './network suspend eth0'
Last Visitors
xiangzi has no visitors to display.

Comments
Other users have left no comments for xiangzi.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 27th December 2014 - 09:14 AM