OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
Heather doesn't have a personal statement currently.
Personal Info
Heather
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 14-December 05
Profile Views: 446*
Last Seen: 3rd March 2008 - 05:47 AM
Local Time: Aug 21 2014, 01:21 AM
21 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

Heather

Members


Topics
Posts
Comments
Friends
My Content
28 Sep 2007
I bought a leftie frogpad from ThinkGeek because it said that it's USB plug-and-play. I made the assumption that this meant that all of the keys would present to the O/S exactly the same as they do with my USB keyboard.

They didn't, but I'm not sure if it's a driver or recognition issue, or automounter isn't working, or what the exact problem is. I hate to admit that I'm not very knowledgable with the inner workings of the USB host, automounter, and keyhelper.

Here's what I do know:
When I started using a standard USB keyboard, I initially had problems with keys working but mapping to really really crazy key combos. For example, one letter would suspend the Z (I don't remember which). I used poor problem-solving methods to fix it: I started installing a bunch of stuff and stopped when the problem went away, so I'm not sure what app fixed that problem.

The standard keyboard still works but FrogPad's keys map crazy. I am not sure if it's the same crazy. The "f" key suspends and the "g" key acts like the cancel key.

I tried using usbkey enable, but it doesn't fix the mapping issue.

After some painstaking work to pull out FrogPad's key input to match what is written on each key, I was able to develop a keyhelper.xml which gives me most of the alphabet. I still can't type F or G because they will either suspend (and possibly freeze the Z) or cancel. The shift key works ... kind of ... I can type a capital letter but because the shift key naturally inputs "2" instead of "shift", typing shift+t gives me "2T" if I get the T in there quickly or a whole string of 2s ("222222222T") if I don't. I'm thinking I probably have to map the 2 to shift instead of just defining it as a modifier.

Attached is my keyhelper file up to this point.

It seems like with time and practice and more understanding of keyhelper that I might be able to eventually get a mapping that will properly map the entire frogpad. I would assume that this would be helpful to people since I wasn't able to find much information about it in connection with a Zaurus before I bought it. Maybe others have thought about using one and would like to know that it works with their Zaurus.

Or maybe there's a much much much simpler fix that doesn't involve severely altering my keyboard mapping?
1 Aug 2007
Hello. I have had my C3200 for about a week now. Before that, I had an SL-5500. So far my impression is "why did I wait so long to upgrade?" I thought the SL-5500 was like a mini computer, the C3200 is so much more so.

Sorry in advance for long post. The bold headings are the parts that are most important. There are a few things I was hoping to get working on my C3200 that I haven't been able to yet. I have done many searches and just haven't got these fixed yet, so I was hoping maybe someone knew the answers or could better point me in the right direction. I'm still using the stock ROM. I've installed stuff, but haven't flashed anything yet.

First of all...thanks a ton to Meanie. I'm sure everyone says that. I would still be reading Japanese on my Zaurus if it weren't for those extensive customization pages. And also thanks to Cresho because he was very helpful back in my SL-5500 days and I know he does a lot of helping around here.

What works:
USB-Keyboard - usbkbd-en_2.4.20_arm.ipk (I need to reconfigure the xml mapping, though, because some keys weren't mapped properly)
USB-Mouse - inputhelper_1.0.1-1_arm.ipk
Zemufeex - zemufe_0.1.1-3ex_arm.ipk (so far, I tested SNES9X and ZNESTER, I also installed snes9x-sdljoy to work with my joypad, the buttons work but the directional controls do not, see below)
opie-embeddedkonsole (qkonsole crashes when the mouse is plugged in, so I used the terminal app from my SL-5500 in non-mag mode)
qpose - space trader is finally available on my Zaurus, yay
2GB Sandisk SD card - worked perfectly without any coaxing (didn't work on SL-5500)

What does not work:
USB HDD I bought a 120GB USB HDD, it is formatted as NTFS. I installed automounter_c3000_0.5.0_arm.ipk and ntfs-zaurus_2.4.20_arm.ipk ... I can get fdisk to show me that the drive exists and that it is NTFS, but it doesn't mount, and if I try to mount it manually (mount /dev/sda1 /mnt/usbstorage) then it tells me that it's an invalid argument.

WiFi I have a sandisk plus CF wifi 128MB card that doesn't work. I tried installing sandisk-plus_arm.ipk and it still wouldn't work. So I bought a Socket wifi card from eBay. If I can get that one to work, then I won't care that the sandisk one does not.

Joypad I also have a nice cheap retractable USB joypad which is a very nice small size. The Zaurus recognizes it and all of its buttons except turbo and clear (I don't care). I have verified this with jstest.

snes9x-sdljoy works nicely except for the directional controls. I can pause, unpause, open the menu, cancel, and okay just fine (all 6 snes controller buttons work), but cannot move at all.

I tried to use joy2key-z -config kbd1 and joy2key-z -config snes9x, and even tried to figure out how to use joy2key-z without arguments to configure itself to my joypad. When I did that, axis 0, 1, 2, 5, and 6 all did not respond, but axis 3 (up/down) and axis 4 (left/right) did respond. But even so, the buttons should have worked and I can't get any other apps to respond to any button pressing while joy2key is active. There's not a lot of documentation available, but I found one site in Japanese that seems to suggest that I need to install tetsu's special kernel.

Tetsu's kernel So on that note, I searched for tetsu's special kernel. I found the page at http://tetsu.homelinux.org/zaurus/kernel and downloaded zImage-v18h-3200.bin then followed a link above it to get updater.sh.3200. Because these pages are in translated Japanese ... I just want to make sure that these are the files I need before I do this. Meanie's page gives instructions, but he mentions an ipk to install after the kernel update. I can't find an ipk, so I'm assuming updater.sh needs to be run after the zImage is installed?

X/QT and Java The next step is getting X/QT and Blackdown Java 1.3 working. I did install Jeode and it works, except the text editor I wrote for my SL-5500 appears to need to be run in magnified mode. I haven't played around with Jeode's AWT on the C3200 yet, but I suspect it's going to be difficult to get the toolkit windows working correctly in landscape mode. I tried to install Blackdown, but got a lot of errors, ending up with one saying the device is full. I have 30MB left in the program area, so I was a bit surprised. Maybe I need to install it to the HDD instead? But non-GUI Java doesn't interest me much (Jeode would be just fine in that case), so I am going to try X/QT before I try Blackdown again. Any advice about which one? It seems like I should install X/QT Jumbo, but I wasn't sure.
Last Visitors


18 May 2010 - 4:04


12 Dec 2008 - 23:10


3 Dec 2008 - 3:12


1 Nov 2008 - 6:31


3 Oct 2008 - 17:45

Comments
Other users have left no comments for Heather.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 20th August 2014 - 10:21 PM