OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Gemian DNS issues
gemini_user_j
post May 14 2020, 06:46 AM
Post #1





Group: Members
Posts: 68
Joined: 9-August 18
Member No.: 827,849



I have a raspberry pi on my local network, and I have a domain name pointing to it for accessing it from outside my home network

If I am on my local net, the domain name does not work, and I need to ssh to the local IP address.

To unify things, I created a DNSmasq on my local router
```
address/raspberrypi.domain.tld/192.168.X.Y
```

If I now ssh into the raspberry pi, from any other device than the gemini, it will be a success, as opposed to before I added this DNSmasq. The gemini still does not work.

I tried to compare different files from gemini, to a debian 10 machine, and found that
```
cat /etc/resolv.conf
nameserver 8.8.8.8
```
on the gemini, where as the debian10 machine has the IP of my router.


Have I accidentally hardcoded googles DNS service somewhere, or did I miss a setting in connman?

will be happy if anyone from this community can help me figure out what I am doing wrong
Go to the top of the page
 
+Quote Post
mibry
post May 15 2020, 10:44 AM
Post #2





Group: Members
Posts: 51
Joined: 18-May 18
Member No.: 822,788



QUOTE(gemini_user_j @ May 14 2020, 03:46 PM) *
I have a raspberry pi on my local network, and I have a domain name pointing to it for accessing it from outside my home network

If I am on my local net, the domain name does not work, and I need to ssh to the local IP address.

To unify things, I created a DNSmasq on my local router
```
address/raspberrypi.domain.tld/192.168.X.Y
```

If I now ssh into the raspberry pi, from any other device than the gemini, it will be a success, as opposed to before I added this DNSmasq. The gemini still does not work.

I tried to compare different files from gemini, to a debian 10 machine, and found that
```
cat /etc/resolv.conf
nameserver 8.8.8.8
```
on the gemini, where as the debian10 machine has the IP of my router.


Have I accidentally hardcoded googles DNS service somewhere, or did I miss a setting in connman?

will be happy if anyone from this community can help me figure out what I am doing wrong


Did you set a static IP address for wlan0?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 3rd July 2020 - 08:43 AM