OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> RSS Reader - Newsfeed (Python,tcl,tk Based), RSS reader working nicely on pdaxrom
anonuk
post Nov 1 2004, 02:47 PM
Post #1





Group: Members
Posts: 176
Joined: 24-December 03
Member No.: 1,271



I discovered today that the NewsFeed RSS reader (written in python, tcl, tk) works nicely on pdaXrom with dillo, thought some other people might find this useful.
Get the newsfeed program from http://thor.prohosting.com/~mdoege/newsfeed/ i used the latest version (1.8).

It also needs tcl, tk, python, python-crypto and possibly some other python libs from the pdaxrom feed. Apart from that, just decompress the tar.gz file and then run ./newsfeed

If you want to open links in dillo, just type export BROWSER=dillo at the shell prompt before running newsfeed and it should work like a dream.

Its not the best program for reading RSS feeds but i havent found another one that runs easily on pdaxrom (that isnt console based). Not sure how one would ipk it, maybe someone can do that and put it on the unstable feed? Hope this helps someone anyways...
Go to the top of the page
 
+Quote Post
pgas
post Nov 1 2004, 10:54 PM
Post #2





Group: Members
Posts: 1,097
Joined: 17-December 03
From: Athens, Greece
Member No.: 1,210



Some other options might be thunderbird 0.8 which handles rss feeds as mailboxes,
there are also some plugins for firefox-mozilla.
Go to the top of the page
 
+Quote Post
deniscallies
post Nov 2 2004, 02:50 PM
Post #3





Group: Members
Posts: 73
Joined: 28-March 04
Member No.: 2,539



I tried newsfeed but i always get an error in line 19 in newsfeed.py because there is no module named webbrowser. So which pyhon libs are required?
Go to the top of the page
 
+Quote Post
anonuk
post Nov 2 2004, 08:39 PM
Post #4





Group: Members
Posts: 176
Joined: 24-December 03
Member No.: 1,271



the only ones i installed afaik are python-crypto and also the python package (which is the base package i guess) i got the webbrowser error but i think that dissapeared when i installed the python package.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2019 - 01:55 PM