OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Newbie Questions: 3. Openembedded, problems with monotone bitbake and confi
juggler
post Dec 20 2005, 09:40 PM
Post #1





Group: Members
Posts: 11
Joined: 20-December 05
Member No.: 8,761



Hi,

I recently bought a simpad cl4 and after
some struggling with the hardware and the
old opensimpad release (see my other two threads),
I am now trying to build opensimpad using
openembedded.

This ofcourse also raised some Questions / Problems,
most of which I have not resolved yet.

Concerning Monotone:
I tried to pull the repository, after 3 days
and several interruptions due to 404s, I gave
up. This raises two Questions:

1. How long should pulling the repository
normally take (I have a 3 Mbit DSL connection)
2. If monotone breaks due to 404, does a
new call restart it from the beginning
or does it continue from the last stop?


I also tried to grab the OE.db.bz2 database
snapshot, but monotone complained about
an incompatibility (I think it concerned
the database version) and threw two hashkeys
(I think that is monotones replacement for a
version number). I also tried to migrate
the db, but this resulted in the same error.
Finally I settled with a direct snapshot
of the source and skipped monotone.

After I started the build process, I found
somewhere the warning to rename the OE.db
file to oe.db. I dont want to test this
currently, to avoid interferences with the
build process.
But these questions remain.

Would renaming OE.db to oe.db resolve the
above compatibility problem and if yes,
why?
On the other hand if this is not the
solution, how can I make use of these
database snapshots?

Concerning Bitbake:
In the local.conf file I had to alter the line
CVS_TARBALL_STASH = "http://www.oesources.org/source/current"
to
CVS_TARBALL_STASH = "http://www.oesources.org/source/"
Is this normal / correct ?

And now for the hard part, which I have just started with.
Building:

How do I specify the hardware specs of my simpad.
In local.conf I can only specify to build opensimpad.

------------------------------------------------------------

Should I alter settings in /conf/distro/opensimpad-0.9.0.conf ?

------------------------------------------------------------

Furthermore after starting bitbake, it seems that
srcs get pulled from the net, for some modules this produced
404s but didn't stop building immediately.
But now I got the message that building failed:

NOTE: package module-init-tools-3.2-pre9-r0: task do_fetch: failed
ERROR: TaskFailed event exception, aborting
NOTE: package module-init-tools-3.2-pre9: failed
ERROR: Build of task-bootstrap failed

Anyway to fix this, or should I just wait?

Last but not least I concluded from some threads here,
that the patches for mmc and bluetooth were already included
into the openembedded, thus

-------------------------------------------------------------
how do I acitvate the mmc-module, or do I have to compile it by hand.
--------------------------------------------------------------

So far for now, I fear that I will stumple upon a some more questions
during the next days, so I appreciate any help.

Sascha
Go to the top of the page
 
+Quote Post
juggler
post Dec 21 2005, 04:04 AM
Post #2





Group: Members
Posts: 11
Joined: 20-December 05
Member No.: 8,761



Hi,

just some further informations regarding monotone.
I just figured that I overlooked the original renaming advice
in the oe wiki, but renaming OE.db to oe.db did not
help anyway. The resulting error message is:

monotone --db=oe.db checkout --branch=org.openembedded.dev
monotone: misuse: database schemas do not match: wanted 1509fd75019aebef5ac3da3a5edf1312393b70e9, got bd86f9a90b5d552f0be1fa9aee847ea0f317778b. try migrating database

So whats wrong here?


Sascha

P.S. My monotone version is monotone
0.23 (base revision: e32d161b8d5cde9f0968998cc332f82f82c27006)
which I installed via Debian apt-get (it is from unstable)
Go to the top of the page
 
+Quote Post
juggler
post Dec 21 2005, 04:24 AM
Post #3





Group: Members
Posts: 11
Joined: 20-December 05
Member No.: 8,761



Hi,

I just manually installed the newest monontone deb from
verge.net/monotone and this solved the oe.db problem.

I guess the missing key means, that the missing database scheme
stems from the newest monotone version, thus for using
the oe.db snapshots, one has to install at least the version that
was used by the creator of the snapshot...

Drawback of this solution is, that the monotone deb seems to be
somewhat broken, since it requires libboost version > 1.33.0-1
but only 1.33.0c2a is currently available via apt-get (i.e. without
special entrys in sources.list).
Since it seems to work anyway, I'm going to ignore this.

Sascha
Go to the top of the page
 
+Quote Post
juggler
post Dec 21 2005, 06:37 AM
Post #4





Group: Members
Posts: 11
Joined: 20-December 05
Member No.: 8,761



Hi,

the sid monotone deb did not work correctly (probably due to wrong libs) but
the sarge deb did the trick.
So now I have a working (and succesfully updated) oe reposistory.

I think downloading the database snapshot should be the preffered way,
to set up a new repository, given that the installed monotone version
is new enough to handle the snapshot. In my case downloading and
updating the repository just took a few minutes, whereas I gave up
on my attempt to directly pull the oe repository. Still the monotone
error message in case of an outdated version is a bit hard to interpret!

I'm now trying to build again, I hope that at least the problems for
the task-bootstrap target were just temporary.

Sascha
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2017 - 04:44 AM