OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> First Projects Grabbed And Modified, Initial experience and feedbacks
post Jan 14 2005, 12:35 PM
Post #1

Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043

Dear dz,

I have worked a little with the new and great ELSIX to update my projects stored there.

Here my first persoanal experiences and comments:
* I find that the fonts are a little large so that I always have to scroll up and down. Especially the Home page should show a one-liner for each new project and not the full blown description.
* when clicking on "My Subscriptions" I got a mysql error line in the otherwise correct page
* I did not find a method to specify "any ROM", "any processor", "any Screen Resolution" which is important for the Zaurus-X-gcc cross compiler which is not hosted on a Zaurus...
* When adding a branch, I also did not find a way to specify "any supported ROM", "any supported Model". Is it really meant that I specify e.g. 4x5=20 links/versions if I have written my tool to work on all models?
* I got another message in /public/host/elsix/html/mod.php line 421
* After adding a branch release I did not come back to the project page
* I tried to use upload but got an error that there is no permission. Then, I found out that the system assumes to use anonymous FTP. This is IMHO only needed files larger than e.g. 2MByte. All others should be uploadable like the screenshot
* For the Unixname I have just choosen the same as the project name removing all spaces and making everything lowercase. And I have never seen or used it again. Isn't that something which could be done automatically?
* The library mechanism was too complex for me - so I decided not to specify anything there.

So my general impression: great work, very powerful functionality - sometimes it even appears as overkill for my needs as a developer. Some smaller glitches which can be fixed.

Once again many thanks for developing this tool! I really know how much work is behind the scenes...

Have a nice evening,
Go to the top of the page
+Quote Post
Start new topic
post Jan 14 2005, 01:00 PM
Post #2


Group: Admin
Posts: 589
Joined: 2-February 04
From: Cape Canaveral, FL
Member No.: 1,667

I'm working on a solution for the frontpage thing. I'm used to it from using Freshmeat, but I'll try and make a simply small solution for displaying all new projects.

Could you please post the error you recieve from the 'My Subscriptions' page? It's hard for me to figure out what's wrong without knowing the error :-/

As far as the 'any *' thing, I simply did not think of that. I will add that feature soon.

I think I fixed the error in mod.php, but again I don't really know the error you're receiving. If you could post that error as well please smile.gif

Branch Release redirect fixed.

The unixname is used when the system renames your file. You won't see it until you upload a file.

The library mechanism is there mainly for new users. If your project uses standard libraries, I suppose you wouldn't need it.

Release upload is being worked on. We had it all working and good, and then a couple days ago we were held back by the limitations of our hosting. Not a problem though; it'll just take me a little to fix.

I figured there'd be many bugs upon first release of the elsi. Thank you for bearing with me while I fix them smile.gif I'll try and get an updated version of the elsi soon.
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 27th May 2018 - 09:11 AM