OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> 802.11g And Wpa?, supported at all on any ROM any version?
post Mar 1 2005, 02:33 PM
Post #1

Group: Admin
Posts: 3,512
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149

has anyone gotten an 802.11g card to work, and with WPA?

snag is at work they only want to run 11g and WPA (Apple airport extreme) on their wireless lan for security; there's only a vague chance they would drop it down to 802.11b (if the Senior Sysadmin decides to get an iPaq with wlan)... but will definitely stick with WPA.

I would get murdered if I put up my own access point (and rightly so!), so I'd have to use bluetooth, which is OK for surfing but not for file transfer.

I would be happy to choose ANY rom, and I have quite a lot of experience with linux and 802.11~ from hacking together an access point with the Keith Smith OpenSTA/OpenAP stuff on a eumitcom single board computer, so am not afraid of getting my hands dirty!

thanks for any thoughts
Go to the top of the page
+Quote Post
Start new topic
post Mar 22 2005, 06:20 AM
Post #2

Group: Admin
Posts: 3,512
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149

FORKED THIS THREAD OFF TO HERE, about building a cacko WPA supplicant:


d'oh! having delved deeper, I find that cacko has got the command-line tools for wpa (wpa_supplicant, wpa_cli etc)...

see later post for details
Go to the top of the page
+Quote Post
post Apr 14 2005, 03:05 AM
Post #3

Group: Admin
Posts: 3,512
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149

cacko has got the command-line tools for wpa (wpa_supplicant, wpa_cli etc)...

you have to amend the /etc/pcmcia/wlan-ng.opts file and add WPA=y to the "qpewlan0" section which matches the ESSID you are trying to connect to.

then, save a backup copy of /etc/wpa_supplicant.conf, then edit it and trim out all the junk except the config part you want to use.

when you trigger wlan connection, it starts up wpa_supplicant with the appropriate arguments and in theory WPA is configured per the conf file and it should work!

I tried this at work with an Apple airport extreme and it doesn't work (someone running windows didn't make it work either, only people with Apple powerbooks can). I've tried starting wpa_supplicant manually (-w makes it wait till the interface appears) to get a log:
wpa_supplicant -d -dd -w -ieth0 -c /etc/wpa_supplicant.conf -D hostap > /var/log 2>&1

and whilst impressively long, the log doesn't tell me why it fails.

Go to the top of the page
+Quote Post
post Jun 8 2005, 04:57 AM
Post #4

Group: Members
Posts: 33
Joined: 7-March 05
Member No.: 6,589

Are there any updates on rom support for 802.11g cards? I saw the following page after some searching:
In which it is said that the prism54 chipsets are supported in a linux driver
( came on that page after an outdated link on http://www.fuw.edu.pl/~pliszka/hints/wireless.html )
maybe this knowledge can be merged with one of the roms smile.gif Or is this chipset in no way related to the one on the CF cards? (saw they were put on USB or "cardbus", haven't found a CF card with those chips on them but I may not have looked good enough). There is a nice wiki with docs here:
I also want to hold off purchasing a wlan card for my C1000 since I don't want to drop any access points to the slower a/b modes for other people which are connected.

edit: Hmm when looking a bit more I found the Linksys WCF54G card has Linux driver sources at
( I found this on http://www.linuxdevices.com/cgi-bin/board/...Page=0&Session= ) This adapter is CF but does not support the 802.11a 5 GHz band and only the 2.4 GHz band networks, no problem though since most access points are b/g). I hope this is useful info (haven't been able to look through those sources yet) so some of the roms may offer support for such cards smile.gif
Go to the top of the page
+Quote Post

Posts in this topic
speculatrix   802.11g And Wpa?   Mar 1 2005, 02:33 PM
stupkid   QUOTE(speculatrix @ Mar 1 2005, 04:33 PM)has ...   Mar 1 2005, 04:29 PM
speculatrix   QUOTE(stupkid @ Mar 2 2005, 12:29 AM)QUOTE(sp...   Mar 2 2005, 07:02 AM
speculatrix   on the subject of 802.11g: Am I right in thinking...   Mar 14 2005, 09:17 AM
AndyTiedye   QUOTE(speculatrix @ Mar 14 2005, 10:17 AM)on ...   Mar 16 2005, 11:06 PM
kingmob   QUOTE(AndyTiedye @ Mar 17 2005, 07:06 AM)We n...   Mar 17 2005, 04:39 AM
speculatrix   QUOTE(kingmob @ Mar 17 2005, 12:39 PM)There...   Mar 17 2005, 10:20 AM
speculatrix   QUOTE(AndyTiedye @ Mar 17 2005, 07:06 AM)I go...   Mar 22 2005, 05:53 AM
speculatrix   Problem with WEP is you have to change the keys qu...   Mar 17 2005, 10:19 AM
speculatrix   QUOTEFORKED THIS THREAD OFF TO HERE, about buildin...   Mar 22 2005, 06:20 AM
speculatrix   cacko has got the command-line tools for wpa (wpa_...   Apr 14 2005, 03:05 AM
azalin   Are there any updates on rom support for 802.11g c...   Jun 8 2005, 04:57 AM
maslovsky   QUOTE(azalin @ Jun 8 2005, 03:57 PM)edit: Hmm...   Jun 9 2005, 02:27 AM
azalin   QUOTE(maslovsky @ Jun 9 2005, 11:27 AM)QUOTE(...   Jun 9 2005, 03:20 AM
speculatrix   I decided to ask Linksys if they would provide a l...   Apr 10 2005, 10:20 PM
Da_Blitz   www.tomshardware.com had a review where they cut o...   Jun 11 2005, 11:35 PM
Da_Blitz   WE CAN DO IT!!!!!! cant s...   Jun 11 2005, 11:49 PM
speculatrix   WPA and Cacko: I managed to buy a socket/symbol 8...   Jun 14 2005, 01:16 PM
maslovsky   QUOTE(speculatrix @ Jun 15 2005, 12:16 AM)WPA...   Jun 15 2005, 12:03 PM
speculatrix   QUOTEWPA works under Cacko, but only with HostAP d...   Jun 16 2005, 07:06 AM
speculatrix   interesting site: http://www.open1x.org/   Jun 16 2005, 08:37 AM
Da_Blitz   any one know anything about wpa and the c3000, i w...   Jun 16 2005, 10:01 PM
mscdex   Anyone get any farther on zaurus drivers for the l...   Aug 9 2005, 09:14 PM
enochbenjamin   QUOTE(mscdex @ Aug 9 2005, 11:14 PM)Anyone ge...   Aug 15 2005, 08:07 PM
speculatrix   QUOTE(enochbenjamin @ Aug 16 2005, 05:07 AM)I...   Aug 17 2005, 01:51 PM
rob_figlabs   I spent the weekend trying to build the Agere Syst...   Oct 10 2005, 02:53 AM
cmpayc13   Hi All, no way to get Linksys WCF54G working in Z...   Jan 3 2006, 03:03 AM
Yoru   Hi! No news about WCF54G working in Zaurus??   Jan 18 2006, 04:06 AM
agosine   Has anyone managed to get WPA-PSK with AES (CCMP) ...   Jan 31 2006, 08:51 AM
wsk   Hello, I've already asked about this before, ...   Jun 23 2006, 01:40 PM
Vertigok   QUOTE(wsk @ Jun 24 2006, 08:40 AM)It specific...   Jun 26 2006, 02:35 AM
Hrw   agosine: OZ 3.5.4 and newer support WPA - I use WP...   Jun 24 2006, 12:59 PM
suchs   hrw-- are you using a wifi g card with your zauru...   Aug 29 2006, 05:49 PM
walts   I'm looking for help getting an Ambicom WL54-C...   Jul 7 2006, 09:57 AM
Da_Blitz   from a quick google (note the quick, ie may be wro...   Jul 7 2006, 10:03 PM
walts   QUOTE(Da_Blitz @ Jul 8 2006, 06:03 AM)from a ...   Jul 10 2006, 07:28 AM
Da_Blitz   the point is that none of them work we are tryin...   Aug 30 2006, 05:38 AM
zthird   you might want to look here http://projects.linuxt...   Apr 3 2009, 02:50 PM

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 26th May 2018 - 06:29 PM