OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> sync issues, Qtopia Desktop & Debian
post Jan 18 2004, 08:35 PM
Post #1

Group: Members
Posts: 2
Joined: 17-January 04
Member No.: 1,449

I have debian woody and am trying to get Qtopia Desktop to sync with
my Zaurus SL-5500 (2.38 ROM)

I downloaded qtopia-desktop-1.6.2-1.i386.rpm from the trolltech
website, converted it to a .deb (with alien) and installed it. It ran
with a few glitches:

initEnvironment() Invalid TimeZone (null)
init day
TimeZone::current Location information is not set in the Config file locale!
QPopupMenu: (in-combo) Popup has invalid menu item
Network operation (get) failed for url: http://qtopia.net/packages/Packages

But the real problem is that it will not sync.

All the options on the Sync Menu are grayed out. When it start the
prompt line says "Trying to connect to the PDA", but nothing happens
except a little network traffic:

14:22:29.911205 >
S 3437845469:3437845469(0) win 5840 <mss 1460,sackOK,timestamp
9236340 0, nop,wscale 0> (DF)
14:22:29.912306 >
S 2898563305:2898563305(0) ack 3437845470 win 5792 <mss 1460,
sackOK,timestamp 5043712 9236340,nop,wscale 0> (DF)
14:22:29.912422 >
. ack 1 win 5840 <nop,nop,timestamp 9236340 5043712> (DF)
14:22:30.051323 >
F 1:1(0) ack 1 win 5792 <nop,nop,timestamp 5043726 9236340> (DF)
14:22:30.053301 >
F 1:1(0) ack 2 win 5840 <nop,nop,timestamp 9236354 5043726> (DF)
14:22:30.054312 >
. ack 2 win 5792 <nop,nop,timestamp 5043726 9236354> (DF)

There is no data being passed here and the connection is closed as
soon as it is opened! This network traffic repeats every few seconds
as long as Qtopia Desktop is running.

My computer is connected to the 5500 via USB and I have tried running
Qtopia Desktop with and without a LAN configured between the two.
With the LAN up I can telnet to the 5500 and the 5500 can browse the

I read the HOWTO and FAQ on syncing but nothing seemed to address my

I found previous forum posts complaining of nosync with debian:

one post said this:
if you are running the Sharp rom that uses a db for pim data, the Qtopia
Desktop available from Trollech won?t work. You will have to use the
Qtopia Desktop available from Sharp.

I am running 2.3.8 ROM and I don't believe that is is the rom that
uses a db for pin data. Am I right about that??

another post said this:
Also check the security, you might be forcing it to only accept a
certain ip address instead of "any". I found that a big help from
Deisel in another post.

Ahh what, where is 'security'? /etc/hosts.allow? /etc/hosts.deny?
iptables? security setting internal to Qtopia Desktop? Any clue
would be appreciated.

and there were several other posts about syncing problems with linux.

Is there an alternative to the Qtopia Desktop? Would I have to change
my ROM? Change apps on the 5500?

Later... after more investigations:

# netstat -anp
tcp 0 0* LISTEN 207/qpe
tcp 0 0* LISTEN 144/rpc.portmap
tcp 0 0* LISTEN 207/qpe
tcp 0 0* LISTEN 207/qpe
tcp 0 0* LISTEN 134/inetd
tcp 0 0* LISTEN 134/inetd
udp 0 0* 18499/dhcpd
udp 0 0* 144/rpc.portmap
raw 0 0* 7 18499/dhcpd

# ps fax
90 ? S 0:00 /sbin/sdmgr
123 ? S 0:00 /sbin/cardmgr
134 ? S 0:00 /usr/sbin/inetd
144 ? S 0:00 /usr/sbin/rpc.portmap
155 ? S 0:00 /home/QtPalmtop/bin/atd /var/spool/at
186 ? S 0:00 /sbin/launch
204 ? S 0:00 _ /bin/sh ./qpe.sh
207 ? SN 2:43 _ qpe
10570 ? SN 0:02 _ addressbook -qcop /tmp/qcop-msg-addressbook
10571 ? SN 0:07 _ datebook -qcop /tmp/qcop-msg-datebook
10572 ? SN 0:08 _ todolist -qcop /tmp/qcop-msg-todolist
188 ? S 0:03 /sbin/shsync
18499 ? SN 0:00 /usr/sbin/dhcpd -cf /etc/hotplug/dhcpcd.conf -lf
/var/state/dhcp/dhcpd-usbd0.leases -pf
/var/run/dhcpd-usbd0.pid usbd0
(Note that pesky dhcpd which should NOT be running!)

==> qpe is listening on the port to which Qtopia Desktop tries to establish
a connection.

I tried telneting to that port and got this:

[root]# telnet 4243
Connected to zaurus (
Escape character is '^]'.
Connection closed by foreign host.

Except for one extra ack a tcpdump of that little session looked exactly
like the traffic when Qtopia Desktop tries talking to Zaurus.

==> qpe is dropping the connection, but why?

The connection is dropped immediately so it can't be for a bad
username or password, the only thing qpe knows about the connection is
the IP number so it is what I would expect if my linux box was in the
Zaurus /etc/hosts.deny or not listed in /etc/hosts.allow. But I found
no /etc/hosts.allow or /etc/host.deny file.

A forum post suggested checking security but but my Settings->Security
menu only allows me to set a password which may be required at
power-on and has no settings for hosts allowed to sync.

What can I do to fix this problem??


PS Sorry about the double spacing, I added < p r e > to get the indentations
Go to the top of the page
+Quote Post
post Jan 20 2004, 02:06 PM
Post #2

Group: Members
Posts: 1
Joined: 20-January 04
Member No.: 1,490

I am on Debian (sid). No configuration made and the Qtopia (qtopia-desktop-1.7.0-1rh9.i386.rpm) converted as a deb package (qtopia-desktop_1.7.0-2_i386.deb) works just fine.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 28th May 2018 - 12:15 AM