OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Dualboot Idiot Guide, Cacko 1.22 w/ pdaXrom 1.0.0
post Apr 21 2005, 12:56 PM
Post #1

Group: Members
Posts: 51
Joined: 15-March 04
Member No.: 2,316

For those who want to stick with Cacko 1.22 but also want to have a taste on pdaXrom without touching NAND or whatsoever (It's me tongue.gif ), here are some sharings on how I dualboot my Zaurus C760.

Firstly, for sure, you need to have Cacko 1.22 with hotfix installed: Get Cacko here

Secondly, get an ext2 or ext3 formatted SD card. To obtain, simply follow this guide: Step-by-step CF/SD fdisk/formatting for newbies. Remember to unplug and plug the SD again to remount.

Then, download the scripts required: Dual_C760.zip. Unzip and place them on the machine, for instance, I place all the extracted files at /home/zaurus/Documents

Download the pdaXrom tarball: either pdaX-SD.tar.gz or pdaX-1.0.5-SD.tar.gz. I am not sure whether the latter is the real 1.0.5. Let's pick this one.

Transfer and extract the tarball to the root of SD card. To do this, you need to have gtar installed in order to let the system understand the "p" flag to preserve permissions, the gtar package is included in Dual_C760.zip:

$ su
# ipkg install /home/zaurus/gtar_1.13.25-1_arm.ipk
# cd /mnt/card/
# gtar -zxvpf pdaX-1.0.5-SD.tar.gz

Next, follow these steps:

# mount -o rw,remount /
# mkdir /sbin/sys
# cp /sbin/init /sbin/sys/init
# rm /sbin/init
# cp /home/zaurus/init /sbin/init
# cp /home/zaurus/pivot_root /sbin/pivot_root
# chmod +x /sbin/init
# chmod +x /sbin/pivot_root

Since there are changes on the filesystem in Cacko 1.22, line 12 in the /sbin/init script needs to be altered:

mount -n -r -t cramfs /boot/usr.bin /usr -o loop


mount -n -r -t squashfs /boot/usr.bin /usr -o loop

I also attached the modified /sbin/init script, for the sake of convenience.

It's nearly the end, remount / as read-only and reboot:

# mount -o ro,remount /
# reboot

Your Zaurus should now boot into pdaXrom with SD plugged in, and boot into Cacko otherwise. When booted into pdaXrom, login as root and issue startx.

Although this guide may looks idiot, like me, I did put a hard effort on dualbooting my Z (Stu should know, Many thanks biggrin.gif ). I hope someone can benefit from it. Corrections and suggestions are welcome.
Attached File(s)
Attached File  init.zip ( 496bytes ) Number of downloads: 324
Attached File  Dual_C760.zip ( 68.84K ) Number of downloads: 1939
Go to the top of the page
+Quote Post
Start new topic
post Apr 21 2005, 10:06 PM
Post #2

Group: Members
Posts: 9
Joined: 17-April 05
Member No.: 6,906

Thanks for your guide!

I want to know where is the pivot_root located, as it does not exists in Dual_C760.zip

Thanks alot

QUOTE(penguinsam @ Apr 21 2005, 12:56 PM)
# mount -o rw,remount /
# mkdir /sbin/sys
# cp /sbin/init /sbin/sys/init
# rm /sbin/init
# cp /home/zaurus/init /sbin/init
# cp /home/zaurus/pivot_root /sbin/pivot_root
# chmod +x /sbin/init
# chmod +x /sbin/pivot_root
Go to the top of the page
+Quote Post

Posts in this topic
penguinsam   Dualboot Idiot Guide   Apr 21 2005, 12:56 PM
numeric   Thanks for your guide! I want to know where ...   Apr 21 2005, 10:06 PM
penguinsam   Sorry I linked the wrong file and have updated. Pl...   Apr 22 2005, 12:16 AM
ScottYelich   http://zaurus.spy.org/feeds/cacko/pdaXrom/dual-boo...   Apr 22 2005, 08:29 AM
offroadgeek   This seems really cool, but I'm wondering how ...   Apr 22 2005, 08:55 AM
ScottYelich   well, it's load time... I don't mind load ...   Apr 22 2005, 09:18 AM
penguinsam   QUOTE(ScottYelich @ Apr 23 2005, 01:18 AM)wel...   Apr 22 2005, 11:02 PM
numeric   I run pdaxrom on SD now, however the mouse pointer...   Apr 24 2005, 10:48 PM
penguinsam   QUOTE(numeric @ Apr 25 2005, 02:48 PM)I run p...   Apr 25 2005, 12:47 AM
penguinsam   Rather than the mouse pointer offset issue pointed...   Apr 25 2005, 06:31 AM
numeric   Yap, me too. Got exactly the same problem under CA...   Apr 25 2005, 05:25 PM
numeric   And one more problem. I found out that the battery...   Apr 25 2005, 05:30 PM
penguinsam   QUOTE(numeric @ Apr 26 2005, 09:30 AM)And one...   Apr 26 2005, 08:33 PM
omro   Would this work on a C1000 with the stock Sharp RO...   Jun 20 2005, 02:20 AM
omro   Hi there, I'm hoping this will work with my C1...   Jun 23 2005, 12:18 AM
pgas   QUOTEthe gtar package is included in Dual_C760.zip   Jun 23 2005, 12:26 AM
omro   Yup, I spotted that in the end, I'd not unzipp...   Jun 23 2005, 01:25 AM
erikqwerty   Hey! Could anybody tell me how I can use a CF ...   Jul 1 2005, 04:57 PM
erikqwerty   QUOTE(erikqwerty @ Jul 2 2005, 12:57 AM)Hey...   Jul 2 2005, 08:56 AM
wjping119   QUOTE(erikqwerty @ Jul 2 2005, 12:57 AM)Hey...   Mar 4 2006, 02:17 AM
ferdinauta   Is it possible to do the dualboot with PdaXRom RC1...   Mar 3 2006, 05:02 AM
law   QUOTE(ferdinauta @ Mar 3 2006, 05:02 AM)Is it...   Mar 3 2006, 05:19 AM
ferdinauta   QUOTE(law @ Mar 3 2006, 02:19 PM)QUOTE(ferdin...   Mar 3 2006, 07:15 AM
gab74   is it possible to install PDAXROM on the microdriv...   Mar 8 2006, 12:21 PM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 22nd June 2018 - 10:45 PM