OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> How-TO: Connet CF GPRS/GSM (AudioVox RTM8000) to internet
post Jan 30 2004, 08:15 AM
Post #1

Group: Members
Posts: 45
Joined: 30-January 04
Member No.: 1,617

(Updated with less steps)

Hi folks,

I finally managed to get my Audiovox RTM8000 GPRS/GSM CF card to connect to the internet. I do have a Wi-Fi card, but I need to connect sometime when I'm not at a hot-spot, so this is an ideal solution for my needs.

My setup:

Sharp Zaurus SL-C760
Using Sash ROM (but a default ROM should work, as the Sash ROM gave me the same errors as the Sharp ROM, the bad Vcc error)
Audiovox RTM8000 GPRS/GSM compact flash card

GPRS/GSM provider: Fido www.fido.ca in Canada
Plan: data only, no voice. CDN$50, unlimited data

Fido network settings: (Note these, so you can replace with your own provider settings
APN: internet.fido.ca
User name: fido
Password: fido
DNS: none
IP: none

Fido simply asks for your smart card number, and the MEI number (from the bottom of your modem), and sets you up (activate)


Note: You can download a gzip file containing serial_cs.o and sample scripys from here:


Steps 1 and 2 are not required if you are using the Cacko Qtopia 1.2 ROM, as it contains the proper serial_cs module http://www.zaurususergroup.com/index.php?n...iewtopic&t=2232

Step 1.Download serial_cs.o driver. One place that has it available for download:


Step 2 Copy the serial_cs.o to the modules directory:



depmod -a
modprobe serial_cs

Step 3 edit the file /etc/pcmcia/serial.opts and set:

SERIAL_OPTS="uart 16550A"

Step 4 Insert the Audiovox RTM8000 card

Step 5A. Use the network setup application to create a dial-up PPP connection . Simply launch the network setup, select Dial-up PPP from the frop down menu. Click Add, Select, and enter the following information (Images of the screen attached below):

In the Account tab, enter any name, and in the user name and password fields, enter the username and password provided by your GPRS provider. In the phone number field, enter *99#

In the Modem tab screen (image provided below), enter the following modem init string:


Simply replace "internet.fido.ca" with the APN for your GPRS provider.

Click "OK", and thin click "Connect".

That's it, you're done! The following steps are only required for debug, if the above didn't work

Step 5B Go to the directory /etc/ppp/peers

Create 3 files as follows

a. gprs (replace "fido" with your username)
# the two lines below help debugging, delete when things work fine

debug debug debug


# end debug




connect /etc/ppp/peers/connectgprs

user fido



mru 1500

mru 1500







disconnect /etc/ppp/peers/disconnectgprs


And second file, connectgprs (replace "internet.fido.ca with your provider's APN) Note, make sure you use tabs in editing this file, if you need a template use an original file from the links at the bottom, or wget http://kotinetti.suomi.net/mcfrisk/gprs-connect-chat and make the appropriate edits from this code:

exec /usr/sbin/chat -sVS

       TIMEOUT         5                              

       ECHO            ON                              

       ABORT           'nBUSYr'                      

       ABORT           'nERRORr'                    

       ABORT           'nNO ANSWERr'                

       ABORT           'nNO CARRIERr'                

       ABORT           'nNO DIALTONEr'              

       ABORT           'nRINGINGrnrnRINGINGr'    

       ''              rAT                            

       TIMEOUT         12                              

       SAY             "Press CTRL-C to close the connection at any stage!"


       SAY             "ndefining PDP context...n"  

       OK              ATH                            

       OK              ATE0V1                            

       OK              'AT+CGDCONT=1,"IP","internet.fido.ca","",0,0'  

       OK              ATD*99#                        

       TIMEOUT         22                              

       SAY             "nwaiting for connect...n"    

       CONNECT         ""                              

       SAY             "nConnected."

       SAY             "nIf the following ppp negotiations fail,n"  

       SAY             "try restarting the phone.n"

And last file, disconnectgprs
exec /usr/sbin/chat -s -V -S

"" "K"

"" "+++ATH"

Step 6 go to the directory /etc/ppp

edit the file chap-secrets

Add a line to insert your username and password, in my case fido and fido:

fido [tab] * [tab] "fido"

Step 7 Make sure your card is ready, type:

cardctl status

if it shows "suspended", then (only if it is suspended, otherwise skip this step) type:

cardctl resume

Step 8 Now the good part smile.gif To connect, go to /etc/ppp/peers and type:

pppd calll gprs

That should do it!

Step 9 If you want to have the connect/disconnect through the GUI network setting application, simply create a modem connection with username/password and phone number as *99#, then click o.k. (tip: you can enter an accelerator proxy here, if your provider offers one).

Then copy the gprs script to override the generated Zaurus script.

cd /etc/ppp/peers
cp grps DIALUP*

Where DIALUP1234 (or any number) is the one created by the zaurus network app.

Note: Do not edit the connection from the Network setup menu, it will overwrite your connection script

Connection output
Removed stale lock on ttyS3 (pid 4133)

Press CTRL-C to close the connection at any stage!^M

defining PDP context...








waiting for connect...




If the following ppp negotiations fail,

^Mtry restarting the phone.


Serial connection established.

using channel 5

Using interface ppp0

Connect: ppp0 <--> /dev/ttyS3

sent [LCP ConfReq id=0x1 <asyncmap 0x0> <pcomp> <accomp>]

Timeout 0x20084bc:0x203b440 in 3 seconds.

rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <pcomp> <accomp>]

rcvd [LCP ConfReq id=0x1 <auth pap> <pcomp> <accomp>]

lcp_reqci: returning CONFACK.

sent [LCP ConfAck id=0x1 <auth pap> <pcomp> <accomp>]

Untimeout 0x20084bc:0x203b440.

sent [PAP AuthReq id=0x1 user="fido" password="fido"]

Timeout 0x200ebbc:0x203b6e0 in 3 seconds.

rcvd [PAP AuthAck id=0x1 ""]

sent [IPCP ConfReq id=0x1 <addr> <ms-dns1> <ms-dns3>]

Timeout 0x20084bc:0x203b6a0 in 3 seconds.

sent [CCP ConfReq id=0x1 <bsd v1 15>]

Timeout 0x20084bc:0x203b7a0 in 3 seconds.

rcvd [LCP ProtRej id=0x1 80 fd 01 01 00 07 15 03 2f]

Untimeout 0x20084bc:0x203b7a0.

sent [IPCP ConfReq id=0x1 <addr> <ms-dns1> <ms-dns3>]

Timeout 0x20084bc:0x203b6a0 in 3 seconds.

rcvd [IPCP ConfReq id=0x1 <addr>]

ipcp: returning Configure-NAK

sent [IPCP ConfNak id=0x1 <addr>]

rcvd [IPCP ConfReq id=0x2 <addr>]

ipcp: returning Configure-NAK

sent [IPCP ConfNak id=0x2 <addr>]

rcvd [IPCP ConfReq id=0x3 <addr>]

ipcp: returning Configure-NAK

sent [IPCP ConfNak id=0x3 <addr>]

rcvd [IPCP ConfReq id=0x4 <addr>]

ipcp: returning Configure-NAK

sent [IPCP ConfNak id=0x4 <addr>]

rcvd [IPCP ConfReq id=0x5 <addr>]

ipcp: returning Configure-NAK

sent [IPCP ConfNak id=0x5 <addr>]

rcvd [IPCP ConfReq id=0x6 <addr>]

ipcp: returning Configure-REJ

sent [IPCP ConfRej id=0x6 <addr>]

rcvd [IPCP ConfReq id=0x7]

ipcp: returning Configure-ACK

sent [IPCP ConfAck id=0x7]

sent [IPCP ConfReq id=0x1 <addr> <ms-dns1> <ms-dns3>]

Timeout 0x20084bc:0x203b6a0 in 3 seconds.

rcvd [IPCP ConfNak id=0x1 <addr> <ms-dns1> <ms-dns3

Untimeout 0x20084bc:0x203b6a0.

sent [IPCP ConfReq id=0x2 <addr> <ms-dns1> <ms-dns3

Timeout 0x20084bc:0x203b6a0 in 3 seconds.

rcvd [IPCP ConfAck id=0x2 <addr> <ms-dns1> <ms-dns3

Untimeout 0x20084bc:0x203b6a0.

ipcp: up

local  IP address 205.151.xxx.xxx

remote IP address

primary   DNS address

secondary DNS address

Script /etc/ppp/ip-up started (pid 4181)

Script /etc/ppp/ip-up finished (pid 4181), status = 0x0


Finally, this is a really quick how-to, as I've just connected right now, and thought I'd list all the info before I forget.

Try it out, and hopefully it will work for you too. If not, post here, and we'll try to sort out the problem.

Resources: I found the following info below helpful. I had to make adjustments, and after several trials and errors (4 days) it finally worked. I will list the links, just in case they help you, if my info doesn't work in your case:


Tips from members (copied from the devboard which has been shutdown)

1. Using voice GSM.
From: datatedy   
Posted: Sep 10 2003, 01:06 AM

BTW: If you ever like to use you card as a phone try this:

atd 001 212 123 4567;

The pin needs to be the pin of your sim card (PIN1). The semikolon after the telephone nunber is important. Otherwise you will try to make a data call.


2. List of international GPRS providers
I found this link, which lists many global GPRS providers:

Go to the top of the page
+Quote Post
Start new topic
post Apr 20 2004, 06:19 PM
Post #2

Group: Members
Posts: 2
Joined: 18-April 04
Member No.: 2,903

I have used this /" and cardctl resume, but still got the same error message like before. Any suggestion on where I should start checking?
Go to the top of the page
+Quote Post

Posts in this topic
tamarian   How-TO: Connet CF GPRS/GSM (AudioVox RTM8000) to internet   Jan 30 2004, 08:15 AM
tamarian   serial_cs.o and sample 3 gprs scripts were uploade...   Feb 7 2004, 12:40 PM
tamarian   Major update 1. You no longer need the serial_cs...   Mar 13 2004, 06:06 PM
NHT   I have difficulty in making my AudioVox GPRS card ...   Apr 18 2004, 10:57 PM
tamarian   QUOTEI just need to specify phone number=*99# and ...   Apr 19 2004, 09:27 AM
NHT   I have used this /" and cardctl resume, but still ...   Apr 20 2004, 06:19 PM
maslovsky   QUOTEI have used this /" and cardctl resume, but s...   May 4 2004, 05:09 AM
ZeeUser   Tamarian: Thanks for the how-to! It was instrument...   May 7 2004, 05:36 AM
cs_jacky   "My Z specifically had to be in suspend mode befor...   May 27 2004, 06:18 AM
maslovsky   QUOTE"My Z specifically had to be in suspend mode ...   May 27 2004, 07:58 AM
roguetrooper   I am trying to get the AudioVox card working (I ha...   Jun 11 2004, 11:50 PM
maslovsky   QUOTEI am trying to get the AudioVox card working ...   Jun 15 2004, 07:35 AM
roguetrooper   See you early next week   Jun 17 2004, 09:26 PM
Stefani   I have tried to bring up my new RTM8000 Card. Now ...   Aug 26 2004, 06:27 PM
ludovicus   my cf audiovox card is coming in the mail, if ther...   Nov 11 2004, 02:08 AM
cherubina   if i try to use the gui to dial i get connection f...   Dec 11 2004, 09:08 PM
tg   QUOTE(cherubina @ Dec 12 2004, 12:08 AM)if i ...   Dec 13 2004, 06:56 AM
cherubina   Thanks tg - you've saved me many hours of frus...   Dec 13 2004, 05:26 PM
tg   Happy to see that worked for you. And I want to th...   Dec 13 2004, 06:50 PM
ludovicus   Hello fellow Z, Tmobile, RTM-8000 users!! ...   Dec 23 2004, 10:59 PM
guylhem   I do - I have the very same ziplink cable. Works l...   Dec 27 2004, 11:12 AM
cherubina   thanks for the info ludovicus (my cat louie ate th...   Jan 3 2005, 10:59 AM
cherubina   well I guess I should have looked things up a litt...   Jan 5 2005, 09:54 PM
steliosx   hello - I bought an Ambicom GPRS CF card, are the ...   May 10 2005, 05:08 AM
mingerz   [quote=steliosx,May 10 2005, 02:08 PM] hello - I b...   May 20 2005, 02:07 PM
Asteroid   [quote=ludovicus,Dec 24 2004, 07:59 PM] Hello fell...   Jun 10 2005, 08:35 PM
interstate80   I have the Zaurus C3000 and the Audiovox RTM8000.....   Jun 29 2005, 08:08 PM
interstate80   Okay so I realized that I needed to make the conne...   Jun 29 2005, 10:56 PM
speculatrix   I tried it using the cacko wizard and it just didn...   Jul 21 2005, 01:34 PM
ensign   QUOTE(speculatrix @ Jul 21 2005, 09:34 PM)I u...   Jul 22 2005, 09:46 AM
jrj   Hi All, I use the AudioVox RTM-8000D GPRS card on...   Jul 23 2005, 09:08 PM
speculatrix   QUOTE(jrj @ Jul 24 2005, 06:08 AM)I'm now...   Jul 24 2005, 12:38 PM
jrj   QUOTE(speculatrix @ Jul 24 2005, 12:38 PM)It ...   Jul 24 2005, 05:16 PM
gustav1888   Hi all, i have an audiovox rtm 8000 that works on ...   Aug 12 2005, 07:42 AM
speculatrix   basically, the gsm/gprs modem behaves like any oth...   Aug 12 2005, 07:55 AM
gustav1888   QUOTE(speculatrix @ Aug 12 2005, 04:55 PM)bas...   Aug 13 2005, 12:49 AM
gustav1888   Solved! For some reason, when connecting using...   Aug 14 2005, 04:10 AM
Lancillotto   Hello to everybody! I solved all my past prob...   Nov 23 2005, 02:07 AM
dhns   QUOTE(Lancillotto @ Nov 23 2005, 11:07 AM)Hel...   Nov 24 2005, 02:34 AM
Lancillotto   Thanks for your answer. I tried It but with no su...   Nov 24 2005, 02:41 AM
dhns   QUOTE(Lancillotto @ Nov 24 2005, 11:41 AM)Tha...   Nov 24 2005, 04:03 AM
Lancillotto   QUOTE(dhns @ Nov 24 2005, 04:03 AM)QUOTE(Lanc...   Nov 29 2005, 01:41 AM
dhns   QUOTE(Lancillotto @ Nov 29 2005, 10:41 AM)I d...   Nov 29 2005, 12:04 PM
Ferret-Simpson   hmmm. . . I'm uing the Ambicom card (Actually ...   Jan 3 2006, 02:00 PM
speculatrix   QUOTE(Ferret-Simpson @ Jan 3 2006, 11:00...   Jan 3 2006, 02:13 PM
gummy_bear   Hi all, I know this thread is old but i am desper...   Jan 15 2007, 05:54 PM
zmiq2   I think that the seerial_cs.o module you got from ...   Jan 15 2007, 06:26 PM
gummy_bear   ok so it is all down to 8250.ko module, it needs t...   Jan 16 2007, 05:49 AM
speculatrix   yeah, I would agree that it sounds like a module m...   Jan 16 2007, 03:41 AM
zmiq2   Hi, I'd suggest 1) ask someone in a gumstix ...   Jan 16 2007, 07:34 AM
Viss   This doesnt work for me, but I found this article ...   Feb 8 2009, 02:01 PM

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 26th May 2018 - 02:18 AM